Perf data for linux VMs is not showing up in LA workspace

%3CLINGO-SUB%20id%3D%22lingo-sub-1320378%22%20slang%3D%22en-US%22%3EPerf%20data%20for%20linux%20VMs%20is%20not%20showing%20up%20in%20LA%20workspace%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1320378%22%20slang%3D%22en-US%22%3E%3CP%3EHello%20Experts%2C%3C%2FP%3E%3CP%3ENeed%20assistance%20!!!%3C%2FP%3E%3CP%3EWe%20have%20created%20a%20new%20LA%20workspce%20and%20onboarded%20agents.%20But%20Perf%20data%20is%20not%20being%20ingested%20for%20linux%20agents%20even%20after%20enabling%20the%20counters%20from%20advanced%20settings%20in%20LA%20console%20though%20agents%20looks%20healthy%20and%20recieving%20heartbeat%20data%20!!!!%3C%2FP%3E%3CP%3EThanks%20in%20Adavance.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1320378%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F73893%22%20target%3D%22_blank%22%3E%40azure%3C%2FA%3E%20Log%20Analytics%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1324797%22%20slang%3D%22en-US%22%3ERe%3A%20Perf%20data%20for%20linux%20VMs%20is%20not%20showing%20up%20in%20LA%20workspace%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1324797%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F612787%22%20target%3D%22_blank%22%3E%40Ashok42%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3COL%3E%0A%3CLI%3EAre%20you%20sure%20you%20configured%20Linux%20Perf%20collection%20settings%20in%20LA%20and%20not%20just%20Windows%20Perf%3F%3C%2FLI%3E%0A%3CLI%3EHave%20you%20tried%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fazure-monitor%2Fplatform%2Fagent-linux-troubleshoot%23issue-when-configuring-collection-from-the-portal-for-syslog-or-linux-performance-counters-the-settings-are-not-applied%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ethese%20troubleshooting%20steps%3C%2FA%3E%3F%3C%2FLI%3E%0A%3C%2FOL%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1327297%22%20slang%3D%22en-US%22%3ERe%3A%20Perf%20data%20for%20linux%20VMs%20is%20not%20showing%20up%20in%20LA%20workspace%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1327297%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F453722%22%20target%3D%22_blank%22%3E%40hspinto%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EYes%20linux%20counters%20were%20enabled%20in%20LA%20workspace.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Ashok42_0-1587530036766.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F185809i77174A28311E3A32%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22Ashok42_0-1587530036766.png%22%20alt%3D%22Ashok42_0-1587530036766.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3ETried%20the%20troubleshooting%20steps%20as%20well.%3C%2FP%3E%3CP%3EPoint%20to%20note%20is%2C%20none%20of%20the%20linux%20agent%20data%20hasn't%20been%20ingested%20so%20far%20since%20the%20initial%20set%20of%20the%20environment%20except%20heartbeat%20data.%3C%2FP%3E%3CP%3EDoes%20perf%20data%20need%20a%20seperate%20set%20of%20firewalls%20to%20be%20opened%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1327689%22%20slang%3D%22en-US%22%3ERe%3A%20Perf%20data%20for%20linux%20VMs%20is%20not%20showing%20up%20in%20LA%20workspace%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1327689%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F612787%22%20target%3D%22_blank%22%3E%40Ashok42%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EAll%20data%20coming%20from%20the%20agent%20to%20LA%20goes%20through%20HTTPS%20(port%20443).%20It%20must%20not%20be%20a%20communications%20issue%2C%20but%20rather%20an%20agent%20setup%20issue.%20Is%20the%20OS%20distribution%20supported%20(%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fazure-monitor%2Fplatform%2Flog-analytics-agent%23supported-linux-operating-systems%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Esee%20list%20here%3C%2FA%3E)%3F%20Have%20you%20tried%20re-onboarding%20the%20agent%3F%26nbsp%3BYou%20can%20also%20try%20other%20troubleshooting%20steps%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fazure-monitor%2Fplatform%2Fagent-linux-troubleshoot%23issue-you-are-not-seeing-any-linux-data%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehere%3C%2FA%3E.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1398492%22%20slang%3D%22en-US%22%3ERe%3A%20Perf%20data%20for%20linux%20VMs%20is%20not%20showing%20up%20in%20LA%20workspace%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1398492%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F453722%22%20target%3D%22_blank%22%3E%40hspinto%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIssue%20is%20resolved.%20It%20was%20missing%20one%20of%20the%20network%20requirement%20to%20open%20port%20443%20against%26nbsp%3B%3CSTRONG%3E*.azure-automation.net%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3EAfter%20firewall%20configuration%20is%20setup%2C%20linux%20perf%20logs%20started%20showing%20up.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Contributor

Hello Experts,

Need assistance !!!

We have created a new LA workspce and onboarded agents. But Perf data is not being ingested for linux agents even after enabling the counters from advanced settings in LA console though agents looks healthy and recieving heartbeat data !!!!

Thanks in Adavance.

 

4 Replies
Highlighted

@Ashok42 

 

  1. Are you sure you configured Linux Perf collection settings in LA and not just Windows Perf?
  2. Have you tried these troubleshooting steps?
Highlighted

@hspinto 

Yes linux counters were enabled in LA workspace.

 

Ashok42_0-1587530036766.png

Tried the troubleshooting steps as well.

Point to note is, none of the linux agent data hasn't been ingested so far since the initial set of the environment except heartbeat data.

Does perf data need a seperate set of firewalls to be opened?

Highlighted

@Ashok42 

 

All data coming from the agent to LA goes through HTTPS (port 443). It must not be a communications issue, but rather an agent setup issue. Is the OS distribution supported (see list here)? Have you tried re-onboarding the agent? You can also try other troubleshooting steps here.

Highlighted

@hspinto 

 

Issue is resolved. It was missing one of the network requirement to open port 443 against *.azure-automation.net

After firewall configuration is setup, linux perf logs started showing up.