Application Insights Logs

%3CLINGO-SUB%20id%3D%22lingo-sub-575409%22%20slang%3D%22en-US%22%3EApplication%20Insights%20Logs%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-575409%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3EI%20am%20new%20to%20Azure%20Portal%20and%20managing%20an%20app%20service%20for%20a%20business%20application.%20I%20have%20a%20webjob%20associated%20with%20it.%20My%20questions%20is%20that%20I%20am%20getting%20System.ArgumentNullException%20every%20minute%20on%20my%20Logs.%20I%20believe%20it%20is%20coming%20from%20my%20webjob%2C%20but%20I%20am%20finding%20that%20tracing%20down%20the%20source%20of%20these%20messages%20is%20extremely%20difficult.%20When%20I%20run%20my%20app%2C%20it%20runs%20with%20no%20problem%20and%20my%20webjobs%20running%20and%20doing%20its%20job%20with%20no%20problem.%20Any%20suggestions%20on%20where%20to%20start.%3CBR%20%2F%3EAlso%2C%20on%20the%20Applications%20Insights%20overview%2C%20my%20default%20graphs%20are%20Failed%20Requests%20and%20Server%20Requests.%20Although%20I%20have%20no%20reported%20problems%2C%20half%20of%20my%20server%20requests%20(30)%20show%20failed%20(15)%20at%20any%20given%20time.%20Just%20need%20kickstarted%20how%20I%20can%20analyze%20some%20of%20these%20tools%20so%20I%20can%20ultimately%20make%20my%20code%20more%20efficient%20to%20eliminate%20these%20alerts%2Fwarnings.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-575409%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EApplication%20Insights%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EAzure%20Log%20Analytics%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-575459%22%20slang%3D%22en-US%22%3ERe%3A%20Application%20Insights%20Logs%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-575459%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20another%20screenshot%20where%20I%20am%20trying%20to%20figure%20out%20my%20failed%20requests.%20Not%20even%20sure%20why%20I%20am%20having%20these.%20Thanks.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

Hi,

I am new to Azure Portal and managing an app service for a business application. I have a webjob associated with it. My questions is that I am getting System.ArgumentNullException every minute on my Logs. I believe it is coming from my webjob, but I am finding that tracing down the source of these messages is extremely difficult. When I run my app, it runs with no problem and my webjobs running and doing its job with no problem. Any suggestions on where to start.
Also, on the Applications Insights overview, my default graphs are Failed Requests and Server Requests. Although I have no reported problems, half of my server requests (30) show failed (15) at any given time. Just need kickstarted how I can analyze some of these tools so I can ultimately make my code more efficient to eliminate these alerts/warnings.  

1 Reply
Highlighted

I have another screenshot where I am trying to figure out my failed requests. Not even sure why I am having these. Thanks.