App Insights: Telemetry not showing User data

%3CLINGO-SUB%20id%3D%22lingo-sub-805502%22%20slang%3D%22en-US%22%3EApp%20Insights%3A%20Telemetry%20not%20showing%20User%20data%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-805502%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20my%20.Net%20Core%20app%20and%20I've%20added%26nbsp%3BITelemetryInitializer%20and%20got%20that%20all%20set%20up.%20In%20Application%20Insights%20for%20that%20app%2C%20under%20Performance%20%3D%26gt%3B%20Operation%20Name%20%3D%26gt%3B%20Samples%20%3D%26gt%3B%20Suggested%20%3D%26gt%3B%20Request%20Properties%20-%26gt%3B%20Show%20All%20%3D%26gt%3B%20%22Auth%20Id%22%20and%20%22Account%20Id%22%20have%20values%20now%2C%20great.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENow%2C%20in%20Application%20Insights%20%3D%26gt%3B%20Users%2C%20I%20still%20only%20have%201%20User.%20How%20do%20I%20get%20the%20Usage%2FUsers%20functionality%20to%20read%20the%20User%20information%20that%20the%20requests%20under%20performance%20are%20collecting%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20read%20lots%20of%20MSFT%20documentation%20on%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fazure-monitor%2Fapp%2Fusage-send-user-context%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3ESend%20User%20Context%3C%2FA%3E%26nbsp%3Band%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fazure-monitor%2Fapp%2Fusage-troubleshoot%23counting-users%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Etroubleshooting%3C%2FA%3E%2C%20but%20no%20luck.%20It%20seems%20like%20if%20I%20have%20%22%3CSPAN%3Eanonymous%20user%20ID%2C%20authenticated%20user%20ID%2C%20or%20session%20ID%22%20in%20the%20Request%20Properties%2C%20the%20Usage%20telemetry%20should%20be%20picking%20it%20up.%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20suggestions%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-805502%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EApplication%20Insights%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Highlighted
Visitor

Hello,

 

I have my .Net Core app and I've added ITelemetryInitializer and got that all set up. In Application Insights for that app, under Performance => Operation Name => Samples => Suggested => Request Properties -> Show All => "Auth Id" and "Account Id" have values now, great.

 

Now, in Application Insights => Users, I still only have 1 User. How do I get the Usage/Users functionality to read the User information that the requests under performance are collecting?

 

I've read lots of MSFT documentation on Send User Context and troubleshooting, but no luck. It seems like if I have "anonymous user ID, authenticated user ID, or session ID" in the Request Properties, the Usage telemetry should be picking it up. 

 

Any suggestions?