SOLVED

Publishing a self-hosted pipeline on MacOS with dotnet issues

New Contributor

I've been interested in DevOps for a while and finally went around to do some courses on it. I found a nice one that I have been following, but I've recently run into some issues.

 

This course is the one I've been following, the specific step I'm running into issues with is unit 7/10. I did not have any agents available when starting out the course, so I've opted to host the agent and thus jobs locally. This also had some issues with it, but currently it seems to work just fine. I was able to get jobs to be executed and it all works nicely. However, when I tried the following step, publishing using dotnet, I seem to be getting errors.

 

Specifically, I'm getting errors about 'The process .../myagent/_work/_tool/dotnet/dotnet failed with exit code 1', as well as an error that 'Dotnet command failed with non-zero exit code on the following projects: .../myagent/_work/1/s/Tailspin.SpaceGame.Web/Tailspin.SpaceGame.Web.csproj'.

 

The course itself does a good job of explaining the concepts, but with the above errors I feel like I'm somewhat stuck, as I cannot find what makes these error appear, or how to solve them.

 

If anyone has an idea or some pointers, I'd be glad to hear them. If I need to attach some code of my azure-pipelines.yml, I can do so, but it's essentially the same as the one on the linked webpage, except for specifying a specific gulpjs input file(else gulp gave errors), and the name of the pool being Default, to locally host the agent.

1 Reply
best response confirmed by Joostdeboer (New Contributor)
Solution

@JoostdeboerThe issue was solved. I had the path to the file that was being called, and this path contained a space. Inputting the path did not attach quote marks around it, so it was being read as separate files, and thus produced an error. I've fixed the path string to contain no more spaces, instead attaching the words with underscores, and the error disappeared.

If anyone knows of a way to fix it by making the command ran on the pipeline always use quotation marks, that would be good to know as well, but for now I've found a way to solve it.