How do I install new versions of .NET Framework onto a TFS build server?

%3CLINGO-SUB%20id%3D%22lingo-sub-2634243%22%20slang%3D%22en-US%22%3EHow%20do%20I%20install%20new%20versions%20of%20.NET%20Framework%20onto%20a%20TFS%20build%20server%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2634243%22%20slang%3D%22en-US%22%3E%3CP%3EAt%20work%20we're%20still%20using%20TFS%202015.%20The%20current%20version%20of%20.NET%20Framework%20on%20the%20build%20server%20is%20.NET%204.5.2.%20Six%20months%20ago%2C%20I%20tried%20to%20install%20.NET%204.7.2%20onto%20the%20build%20server%2C%20but%20that%20wouldn't%20work.%20It%20complained%2C%20saying%20that%20I%20had%20.NET%20Framework%204.8%20on%20the%20server.%20Either%20I'd%20have%20to%20forget%20it%20and%20uninstall%204.8%20to%20get%204.7.2%20installed%20on%20it.%20(Then%20I%20presume%20install%204.8%20again%2C%20after%20putting%20on%204.7.2.)%20Other%20circumstances%20changed%2C%20so%20I%20didn't%20have%20to%20follow%20that%20any%20further%20at%20that%20time.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHowever%2C%20that%20has%20changed%20today.%20Some%20developers%20are%20finally%20moving%20away%20from%20.NET%204.5.2%2C%20to%20go%20to%204.7.2.%20And%20they%20need%20me%20to%20install%204.7.2%20onto%20the%20build%20server.%20So%2C%20how%20do%20uninstall%20.NET%204.8%20from%20the%20build%20server%20so%20I%20can%20get%20.NET%204.7.2%20installed%20on%20our%20TFS%202015%20build%20server%3F%20Then%20later%20put%20.NET%204.8%20back%20onto%20the%20build%20server%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E
Frequent Contributor

At work we're still using TFS 2015. The current version of .NET Framework on the build server is .NET 4.5.2. Six months ago, I tried to install .NET 4.7.2 onto the build server, but that wouldn't work. It complained, saying that I had .NET Framework 4.8 on the server. Either I'd have to forget it and uninstall 4.8 to get 4.7.2 installed on it. (Then I presume install 4.8 again, after putting on 4.7.2.) Other circumstances changed, so I didn't have to follow that any further at that time.

 

However, that has changed today. Some developers are finally moving away from .NET 4.5.2, to go to 4.7.2. And they need me to install 4.7.2 onto the build server. So, how do uninstall .NET 4.8 from the build server so I can get .NET 4.7.2 installed on our TFS 2015 build server? Then later put .NET 4.8 back onto the build server?

0 Replies