Azure DevOps 2019 Update 1.2 Hanging on Install

Copper Contributor

I'm trying to install Azure Devops 2019 Update 1.2.  We are disconnected from the internet so I acquired the offline installed.  Extracted the iso.  Then attempted to install.  It hangs very early in the process, I let it sit for close to an hour with no progress even though I got no errors and there were no entries in the event logs (I'm attempting to install to a Server 2016 server).  Currently Azure DevOps 2019 Update 1.1 is installed.  Any idea why this might be stalling?  Does 1.1 need to be uninstalled first instead of upgrading in place?

3 Replies

@soccastar001 

 

Any events logs or error observed?

@Kidd_Ip 

 

Unfortunately no.

Hey there!

Installing Azure DevOps 2019 Update 1.2 can be a bit tricky, especially when you're offline. I've been down that road before, and I feel your pain. So, about your situation, the upgrade from 1.1 to 1.2 shouldn't usually require uninstalling the previous version, but hey, technology can be a bit unpredictable.

I took help from my friends at triotech systems, here's my two cents: you might wanna try uninstalling 1.1 before diving into 1.2. It's not always necessary, but sometimes it smooths out the process. Also, check if you're ticking all the boxes on the prerequisites list. Tech can be picky about that.

Now, log files are your friends. Dive into those and see if they spill the beans on what's tripping up the process. And oh, run that installer as an admin. Right-click, make it feel important. Sometimes it does the trick.

Also, scan your system for any overprotective firewalls or antivirus software. They can be a bit too enthusiastic, causing hiccups.

I get it, waiting for an hour feels like an eternity, but sometimes these installs need a nudge. If it's still stuck, don't be afraid to pull the plug and try a different angle.

Hang in there! Let me know how it goes or if you need more hacks to tame this beast.