QnA maker bot returns both short and long answer in Test in Web Chat

Copper Contributor


I created a knowledge base at and followed some basic steps in order to create a bot without coding yet. However, when I'm testing it in Test in Web Chat in Azure, it's returning me both short and long answer, as I show in the following picture.




IMPORTANT NOTE: It's not returning in all questions two answers, just with some of them.

I just want to get the long answers

5 Replies
Have you received any update on this? I am facing this issue myself and can't seem to find a solution either.
best response confirmed by wilzuluaga (Copper Contributor)


I was finding the same issue, running within the test web bot and Teams. I eventually found a solution.

If you navigate to the bot's app service in Azure portal, go to the configuration settings and add the key value pair EnablePreciseAnswer:false then this will remove the precise answer or short answer from the response. You will need to save the change and restart the app service for the change to take effect.

Dude you're a legend! I tried to find an application setting like that from the official MS docs but couldn't find anything. Cheers, this actually worked!

@maumak Can you specify where you added the key value pair? I went to Azure Portal>Bot Services>Configuration (under settings), but do not see somewhere for a value pair input. I see headings 'Messaging endpoint', 'Application Insights instrumentation key', 'Application Insights API key', 'Application Insights Application ID', 'Schema Transformation Version', and then below a button for adding OAuth Connection Settings. I am also on the free 30 day trial so if there's another heading, perhaps I don't have permissions?

You find the configuration in the app service, not in the bot service.