Home

Problem with Multi Factor Authentication on Windows 10 - Fix Now button is not available

%3CLINGO-SUB%20id%3D%22lingo-sub-1114402%22%20slang%3D%22en-US%22%3EProblem%20with%20Multi%20Factor%20Authentication%20on%20Windows%2010%20-%20Fix%20Now%20button%20is%20not%20available%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1114402%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20have%20big%20(touch)screen%20Windows%2010%20computers%20in%20our%20classrooms.%20Since%20a%20few%20weeks%20we%20are%20using%20Office%20365%20MFA%20for%20all%20teachers.%20We%20use%20the%20Athenticator%20app%20to%20generate%206%20digit%20codes%20to%20get%20access%20to%20OneDrive%20files%20and%20other%20Office%20365%20sources.%20In%20two%20places%20they%20need%20to%20put%20in%20a%20code%20when%20using%20O365%3A%201)%20via%20the%20browser%20and%202)%20via%20Windows%20OS%20level%20(local%20O365%20app).%20The%20latter%20is%20pretty%20cryptic.%20Users%20get%20a%20message%20that%20there%20is%20a%20problem%20with%20their%20work%20or%20school%20account.%20When%20they%20hit%20that%20message%2C%20they%20are%20redirected%20to%20the%20page%20Settings%20%2F%20System%20%2F%20Shared%20Experiences.%20There%20is%20a%20button%20to%20fix%20the%20problems%20(Fix%20now).%20In%20that%20way%20the%20authenticator%20code%20is%20asked%20and%20users%20get%20access%20directly%20to%20O365%20from%20apps%20like%20Powerpoint%20or%20OneNote.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20two%20questions%3A%3C%2FP%3E%3CP%3E1)%20Is%20there%20a%20less%20cryptic%20way%20to%20get%20the%20code%20screen%20on%20OS%20level%3F%3C%2FP%3E%3CP%3E2)%20Sometimes%20the%20Shared%20Experiences%20page%20indicates%20no%20problems%20with%20the%20account%2C%20but%20access%20to%20OneDrive%20from%20the%20local%20Powerpoint%20app%20gives%20a%20message%20that%20there%20is%20a%20problem%20(no%20error%20code)%20and%20recently%20used%20documents%20stay%20blanc%20when%20opened.%20How%20can%20users%20initiate%20the%20system%20to%20ask%20for%20a%20code%20in%20that%20specific%20case%3F%20I%20found%20one%20way%20that%20will%20work%20only%20once%3A%20remove%20the%20user%20profile%20from%20the%20computer.%20After%20the%20first%20new%20login%2C%20the%20cryptic%20message%20with%20the%20problem%20with%20the%20account%20appears%20and%20code%20is%20asked.%20But%20the%20next%20login%20the%20problem%20is%20back.%20How%20come%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERegards%2C%3C%2FP%3E%3CP%3ERandolf.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1114402%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAzure%20AD%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMulti-Factor%20Authentication%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Highlighted
New Contributor

We have big (touch)screen Windows 10 computers in our classrooms. Since a few weeks we are using Office 365 MFA for all teachers. We use the Athenticator app to generate 6 digit codes to get access to OneDrive files and other Office 365 sources. In two places they need to put in a code when using O365: 1) via the browser and 2) via Windows OS level (local O365 app). The latter is pretty cryptic. Users get a message that there is a problem with their work or school account. When they hit that message, they are redirected to the page Settings / System / Shared Experiences. There is a button to fix the problems (Fix now). In that way the authenticator code is asked and users get access directly to O365 from apps like Powerpoint or OneNote.

 

I have two questions:

1) Is there a less cryptic way to get the code screen on OS level?

2) Sometimes the Shared Experiences page indicates no problems with the account, but access to OneDrive from the local Powerpoint app gives a message that there is a problem (no error code) and recently used documents stay blanc when opened. How can users initiate the system to ask for a code in that specific case? I found one way that will work only once: remove the user profile from the computer. After the first new login, the cryptic message with the problem with the account appears and code is asked. But the next login the problem is back. How come?

 

Regards,

Randolf.