Get-Msol cmdlets deprecated already?

New Contributor

I have several scripts that were created using the the v1 AzureAD PowerShell modules. Recently I have encountered a tenant that is failing on a particlar cmdlet. 

When running Get-MsolCompanyInformation on the problematic tenant I receive the following output:


Get-Msolcompanyinformation -TenantId {tenantid} - The version of the Microsoft Online Services Module that you are using is no longer supported. Download the latest version at

This causes my script to ciese from working, which is not good. 

Also, I have only seen this issue with a tenant. I have not been able to reproduce this problem with other tenants. 

So the questions I have are:

1. Are the v1 cmdlets being deprecated soon or are already in the process of doing so? 

2. How is the cmdlet deprecation applied? Does this only effect new tenants? CSP tenants? A certain license type in the tenant? 

3. If the v1 cmdlets are being deprecated, will tenants no longer respond to any of Msol cmdlets? (Do I need to rewrite my scripts with v2 cmdlets)


Thanks guys! :) 

2 Replies

I just downloaded the latest GA bits here:


It connected to my tenant and Get-MsolCompanyInformation works fine. I'm not using the -TenantId parameter though.


I haven't seen any deprecation notice for this module. The download page says nothing, and the docs page here only says they encourage the use of the V2 module instead.


Should you rewrite scripts for V2? Yes, now would be the time to start working on that, as it's not always a simple task to get like for like functionality as some of the new module's cmdlets work very differently to the old ones in terms of parameters, input, and output.

The Microsoft Online Data Service (MSOL) Module for Windows PowerShell is available in the PowerShell Gallery. For additional PS Gallery information, run this PS command:

Find-Module -Name MSOnline -Verbose -AllVersions | Format-List


To import the MSOL module into your current PS session, run this PS command:

Import-Module -Name MSOnline -Force -Scope Local -Verbose

For testing in my PS session, I imported MSOL from the PS Gallery. After I ran Connect-MsolService, the Get-MsolCompanyInformation cmdlet worked like a charm with or without the tenantID specified.



Kind regards,



Related Conversations
How to get the manager with the get-user?
Andy Kw in Office 365 on
4 Replies
Table of Basic PowerShell Commands
Michael Holste in Windows PowerShell on
0 Replies