SOLVED
Home

AD Connect hang by delta Import

%3CLINGO-SUB%20id%3D%22lingo-sub-297711%22%20slang%3D%22en-US%22%3EAD%20Connect%20hang%20by%20delta%20Import%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-297711%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIn%20my%20test%20system%20there%20is%20problem%20with%20ad-connect.%20It%20stocks%20by%20the%20step%20delta-import%20for%20days%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20533px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F62219i868050DF11C83A82%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22ADSync.png%22%20title%3D%22ADSync.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ETanks%20for%20your%20help%3C%2FP%3E%3CP%3EStefan%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-297711%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAccess%20Management%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EAzure%20AD%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EIdentity%20Management%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-300287%22%20slang%3D%22en-US%22%3ERe%3A%20AD%20Connect%20hang%20by%20delta%20Import%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-300287%22%20slang%3D%22en-US%22%3E%3CP%3EInteresting%2C%20so%20it%20simply%20needed%20a%20full%20sync.%20Cant%20say%20I've%20seen%20such%20behavior%20previously...%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-299701%22%20slang%3D%22en-US%22%3ERe%3A%20AD%20Connect%20hang%20by%20delta%20Import%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-299701%22%20slang%3D%22en-US%22%3E%3CP%3EThis%20Powershell%20commands%20solved%20my%20problem%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CFONT%20face%3D%22Arial%20Narrow%22%20size%3D%223%22%3ESet-ADSyncScheduler%20-SyncCycleEnabled%20%24FALSE%20%3C%2FFONT%3E%3C%2FP%3E%3CP%3E%3CFONT%20face%3D%22Arial%20Narrow%22%20size%3D%223%22%3EStart-ADSyncSyncCycle%20-PolicyType%20Initial%20%3C%2FFONT%3E%3C%2FP%3E%3CP%3E%3CFONT%20face%3D%22Arial%20Narrow%22%20size%3D%223%22%3EStart-ADSyncSyncCycle%20-PolicyType%20Delta%3C%2FFONT%3E%3C%2FP%3E%3CP%3E%3CFONT%20face%3D%22Arial%20Narrow%22%20size%3D%223%22%3ESet-ADSyncScheduler%20-SyncCycleEnabled%20%24TRUE%3C%2FFONT%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-298797%22%20slang%3D%22en-US%22%3ERe%3A%20AD%20Connect%20hang%20by%20delta%20Import%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-298797%22%20slang%3D%22en-US%22%3E%3CP%3EYes%20I%20had%20checkt%20it.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhy%20is%20the%20network%20problem%20only%20in%20this%20one%20step%20and%20all%20other%20steps%20works%20fine.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-298406%22%20slang%3D%22en-US%22%3ERe%3A%20AD%20Connect%20hang%20by%20delta%20Import%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-298406%22%20slang%3D%22en-US%22%3E%3CP%3EThat%20does%20look%20like%20a%20connectivity%20issue%2C%20have%20you%20checked%20the%20steps%20in%20the%20article%20they%20are%20referencing%3F%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Factive-directory%2Fhybrid%2Ftshoot-connect-connectivity%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Factive-directory%2Fhybrid%2Ftshoot-connect-connectivity%3C%2FA%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-298044%22%20slang%3D%22en-US%22%3ERe%3A%20AD%20Connect%20hang%20by%20delta%20Import%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-298044%22%20slang%3D%22en-US%22%3E%3CP%3EFull%20sync%20starts%20via%20PowerShell%20or%20with%20ad%20connects%20runs%20without%20any%20problems.%20Only%20the%20delta%20Import%20brings%20the%20problems%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20888px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F62280i53BE68635589921F%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22ADSync.png%22%20title%3D%22ADSync.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20find%20three%20log%20entries%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EFailure%20while%20prefetching%20import%20data.%20More%20details%20at%3A%20%3CA%20href%3D%22https%3A%2F%2Fgo.microsoft.com%2Ffwlink%2F%3Flinkid%3D869679%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fgo.microsoft.com%2Ffwlink%2F%3Flinkid%3D869679%3C%2FA%3E.%20Exception%20message%3A%20Failed%20even%20after%205%20retries.%20Action%3A%20ImportV1%2C%20Network%20error%20occurrences%20%3D%200.%20Exception%3A%20The%20Windows%20Azure%20Active%20Directory%20service%20is%20temporarily%20unavailable.%20If%20you%20continue%20to%20see%20this%20issue%2C%20contact%20Technical%20Support.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EFailure%20while%20importing%20entries%20from%20Windows%20Azure%20Active%20Directory.%20More%20details%20at%3A%20%3CA%20href%3D%22https%3A%2F%2Fgo.microsoft.com%2Ffwlink%2F%3Flinkid%3D869679%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fgo.microsoft.com%2Ffwlink%2F%3Flinkid%3D869679%3C%2FA%3E.%20Exception%20message%3A%20Failed%20even%20after%205%20retries.%20Action%3A%20ImportV1%2C%20Network%20error%20occurrences%20%3D%200.%20Exception%3A%20The%20Windows%20Azure%20Active%20Directory%20service%20is%20temporarily%20unavailable.%20If%20you%20continue%20to%20see%20this%20issue%2C%20contact%20Technical%20Support.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20management%20agent%20%22dev.onmicrosoft.com%20-%20AAD%22%20failed%20on%20run%20profile%20%22Delta%20Import%22%20because%20the%20server%20encountered%20errors.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-298013%22%20slang%3D%22en-US%22%3ERe%3A%20AD%20Connect%20hang%20by%20delta%20Import%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-298013%22%20slang%3D%22en-US%22%3EAs%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F58%22%20target%3D%22_blank%22%3E%40Vasil%20Michev%3C%2FA%3Esaid%2C%20the%20logs%20should%20tell%20you%20something%20hopefully!%20My%20experience%20is%20that%20it%20often%20is!%3CBR%20%2F%3EThis%20could%20be%20an%20network%20issue%20as%20well!%3CBR%20%2F%3EWhat%20happens%20if%20you%20initiate%20a%20delta%20or%20full%20sync%20via%20powershell%3F%3CBR%20%2F%3Estart-adsyncsynccycle%20-policytype%20delta%2Finitial%3CBR%20%2F%3E%3CBR%20%2F%3EI%E2%80%99ve%20heard%20other%20with%20this%20problem%20and%20got%20it%20resolved%20by%20changing%20the%20syncing%20service%20account%20as%20well%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-298009%22%20slang%3D%22en-US%22%3ERe%3A%20AD%20Connect%20hang%20by%20delta%20Import%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-298009%22%20slang%3D%22en-US%22%3E%3CP%3ECheck%20the%20event%20logs%20then%2C%20there%20might%20be%20some%20events%20there%20to%20give%20you%20a%20clue%20what's%20going%20on.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-298006%22%20slang%3D%22en-US%22%3ERe%3A%20AD%20Connect%20hang%20by%20delta%20Import%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-298006%22%20slang%3D%22en-US%22%3E%3CP%3EIt%20is%20still%20the%20same%20problem%20I%20restarted%20the%20server%20and%20the%20Service.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-297819%22%20slang%3D%22en-US%22%3ERe%3A%20AD%20Connect%20hang%20by%20delta%20Import%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-297819%22%20slang%3D%22en-US%22%3E%3CP%3EIf%20it's%20a%20test%20machine%20just%20restart%20it.%20Or%20you%20can%20just%20restart%20the%20AAD%20Sync%20service%20instead%20%3A)%3C%2Fimg%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Frequent Contributor

Hello,

 

In my test system there is problem with ad-connect. It stocks by the step delta-import for days

 

ADSync.png

 

Tanks for your help

Stefan

 

9 Replies
Highlighted

If it's a test machine just restart it. Or you can just restart the AAD Sync service instead :)

Highlighted

It is still the same problem I restarted the server and the Service.

Highlighted

Check the event logs then, there might be some events there to give you a clue what's going on.

Highlighted
As @Vasil Michev said, the logs should tell you something hopefully! My experience is that it often is!
This could be an network issue as well!
What happens if you initiate a delta or full sync via powershell?
start-adsyncsynccycle -policytype delta/initial

I’ve heard other with this problem and got it resolved by changing the syncing service account as well
Highlighted

Full sync starts via PowerShell or with ad connects runs without any problems. Only the delta Import brings the problems

ADSync.png

 

I find three log entries:

 

Failure while prefetching import data. More details at: https://go.microsoft.com/fwlink/?linkid=869679. Exception message: Failed even after 5 retries. Action: ImportV1, Network error occurrences = 0. Exception: The Windows Azure Active Directory service is temporarily unavailable. If you continue to see this issue, contact Technical Support.

 

Failure while importing entries from Windows Azure Active Directory. More details at: https://go.microsoft.com/fwlink/?linkid=869679. Exception message: Failed even after 5 retries. Action: ImportV1, Network error occurrences = 0. Exception: The Windows Azure Active Directory service is temporarily unavailable. If you continue to see this issue, contact Technical Support.

 

The management agent "dev.onmicrosoft.com - AAD" failed on run profile "Delta Import" because the server encountered errors.

Highlighted

That does look like a connectivity issue, have you checked the steps in the article they are referencing? https://docs.microsoft.com/en-us/azure/active-directory/hybrid/tshoot-connect-connectivity

Highlighted

Yes I had checkt it. 

 

Why is the network problem only in this one step and all other steps works fine.

Highlighted
Solution

This Powershell commands solved my problem

 

Set-ADSyncScheduler -SyncCycleEnabled $FALSE

Start-ADSyncSyncCycle -PolicyType Initial

Start-ADSyncSyncCycle -PolicyType Delta

Set-ADSyncScheduler -SyncCycleEnabled $TRUE

Highlighted

Interesting, so it simply needed a full sync. Cant say I've seen such behavior previously...

Related Conversations