Swedish characters encoding garbled in Application Proxy

%3CLINGO-SUB%20id%3D%22lingo-sub-1381945%22%20slang%3D%22en-US%22%3ESwedish%20characters%20encoding%20garbled%20in%20Application%20Proxy%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1381945%22%20slang%3D%22en-US%22%3E%3CP%3EHi!%26nbsp%3B%3C%2FP%3E%3CP%3E%3CBR%20%2F%3EWe%20have%20a%20problem%20with%20character%20encoding%20for%20an%20application%20that%20we%20publish%20through%20Azure%20AD%20Application%20Proxy.%20The%20application%20works%20great%20when%20accessed%20internally%2C%20but%20when%20published%20through%20AADAP%20the%20Swedish%20characters%20(%C3%85%C3%84%C3%96%20and%20so%20on)%20gets%20garbled%20with%20for%20instance%20%22%C3%83%C2%BDlt%22.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20not%20sure%20where%20to%20start%20troubleshooting%20this%3B%20but%20I%20cannot%20find%20any%20settings%20regarding%20content%20encoding%20in%20AADAP.%20I%20found%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Factive-directory%2Fmanage-apps%2Fapplication-proxy-configure-hard-coded-link-translation%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%22%3Edocumentation%3C%2FA%3E%20stating%20that%20AADAP%20expects%20UTF-8%20and%20that%20I%20could%20change%20the%20behavior%20using%20a%20response%20header%20-%20preferably%20to%20%22ISO-8859-1%22.%20But%20I'm%20a%20bit%20out%20of%20my%20depth%20here%20and%20any%20help%20would%20be%20greatly%20appreciated!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1381945%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3Eapplication%20proxy%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EAzure%20AD%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1405286%22%20slang%3D%22en-US%22%3ERe%3A%20Swedish%20characters%20encoding%20garbled%20in%20Application%20Proxy%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1405286%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F218914%22%20target%3D%22_blank%22%3E%40Magnus%20Tjerneld%3C%2FA%3E%26nbsp%3Bdo%20you%20mean%20that%20the%20body%20of%20the%20application%20is%26nbsp%3B%3CSPAN%3Egarbled%20or%20the%20URL%3F%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1410256%22%20slang%3D%22en-US%22%3ERe%3A%20Swedish%20characters%20encoding%20garbled%20in%20Application%20Proxy%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1410256%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F470541%22%20target%3D%22_blank%22%3E%40JanBakker330%3C%2FA%3E%26nbsp%3BThe%20body%20of%20the%20site%20content%2C%20not%20the%20URL.%20Some%20(not%20all)%20occurances%20of%20%C3%85%C3%84%C3%96%20shows%20up%20as%20nonsense%20characters.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

Hi! 


We have a problem with character encoding for an application that we publish through Azure AD Application Proxy. The application works great when accessed internally, but when published through AADAP the Swedish characters (ÅÄÖ and so on) gets garbled with for instance "ýlt".

 

I'm not sure where to start troubleshooting this; but I cannot find any settings regarding content encoding in AADAP. I found documentation stating that AADAP expects UTF-8 and that I could change the behavior using a response header - preferably to "ISO-8859-1". But I'm a bit out of my depth here and any help would be greatly appreciated!

2 Replies

@Magnus Tjerneld do you mean that the body of the application is garbled or the URL? 

@JanBakkerOrphaned The body of the site content, not the URL. Some (not all) occurances of ÅÄÖ shows up as nonsense characters.