Number added to user email addresses - SharePoint access

%3CLINGO-SUB%20id%3D%22lingo-sub-2012152%22%20slang%3D%22en-US%22%3ENumber%20added%20to%20user%20email%20addresses%20-%20SharePoint%20access%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2012152%22%20slang%3D%22en-US%22%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHi%2C%3CBR%20%2F%3EI%20have%20an%20issue%20with%20the%20user%20account%20which%20is%20created%20on%20onPrem%20AD%20and%20synced%20to%20AzureAD.%20The%20user%20account%20has%20been%20terminated%20and%20recreated.%20After%20the%20Account%20has%20been%20recreated%20with%20the%20same%20name%20we%20noticed%20that%20the%20user%20got%20also%20an%20additional%20email%20alias%20with%20user%2B4digits%40domain.com%20in%26nbsp%3B%26nbsp%3BOffice365.%20I%20was%20able%20to%20clean%20up%20and%20delete%20the%20additional%20email%20with%20digits%20by%20using%20this%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Ftroubleshoot%2Fazure%2Factive-directory%2Fnumber-add-username-email-address%26nbsp%3Blink.%26nbsp%3B%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Ftroubleshoot%2Fazure%2Factive-directory%2Fnumber-add-username-email-address%26nbsp%3Blink.%26nbsp%3B%3C%2FA%3E%3CBR%20%2F%3EAfter%20this%20procedure%20the%20user%20is%20working%20ok%2C%20emails%2C%20etc%20are%20just%20fine%20but%20when%20the%20user%20access%20SharePoint%20website%20I%20still%20see%20that%20in%20some%20part%20of%20tracing%20it%20still%20appears%20with%20the%20digits%20added%20to%20his%20mail%20address%3A%3CBR%20%2F%3E%5C%22userPrincipalName%5C%22%3A%5C%22user6795%40domain.onmicrosoft.com%3C%2FP%3E%3CP%3E%5C%22userEmail%5C%22%3A%5C%22user%40domain.com%5C%22%2C%5C%22userId%5C%22%3A2144%2C%5C%22userLoginName%5C%22%3A%5C%22user6795%40domain.onmicrosoft.com%5C%3C%2FP%3E%3CP%3EThis%20is%20causing%20a%20lot%20of%20issues%20on%20SharePoint.%20Any%20Ideas%3F%3C%2FP%3E%3CP%3EThank%20you%20in%20advance%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2012152%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAzure%20AD%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2028497%22%20slang%3D%22en-US%22%3ERe%3A%20Number%20added%20to%20user%20email%20addresses%20-%20SharePoint%20access%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2028497%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F652239%22%20target%3D%22_blank%22%3E%40pawmo%3C%2FA%3E%26nbsp%3BAccording%20to%20the%20information%20that%20you%20gave%2C%20the%20user%20account%20is%20deleted%20on-prem%20and%20re-created.%20But%2C%20when%20a%20cloud%20account%2Fmailbox%20is%20deleted%2C%20it%20is%20only%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fexchange%2Frecipients-in-exchange-online%2Fdelete-or-restore-mailboxes%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%22%3E%3CSTRONG%3Esoft%20deleted%3C%2FSTRONG%3E%3C%2FA%3E.%20So%20the%20account%20would%20still%20exist%20for%2030%20days%2C%20and%20that's%20why%20the%20email%20address%20is%20different.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECan%20you%20see%20the%20deleted%20account%2Fmailbox%20under%20deleted%20users%20in%20the%20Admin%20portal%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

 

Hi,
I have an issue with the user account which is created on onPrem AD and synced to AzureAD. The user account has been terminated and recreated. After the Account has been recreated with the same name we noticed that the user got also an additional email alias with user+4digits@domain.com in  Office365. I was able to clean up and delete the additional email with digits by using this https://docs.microsoft.com/en-us/troubleshoot/azure/active-directory/number-add-username-email-addre...
After this procedure the user is working ok, emails, etc are just fine but when the user access SharePoint website I still see that in some part of tracing it still appears with the digits added to his mail address:
\"userPrincipalName\":\"user6795@domain.onmicrosoft.com

\"userEmail\":\"user@domain.com\",\"userId\":2144,\"userLoginName\":\"user6795@domain.onmicrosoft.com\

This is causing a lot of issues on SharePoint. Any Ideas?

Thank you in advance

1 Reply

@pawmo According to the information that you gave, the user account is deleted on-prem and re-created. But, when a cloud account/mailbox is deleted, it is only soft deleted. So the account would still exist for 30 days, and that's why the email address is different.

 

Can you see the deleted account/mailbox under deleted users in the Admin portal?