Azure B2B Invite creating new AD User instead of inviting

%3CLINGO-SUB%20id%3D%22lingo-sub-200301%22%20slang%3D%22en-US%22%3EAzure%20B2B%20Invite%20creating%20new%20AD%20User%20instead%20of%20inviting%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-200301%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%3C%2FP%3E%3CP%3EI%20am%20currently%20a%20global%20admin%20in%20both%20my%20home%20tenant%20and%20foreign%20AD%20tenant.%20I%20am%20trying%20to%20invite%20users%20using%20PS%20code%20I've%20used%20in%20the%20past%20(see%20below)%20but%20now%20it's%20creating%20a%20new%20Azure%20AD%20user%20instead%20of%20inviting%20them.%20I%20noticed%20this%20by%20the%20source%20field%20under%20the%20user%20properties.%20It%20should%20say%20External%20Azure%20Active%20Directory%20but%20now%20it's%26nbsp%3BAzure%20Active%20Directory.%20I'm%20not%20sure%20how%20this%20is%20possible%20as%20the%20domain%20of%20the%20user%20that%20was%20created%20is%20not%20even%20registered%20with%20that%20tenant.%20Anyone%20else%20see%20this%20before%3F%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EImport-Module%20AzureAD%3C%2FP%3E%3CP%3EConnect-AzureAD%20-TenantId%20%24sub.TenantId%20-Credential%20%24cred%20-Verbose%3C%2FP%3E%3CP%3ENew-AzureADMSInvitation%20-InvitedUserDisplayName%20%24user.DisplayName%20-InvitedUserEmailAddress%20%24user.eMail%26nbsp%3B-SendInvitationMessage%20%24false%20-InvitedUserType%20Member%20-InviteRedirectUrl%20%22%3CA%20href%3D%22http%3A%2F%2Fmyapps.onmicrosoft.com%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttp%3A%2F%2Fmyapps.onmicrosoft.com%3C%2FA%3E%22%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-200301%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAzure%20AD%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EAzure%20AD%20B2B%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-211239%22%20slang%3D%22en-US%22%3ERe%3A%20Azure%20B2B%20Invite%20creating%20new%20AD%20User%20instead%20of%20inviting%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-211239%22%20slang%3D%22en-US%22%3E%3CP%3EHello%20Joseph%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EVerify%20the%20option%20of%20the%20source%20when%20we%20navigate%20to%20the%20users%20properties.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDefault%20list%20%3A-%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F36962iF73F857B3F1A10D6%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Untitled.png%22%20title%3D%22Untitled.png%22%20%2F%3E%3C%2FSPAN%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20513px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F36963iECB2F5A13EFE45CD%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Untitled.png%22%20title%3D%22Untitled.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERegards%2C%3C%2FP%3E%3CP%3ERishabh%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

Hello,

I am currently a global admin in both my home tenant and foreign AD tenant. I am trying to invite users using PS code I've used in the past (see below) but now it's creating a new Azure AD user instead of inviting them. I noticed this by the source field under the user properties. It should say External Azure Active Directory but now it's Azure Active Directory. I'm not sure how this is possible as the domain of the user that was created is not even registered with that tenant. Anyone else see this before? 

 

Thanks!

 

Import-Module AzureAD

Connect-AzureAD -TenantId $sub.TenantId -Credential $cred -Verbose

New-AzureADMSInvitation -InvitedUserDisplayName $user.DisplayName -InvitedUserEmailAddress $user.eMail -SendInvitationMessage $false -InvitedUserType Member -InviteRedirectUrl "http://myapps.onmicrosoft.com"

1 Reply
Highlighted

Hello Joseph,

 

Verify the option of the source when we navigate to the users properties. 

 

Default list :- 

 

Untitled.pngUntitled.png

 

Regards,

Rishabh