SOLVED

Azure AD Powershell v2 missing some commands :-(

%3CLINGO-SUB%20id%3D%22lingo-sub-327857%22%20slang%3D%22en-US%22%3EAzure%20AD%20Powershell%20v2%20missing%20some%20commands%20%3A(%3C%2Fimg%3E%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-327857%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENot%20sure%20if%20this%20is%20the%20correct%20community%20to%20ask%20but%20I%20seem%20to%20be%20missing%20certain%20ps%20commands%20in%20Azure%20AD%20v2%20(2.0.2.4)%2C%20more%20specifically%20all%20the%20commands%20with%20AzureADServicePrincipalPolicy%20(Get%2C%20Add).%3C%2FP%3E%3CP%3EThe%20others%20are%20all%20there%20(AzureADServicePrincipal%20%2C%20KeyCredential%2C%20Owner%2C%20CreatedObject%2C...).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20tried%20uninstalling%20and%20reinstalling%20the%20module%20but%20that%20did%20not%20work.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENot%20sure%20what%20else%20I%20can%20do%20%3A)%3C%2Fimg%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-327857%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAzure%20AD%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-328167%22%20slang%3D%22en-US%22%3ERe%3A%20Azure%20AD%20Powershell%20v2%20missing%20some%20commands%20%3A(%3C%2Fimg%3E%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-328167%22%20slang%3D%22en-US%22%3EGreat.%20Thanks%20Vasil%20%3A)%3C%2Fimg%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-328138%22%20slang%3D%22en-US%22%3ERe%3A%20Azure%20AD%20Powershell%20v2%20missing%20some%20commands%20%3A(%3C%2Fimg%3E%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-328138%22%20slang%3D%22en-US%22%3E%3CP%3ECertain%20cmdlets%2C%20such%20as%20the%20*-Get-AzureADServicePrincipalPolicy%20ones%2C%20are%20only%20available%20as%20part%20of%20the%20AzureADPreview%20module%3A%20%3CA%20href%3D%22https%3A%2F%2Fwww.powershellgallery.com%2Fpackages%2FAzureADPreview%2F2.0.2.5%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fwww.powershellgallery.com%2Fpackages%2FAzureADPreview%2F2.0.2.5%3C%2FA%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Contributor

Hi,

 

Not sure if this is the correct community to ask but I seem to be missing certain ps commands in Azure AD v2 (2.0.2.4), more specifically all the commands with AzureADServicePrincipalPolicy (Get, Add).

The others are all there (AzureADServicePrincipal , KeyCredential, Owner, CreatedObject,...).

 

I have tried uninstalling and reinstalling the module but that did not work. 

 

Not sure what else I can do :)

 

2 Replies
Highlighted
Best Response confirmed by Steve Hernou (Contributor)
Solution

Certain cmdlets, such as the *-Get-AzureADServicePrincipalPolicy ones, are only available as part of the AzureADPreview module: https://www.powershellgallery.com/packages/AzureADPreview/2.0.2.5

Highlighted
Great. Thanks Vasil :)