Unable to upload videos

New Contributor

I have previously been able to upload vides, but the last few videos I have tried to upload repeatedly, yesterday and today, fail slightly past mid-upload.


I have tried from Chrome and Safari on a fully up-to-date Mac and from IE on a Windows 10 PC, all with the same result.


The files are 1.78 GB and 2.42 GB MP4 files using H.264 and AAC codecs.



5 Replies

Can you try to reproduce this and then provide the following additional information:

  • Exact timeframe / timezone
  • Session ID 
    • Can be found from the "?" menu in the upper-right, select "About Microsoft Stream"
  • User ID
    • Can be found by typing in the browser Console "sessionInfo.UserClaim.UserInfo.UniqueId"


With these three pieces, we will be able to fully dig into the issue you are experiencing.


Thank you @adarsh.  


I tried again and it failed at Fri Apr  7 16:57:31 CDT 2017.  The Session ID is 9eeacf23-9ea5-491a-b607-97ae635ebb84 and the User ID is 1e2ba46a-0544-4f17-ae79-4e3ded424cde.


For what it is worth, it looks like the XHR receieved an HTTP 403 on a PUT right before the error.


"Response to preflight request doesn't pass access control check: No 'Access-Control-Allow-Origin' header is present on the requested resource. Origin 'https://web.microsoftstream.com' is therefore not allowed access."






Based off the errors I saw in the console, I am assuming that a security token weasn't getting extended or renewed on each put of the video chunk, and ultimately it expired causing the upload to fail.


I was able to get an internet connection with a specifically fast upload speed and was able to upload the videos successfully on that connection.  The problem is repeatable on my normal Internet connection, so if it is something you would like help troubleshooting, please let me know and I can re-test and give feedback.


On the slow connection, how long was the upload taking approximately?


Sorry for the delayed response--I was traveling.


I just tested an using timestamps on the Google Chrome console the error showed up right at 30 minutes in.  The upload started at 20:56:37.391 local time and errored at 21:26:41.705.