Unable to connect to App through Connect-IPPSession under CertificateThumbPrint or even Certificate

Copper Contributor

Hello everyone,


I am trying to perform a login through a script without having to put simply a password as an argument, but not sure what I am missing here regarding Connect-IPPSession arguments.

This is the tutorial that I am following.


From my side, when I try to login with Certificate argument, I receive an error saying, "The specified network password is not correct", but really don't know why (both user and password set on the certificate, when exported was my current username and password of current user account, on this, machine where I also have the certificate installed, and where it was created):


If I try with CertificateThumbPrint argument, it pops up a window to sign with an account:


Regarding Certificate argument, from documentation there is an input that I don't understand what to set there, regarding <%X509Certificate2 Object%>, so tried to add the pfx file itself to try, even knowing that the certificate does not need to be installed on the computer. 


My main objective is to use CertificateThumbPrint argument, but till now, no luck.






3 Replies
Tried with the newest exchange command and worked, but through that I am not able to use SCC cmdlets:

Have also installed the must recent ExchangeOnlineManagement version,

Install-Module -Name ExchangeOnlineManagement -RequiredVersion 2.0.5

but still being popup with Connect-IPPSession ...
From documentation I need to have at least Exchange Online PowerShell module version 2.0.6-Preview5 or later, but when I use Connect-IPPSSession with CertificateThumbPrint when I close that login popup, I receive an error message with 3.0.0 on command path error.

On my system I've the following versions:

But really don't know how to force 2.0.6-Preview5 or later, under v2 to be used, instead of 3.0.0 who is the current one, for this case.
best response confirmed by GodzillaKP (Copper Contributor)
1 best response

Accepted Solutions
best response confirmed by GodzillaKP (Copper Contributor)