Unable mount FileShare to multi-container App Service

New Contributor

Hi,

I am struggling with mounting FileShare to multi-container app service. I was trying to follow e.g. https://azure.github.io/AppService/2018/09/24/Announcing-Bring-your-own-Storage-to-App-Service.html.

 

When I executed something like:

az webapp config storage-account add -g <my-rg> -n <my-app> --custom-id imagesMountId2 --storage-type AzureFiles --account-name <accountName> --share-name images --access-key "<SAME_ACCESS_KEY>" --mount-path /image_database2

Then in a result I can see InvalidCredentials for AzureFiles

  "imagesMountId2": {
    "accessKey": "<SAME_ACCESS_KEY>",
    "accountName": "<accountName>",
    "mountPath": "/image_database2",
    "shareName": "images",
    "state": "InvalidCredentials",
    "type": "AzureFiles"
  },
  "testBlob": {
    "accessKey": "<SAME_ACCESS_KEY>",
    "accountName": "<accountName>",
    "mountPath": "/test-blob",
    "shareName": "docker-images",
    "state": "Ok",
    "type": "AzureBlob"
  }

As you can see above I was able to mount AzureBlob using same accessKey. Additionally I have tried mount same AzureFile to some regular node.js application on AppService (no multi-container app) and it was working fine. So looks like I have some problem to mount FileShare to my multi-container App Service (but looks like AzureBlob works fine).

 

Additionally what I have tried to make it working:

  • set on FileShares - Security: Maximum compatibility -> not helped
  • upgrade Service Plan to S1 -> not helped
  • run command to mount FileShare with --debug -> got just 200 response with this state: 'InvalidCredentials' for FileShare and no warnings, errors, etc..

Any idea what should I do to make it working?

1 Reply

Hi,

Just an update from my side. Looks like at the end FileShare was properly mounted to my container. State all time was “InvalidCredentials” for this mount, but it was fully functional. Both, read and write operations worked fine.