Slow performance of azure web app (Django rest framework)

%3CLINGO-SUB%20id%3D%22lingo-sub-1513496%22%20slang%3D%22en-US%22%3ESlow%20performance%20of%20azure%20web%20app%20(Django%20rest%20framework)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1513496%22%20slang%3D%22en-US%22%3E%3CP%3E%3CSPAN%3EI%20am%20working%20on%20Django%20Rest%20Framework%20and%20I%20have%20deployed%20it%20in%20azure%20app%20service%20with%20azure%20PostgreSQL%20database.%20When%20I%20am%20trying%20to%20integrate%20it%20with%20my%20mobile%20app%20it%20is%20working%20good%20for%20the%20first%20few%20requests%20after%20that%20it's%20running%20very%20slow.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EIt's%20taking%20more%20than%2016%20seconds%20to%20get%20some%20responses.%20I%20already%20tested%20in%20Heroku%20it's%20was%20very%20good%20but%20it's%20not%20working%20properly%20in%20azure.%20Did%20I%20do%20anything%20wrong%3F%20%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EPremiumV2%20%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3ELocation%3A%20Southeast%20Asia%20%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EI%20even%20tried%20changing%20location.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1513496%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EWeb%20Apps%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1603041%22%20slang%3D%22en-US%22%3ERe%3A%20Slow%20performance%20of%20azure%20web%20app%20(Django%20rest%20framework)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1603041%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F409959%22%20target%3D%22_blank%22%3E%40saibhaskar%3C%2FA%3E%26nbsp%3BHi%20Sai.%20Can%20you%20share%20more%20information%20on%20your%20setup%20and%20the%20issues%20faced%3F%3C%2FP%3E%0A%3CP%3EI'm%20from%20the%20PostgreSQL%20Engineering%20team%20and%20would%20like%20to%20understand%20more.%20Please%20feel%20free%20to%20email%20me%20at%20%3CA%20href%3D%22mailto%3Adeepthi.prasad%40microsoft.com%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Edeepthi.prasad%40microsoft.com%3C%2FA%3E.%3C%2FP%3E%0A%3CP%3EThanks.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1609653%22%20slang%3D%22en-US%22%3ERE%3A%20Slow%20performance%20of%20azure%20web%20app%20(Django%20rest%20framework)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1609653%22%20slang%3D%22en-US%22%3E**bleep**%20u%20chump%20game%20on%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1612393%22%20slang%3D%22en-US%22%3ERe%3A%20Slow%20performance%20of%20azure%20web%20app%20(Django%20rest%20framework)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1612393%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F111203%22%20target%3D%22_blank%22%3E%40Deepthi%20Prasad%3C%2FA%3E%26nbsp%3BI%20have%20sent%20you%20the%20mail.%3C%2FP%3E%3CP%3EThanks%20for%20responding%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

I am working on Django Rest Framework and I have deployed it in azure app service with azure PostgreSQL database. When I am trying to integrate it with my mobile app it is working good for the first few requests after that it's running very slow.

 

It's taking more than 16 seconds to get some responses. I already tested in Heroku it's was very good but it's not working properly in azure. Did I do anything wrong?

 

PremiumV2

Location: Southeast Asia

I even tried changing location.

 

3 Replies

@saibhaskar Hi Sai. Can you share more information on your setup and the issues faced?

I'm from the PostgreSQL Engineering team and would like to understand more. Please feel free to email me at deepthi.prasad@microsoft.com.

Thanks.

**bleep** u chump game on

@Deepthi Prasad I have sent you the mail.

Thanks for responding