Issue with multiple Index data field mapping in Azure AI Studio

Copper Contributor

I’m working on integrating my own data into a deployed GPT-4 model using an Azure SQL database. The database connection is working perfectly, and I’m able to perform searches in the Azure portal using Azure AI Search without any issues.

 

However, I’m running into a problem in Azure AI Studio. When setting up the content mapping, I’m able to add a single column without any issues. But each time I try to add multiple columns, I receive the following error message:

An error occurred when calling Azure Cognitive Search: AzureSearch: Wrong content columns provided. Please ensure your content columns are retrievable. Cannot find the following columns in result set: Description, CustomerName.

{ "search": "*", "select": "Description,CustomerName", "top": 10 }

 

I tested this query in the Search explorer, and it successfully returned the expected results, which confirms that the columns are present and retrievable in the index. I’ve also checked that all fields are retrievable and searchable in the index.

What am I missing here? Has anyone else faced this issue or have any ideas on what might be going wrong with the content mapping in Azure AI Studio when specifying multiple columns?

 

Thanks in advance for your help!

1 Reply

@dsn921005 I have the same problem. Looks like Completions API (2024-02-15-preview) expects array to be received, but Open AI Studio sandbox pass it as plain string. Tried to reproduced with fixed value in Postman and it worked. Looks like defect.