SOLVED

Could not fetch o365 usage Reports API

%3CLINGO-SUB%20id%3D%22lingo-sub-1811651%22%20slang%3D%22en-US%22%3ECould%20not%20fetch%20o365%20usage%20Reports%20API%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1811651%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%3CP%3EIn%20graph%20explorer%2C%20I'm%20able%20to%20get%20results%20for%20basic%20sample%20API's%20as%20described%20in%20Graph%20explorer%20sample%20queries%2C%20(ex%3A%20request%3A%20%2Fusers%2F%3CTENANTID%3E%2Fdrives)%2C%20but%20for%20reports%20usage%20API%2C%20could%20not%20able%20to%20fetch%20details%20for%20any%20other%20GET%20requests%2C%20getting%20the%20below%20error%20everytime.%20I've%20checked%20and%20given%20all%20the%20permissions%20as%20mentioned%20in%20docs.%20Need%20help%20regarding%20the%20unknown%20tenant%20id..%3C%2FTENANTID%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSTRONG%3E%3CA%20href%3D%22https%3A%2F%2Fgraph.microsoft.com%2Fbeta%2Freports%2FgetOneDriveActivityUserCounts(period%3D'D7')%3F%24format%3Dapplication%2Fjson%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fgraph.microsoft.com%2Fbeta%2Freports%2FgetOneDriveActivityUserCounts(period%3D'D7')%3F%24format%3Dapplication%2Fjson%3C%2FA%3E.%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3E%3CBR%20%2F%3E%3CSTRONG%3EOutput%20error%3A%26nbsp%3B%3C%2FSTRONG%3E%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%3CP%3E%3CSTRONG%3E%22code%22%3A%20%22UnknownError%22%2C%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3E%3CSTRONG%3E%22message%22%3A%20%22%7B%5C%22error%5C%22%3A%7B%5C%22code%5C%22%3A%5C%22UnknownTenantId%5C%22%2C%5C%22message%5C%22%3A%5C%22We%20do%20not%20recognize%20this%20tenant%20ID%205b1afc8e-xxxx-4842-xxxx-xxxxxx.%20Please%20double-check%20the%20tenant%20ID%20and%20try%20again.%5C%22%7D%7D%22%2C%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1811651%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAdmin%20Center%20App%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOffice%20365%20Administration%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOffice%20365%20Management%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1812954%22%20slang%3D%22en-US%22%3ERe%3A%20Could%20not%20fetch%20o365%20usage%20Reports%20API%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1812954%22%20slang%3D%22en-US%22%3E%3CP%3EIf%20this%20is%20a%20new%20tenant%2C%20it%20might%20take%20a%20while%20for%20the%20report%20service%20to%20pick%20it%20up%20and%20start%20generating%20reports.%20In%20any%20case%2C%20contact%20support%20and%20report%20this.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Visitor

Hello,

In graph explorer, I'm able to get results for basic sample API's as described in Graph explorer sample queries, (ex: request: /users/<tenantid>/drives), but for reports usage API, could not able to fetch details for any other GET requests, getting the below error everytime. I've checked and given all the permissions as mentioned in docs. Need help regarding the unknown tenant id..

 

https://graph.microsoft.com/beta/reports/getOneDriveActivityUserCounts(period='D7')?$format=applicat....


Output error: 

"code": "UnknownError",

"message": "{\"error\":{\"code\":\"UnknownTenantId\",\"message\":\"We do not recognize this tenant ID 5b1afc8e-xxxx-4842-xxxx-xxxxxx. Please double-check the tenant ID and try again.\"}}",

 

1 Reply
best response confirmed by gaurav_k (Occasional Visitor)
Solution

If this is a new tenant, it might take a while for the report service to pick it up and start generating reports. In any case, contact support and report this.