Changed language, but can't change Admin UI Back!

%3CLINGO-SUB%20id%3D%22lingo-sub-1269880%22%20slang%3D%22en-US%22%3EChanged%20language%2C%20but%20can't%20change%20Admin%20UI%20Back!%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1269880%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20there!%3C%2FP%3E%3CP%3EI%20was%20testing%20something%20so%20I%20changed%20the%20UI%20language%20to%20Chinese.%20I%20then%20changed%20the%20UI%20language%20back%20to%20English.%20While%20the%20main%20office.com%20screen%20and%20Word%20UI%20are%20back%20in%20English%2C%20the%20Admin%20Panel%20remains%20in%20Chinese.%20Help%20please.%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22mokiee_1-1585707176944.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F181174i86DF8D576C7D3298%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22mokiee_1-1585707176944.png%22%20alt%3D%22mokiee_1-1585707176944.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1269880%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAdmin%20center%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOffice%20365%20Administration%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1270263%22%20slang%3D%22en-US%22%3ERe%3A%20Changed%20language%2C%20but%20can't%20change%20Admin%20UI%20Back!%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1270263%22%20slang%3D%22en-US%22%3EYou%20might%20need%20to%20re-start%20your%20session%20in%20the%20browser%20or%20even%20an%20inprivate%20session%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1270511%22%20slang%3D%22en-US%22%3ERe%3A%20Changed%20language%2C%20but%20can't%20change%20Admin%20UI%20Back!%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1270511%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F60%22%20target%3D%22_blank%22%3E%40Juan%20Carlos%20Gonz%C3%A1lez%20Mart%C3%ADn%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20for%20the%20reply!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20ended%20up%20noticing%20it%20was%20persistent%20in%20Edge%20on%20the%20desktop%2C%20but%20when%20I%20loaded%20it%20in%20Chrome%20on%20my%20laptop%20later%20on%2C%20it%20was%20in%20English.%20So%20I%20presumed%20the%20setting%20was%20either%20in%20LocalStorage%20or%20Cookies.%20I%20ended%20up%20just%20deleting%20the%20cookies%20for%20admin.microsoft.com%20and%20it%20is%20back%20in%20English%20now.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EKinda%20weird%20that%20MS%20handled%20the%20language%20issue%20differently%20for%20Admin%20than%20the%20rest%20of%20O365!%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Contributor

Hi there!

I was testing something so I changed the UI language to Chinese. I then changed the UI language back to English. While the main office.com screen and Word UI are back in English, the Admin Panel remains in Chinese. Help please.

mokiee_1-1585707176944.png

 

2 Replies
Highlighted
You might need to re-start your session in the browser or even an inprivate session

@Juan Carlos González Martín 

Thanks for the reply!

 

I ended up noticing it was persistent in Edge on the desktop, but when I loaded it in Chrome on my laptop later on, it was in English. So I presumed the setting was either in LocalStorage or Cookies. I ended up just deleting the cookies for admin.microsoft.com and it is back in English now.

 

Kinda weird that MS handled the language issue differently for Admin than the rest of O365!