Version 16.0.15225.20204 - Problems with Runtime

Copper Contributor

I have update today to the may release 16.0.15225.20204 - now i have Problems to start our Access Runtime Application. I get a message 3167 Record has delete - but their is no Record deleted.

After this there is a message - to complex.

This Problem exists ownly by the accde file - the Database accdb runs correct -

> Problem exists on both Files


21 Replies


"This Problem exists ownly by the accde file - the Database accdb runs correct"


Does it help if you create a NEW accde from the current accdb?


- I found the Problem - this Release has a Problem to use an SQL-Server table with a Primary Key of three fields (integer, nvarchar, nvarchar). In all older Versions this works in the new version it work not. The Tableview in Access shows all rows but each row shows the entry record deleted.


I changed the Fields to varchar an use another PrimaryKey. Now it works.

Just re-linking the table worked for me.
Changing the primary key might not be needed.



I think i have a similar problem but relinking the table is not enough.

I can not access my tables if the primary key is a varchar.

For the moment my only issue is to add a serial , make it the primary key and add a unique constraint corresponding to my former primary key ...

The problem seems to be linked to the last update (Version 2205 build 16.0.15225.20172-64bits)

Is the problem identified by Office team ?

Thank you for your response



Yes, this newest bug release is widely discussed in several forums.


I didn't know that it impacted the runtime as well, but version 2205 has this and other problems.

The solutions include changing the Primary Key fields from NVARCHAR to VARCHAR, or preferably, to an Identity  integer or even to a sequence (which is what you did I suspect?)

Also, it has been confirmed that ODBC drivers for SQL Server 17 and 18 are not impacted by this problem.



Actually we are working with postgresql databases and the postgresql ODBC driver ...
This problem appears with the last update of Microsoft Access (full version not runtime)
Indeed using a serial type in postgres is the same as adding a sequence but in our databases several codification tables are using varchar column type as primary key, this solution works but will bring lot of work and tests for ou Microsoft Access applications
According to your remark i am going to try with the ansi driver to see it it makes a difference

Yes, sorry. You are working with Postgres, not SQL Server. Too many bugs, too little time.
The use of ANSI driver instead of Unicode works for the moment. It may be linked to your remark of using VARCHAR instead of NVARCHAR .
Thanks and hope it will be enough for our case ..
Good luck to solve your bugs
I have updated Access today and it works fine again. The problem seems to be solved
For info, MS have just announced that the #Deleted bug fix is now available to all in the Current Channel, Current Channel (Preview), Beta, and Semi-Annual Channel (Preview).
It does not require a new build but will require closing and restarting Access to see the change. In other words, the fix was done by rolling back the change that caused the problem

Just tested & now working for me


where is link?  I need this badly. thanks


"It does not require a new build but will require closing and restarting Access to see the change. In other words, the fix was done by rolling back the change that caused the problem"

but my version # is still same and still getting #deleted in my linked tables.

not true odbc SQL Server 17 driver  still giving me #deleted

I have Microsoft Access Version 2205 Build 16.0.15225.20172 64bits version
Since friday it works again for me with sql server and with postgresql
Best regards

I am using 365 Access Version 2205 Build 16.0.15225.20204 (both 32-bit & 64-bit)


My experience (backed up by the MS Access team) is that anyone using the SQL Server 17 driver was unaffected by last week's #DELETED bug. Indeed it was one of the recommended workrounds before the fix was released

However, it sounds like your issue is unrelated,
There are other reasons why records may be shown as #DELETED.



Perhaps, then, you are being impacted by a different problem. Sorry, but in the flurry of reports about this bug, it is easy to assume such problems are all caused by it.


If your tables worked properly up until the day of the update, it's hard to think of any other reason, though. 


Can you delete and relink the tables? When you do that, do it in a back up copy of the accdb.

Make sure that all tables have a valid Primary Key and that you designate it as the Primary Key if Access asks you to do that. If any of those Primary Keys are of NVarchar datatype, this bug did impact such tables. Again, if your tables use such NVarchar datatype fields as Primary Keys, and relinking doesn't correct the problem when linked using ODBC Driver 17 or 18, then there could be some other, yet to be determined problem.

thanks for the info. It's working now.
Good work. Happy to hear you resolved it.