Problema conexión del "Nuevo navegadorEdge (WebBrowser)" de Access con informes en PowerBI

Copper Contributor

Tengo una aplicación en Access que utiliza el "Nuevo Control del navegadorEdge (WebBrowser)" para conectar con un informe en Power BI PRO (Licencia pagada).
Hasta EL 16 de diciembre de 2023 trabajó normalmente, pero dejó de funcionar aparentemente por falta de permisos de acceso a la cuenta empresarial de la licencia (@xx.onmicrosoft.com) sin mostrar errores.
Si se usa la URL pública suministrada por el sitio de Power BI, el control WebBrowser funciona correctamente.
He formateado el PC y reinstalado, actualizado y reconfigurado todas las aplicaciones relacionadas (Microsoft 365, PowerBI Descktop, Microsoft SLQ 2019, Puertas de enlace, etc. y Nada...)
El servicio de soporte de Microsoft Access me rimitió a ustedes.
¿A alguien se le ocurre lo que puede suceder?

Gracias por su atención
Fernando Uribe Jaramillo
email address removed for privacy reasons

8 Replies

@FernandoUribeJaramillo 

Lo unico que me ocure es que, en el "Nuevo Control del navegadorEdge (WebBrowser)"

uso la URL del propio PowerBI grafico, no la URL del PowerBI sitio donde se encuentra este PowerBI.

Por ejemplo:

 

="https://app.powerbi.com/view?r=eyJrIjoXXXXXXXXX..."

 

(Descuple mi pobre Español.) 

 

 

Gracias por su aporte señor George Hepworth; es cierto, extrañamente con ese link estaba funcionando bien, pero ahora ese link fue retirado del menu de opciones.

@FernandoUribeJaramillo 

 

¿No se puede "copy/paste" la URL en Control Source como aqui?

GeorgeHepworth_0-1703682821730.png

 

Gracias por su apoyo sr George Hepworth

Seguí su amable recomendación y:

Cuando utilizo la URL del tipo (https://app.powerbi.com/view?r=....) tal como ud lo propone, funciona correctamente; el problema es cuando utilizo la URL del sitio personal (https://app.powerbi.com/reportEmbed?reportId=xxxxxxxxxxxxxxxx&autoAuth=true&ctid=xxxxxxxxxxxxxxxxxxx...). En este caso me solicita el inicio de sesión (con mi cuenta empresarial) pero no responde a la apertura.

Al parecer, cuando se usa la URL del sitio personal, se está bloqueando el inicio de sesión. No sucede con su propuesta!!!
La puerta de enlace esta configurada correctamente y los informes son perfectamente visibles cuando se consultan directamente en el explorador.

Mi entorno de trabajo es el siguiente:Licencias utilizadas:

. Microsoft 365 Familia
. Power BI PRO (Pagada para un usuario).
SQL Server 2019 Express (la versión gratuita)
. Computador: ASUS ZenBook 13, RAM 16 GB
. Sistema operativo: Windows 10 Pro, 64 Bits, Versión 22H2
. Marco: Cliente 4.8.09037

Aunque la primera opción es válida, tiene sus problemas debido a que manejo información privada y delicada, y me veo obligado a pagar por la licencia Power Bi PRO para acceder a un sitio privado y personal.

agradezco su aporte y no se si el problema está en mi configuración o es un problema del PowerBI.

@George_Hepworth 

@FernandoUribeJaramillo 

Yo voy a preguntar a una compañera que tiene mas experiencia con PowerBI, pero, de lo que se, la alternativa es como dices. Una licencia de PowerBI Pro.

@FernandoUribeJaramillo 

Mejor idea. Aqui es un YouTube que incluye una discusión entre Maria y yo. 

https://www.youtube.com/watch?v=66wNedvHizk

 

Maria gives her standard excellent overview of new stuff in Access. This time its about the new Edge Browser Control. Maria is joined by George Hepworth who shows a Power BI report that can run in the new browser control, and Colin Riddington who discusses loading long URLs and local files. local

@George_Hepworth 

Magnífico video sr George Hepworth, da en el punto y me aporta mucho, muchas gracias!!!

Veo cómo por el minuto 23 se reporta el mismo problema que tengo en este momento.
pero lo cierto es que hasta el 16 de diciembre me estaba funcionando bien con la URL propia, al parecer lo arreglaron y se volvió a dañar.
Espero que así sea.

Esto soluciona mi duda de si el problema estaba en mis configuraciones o era un problema de Microsoft, al parecer es esto último.
Llevo 15 días haciendo y deshaciendo, creo que toca esperar y confiar en que solucionen el problema.

De nuevo mil gracias por su valiosa ayuda sr. Hepworth.

Feliz 2024!!!