Problem with the MsJet40.dll released with the Windows 10 KB4566782 Update

Copper Contributor

Hello,

 

We have a problem with the new MsJet40.dll version 4.0.9801.25 released with the Windows 10 KB4566782 Update

 

All "replicated' MDB database can't be open anymore with an error message :

 

" Impossible d'ouvrir la base de données 'MSysAccessObjects'. Ce n'est peut-être pas une base de données que votre application reconnaît, ou le fichier est peut être endommagé " (Sorry In french)

 

When I revert to msjet40.dll version 4.0.9801.20   the database can be openned again

 

I hope you can repair this problem. We are still using msaccess 2000, but I think this is a problem with all version using Jet engine

 

Regards,

 

Dan

38 Replies

> Basically, what Karl is asking...

 

No, Daniel, I really would like to know what I was asking for. The point is to determine if this is more an Access problem or a Windows problem.

 

 

Sorry Karl,

 

Truly didn't mean to step on your toes or insinuate not answering your questions for a single moment, it was more to encourage people to send information/feedback to Microsoft and share their issues and relevant information.

Microsoft told me to write here , and here they are telling me to write to microsoft !

This is very simple. The developper who changed the msjet40.dll code from version .24 to .25 need to correct his bug

This dll is the msjet database engine used by msaccess mdb and is automatically updated by Windows update 

The bug is very simple to reproduce, when you double clik on a MDB database file that is replicated, then msaccess can't open it anymore

I personnaly still open mdb database with msaccess 2000 exe, but I think it is the same with all msaccess versions, or openning the database by code

Hi,

It's not that simple that just someone "has to correct his bug". We are talking about versions and features of (maybe) Access that are many years out of any support and the JET dll is part of Windows not of Access in the first place. So I would like to ask about your use case again:

 

Point 3 is clear as you mentioned Access 2000. But how about 1+2? Mind, there is a difference between opening up an MDB one time with Access to control it or really working with fully fledged Access applications and experiencing the problem.

 

1) Is it that you or your users open Access to manage replicated data in an Access frontend with forms, queries etc. and it is there where they experience the replication related problem, i.e. they cant't open their Access application with Access any more?

Or

2) Is it that you just use MDB files to hold data and pilote the MDB files and replication (i.e. msjt40.dll and msjro.dll) from outside of Access like with a VB or .NET etc. application? So there is no real Access application involved, just MDB files.

 

@Karl_Donaubauer 

As I wrote, I just double clic on the file, and msaccess.exe can't open the mdb entire file anymore, since it contains replicated tabes on it

Accessing data from outside does not work too

Is there anyone working with msaccess team here, so I can send him a mdb file to open ?

 

Hi,

 

Another attempt to make my point clear which is not about the known fact that you can't open the replicated MDB files:

 

Did you do the replication by code from outside of Access (by programming it from wherever) or did you always and only work with the MDBs from within Access?

 

If we get several reports about this aspect, it would make the difference between an Access application problem in very old and unsupported versions but at least Access or a Windows problem that by accident affects MDB files. This distinction may not be easy to understand but it makes a difference in some respect (and I've tried my best until exhaustion ;-).

@Karl_Donaubauer 

second option:

MDB used for data, external application (not written in the languages you mention, but that doesn't matter) used to change, replicate, read etc data from the MDB and its companions.

 

There is no real Access application involved in this process.

 

I know that replication has been ditched after Access 2007 (if im correct). We still use the last version that supports it if need be to change things in the mdb.

 

I got 2 dumps from our tools about registry stuff, I don't think you'll be able to get things from it.

But nevertheless:

 

******************************************************************************
Error : An unhandled exception (0xC0000005) occurred inside module:
: C:\Windows\system32\msjet40.dll at 0x7AAD000E

Registers: EAX = 0x00000000 EBX = 0x00000004 ECX = 0x00000004 EDX = 0x00000000
: ESI = 0x00000000 EDI = 0x009DD968 ESP = 0x009DD8BC EBP = 0x01730AE8

 

******************************************************************************
Error : An unhandled exception (0xC0000005) occurred inside module:
: C:\Windows\system32\msjet40.dll at 0x7AAD000E

Registers: EAX = 0x00000000 EBX = 0x00000004 ECX = 0x00000004 EDX = 0x00000000
: ESI = 0x00000000 EDI = 0x0148DE70 ESP = 0x0148DDC4 EBP = 0x060E27A0

 

If you need more, I'm able to produce more.

 

As I'm not using Access, this isn't applicable
Hi Karl,

I pretty sure and definitely that the problem is related Windows 10 because the problem occurred since Windows automatic updated by KB4565351, At the same time the MSJET40.dll is updated to version 4.0.9801.25, afterward we could not open my Accesss program, we needed to rollback to MSJET40.dll 4.0.9801.24 then to be back to normal working.

For My Case:
I am using Access 2000. One frontend MDB including many forms, report and queries to connect a backend MDB which is as database including all db tables. No others and it is so simple.

Problem with MSJET40.dll 4.0.9801.25 :
I just clicked the frontend MDB, it will show below error message:
"Unable to open database 'MSysAccessObjects'. It may not be a database that your application recognizes, or the file may be damaged "

I know i am using a old Access 2000, but the problem absolutely is related to Windows updated then cause this bug and issue.

I am grateful for Access Dev. Team helping to fix the bug.

@Karl_Donaubauer 

 

Bei mir ist es wie bei OChristiaanse die 2.Option:

die MDB (A2007) wird für Datenspeicherung verwendet und eine externe Anwendung (VB) wird verwendet, um zu replizieren, lesen, schreiben usw. in der der MDB.

An diesem Prozess ist keine echte Access-Anwendung beteiligt.

 

Hi,

 

Nachdem bei einem HP-Laptop mit Win 10 x64 1909 das Update KB4565351 installiert wurde, haben die replizierte Datenbanken von Access 2003 wieder nicht funktioniert, weil damit die MsJet40.dll Version 4.0.9801.25 installiert wurde.

Das Problem betrifft also nicht nur Win 10 2004, sondern alle Versionen, bei dehnen auf MsJet40.dll Version 4.0.9801.25 aktualisiert wird.

Mit MsJet40.dll 4.0.9801.24 ging es dann aber wieder - erstmal.

 

@viadyello 

Any progress?
I'm amazed that the update still has a line like "we don't know of any problems with this update".
Might be applicable to the update process on it own, but the content has issues.

@Karl_Donaubauer 

 

Due to the MSJET40.dll 4.0.9801.25 still is fixing, I would like to suggest that Access Dev Team takes out MSJET40.dll 4.0.9801.25 and puts back  MSJET40.dll 4.0.9801.24 in both KB4566782 Update and 
KB4565351 update (may be more KBxxxxxxx) until the issue has been fixed.

 

 

@Daniel_Pineault 

Hallo,

ich glaube, das Problem sollte im Windows-Bereich bleiben oder zumindest dorthin verlinkt werden.

Es handelt sich ja hier offensichtlich um eine Fehlfunktion der msjet40.dll, die Bestandteil von Windows ist.

Einige (so wie ich) verwenden ja gar keine Access-Anwendung sondern benutzen nur mdb-Datenbanken für die Datenspeicherung.

Hi,

 

Sorry, but I'm not aware of any public announcement in this matter so far.

You can have a look at the reply a poster gave in this thread on Sep 2 and hope he's right.

 

Karl
*********
http://AccessDevCon.com
Access FAQ (German/Italian): http://donkarl.com

@alle

Gute Nachrichten :) 

Mit dem aktuellen Update (KB4571756) wird die msjet40.dll auf Version 4.0.9801.27 aktualisiert.

Diese scheint nun wieder korrekt zu funktionieren, auf unseren Testsystemen können replizierte Datenbanken geöffnet werden. 

@Tomy41 

 

YEP,

 

It seems my replicated MS Access 2003 .mdb work as used.
Thx to Microsoft for the solution and staying on the path to support older products.

btw. - I made a copy of that 'good working' msnet40.dll version 27 and added it to my collection 20, 24.

Problem Solved

 

Thanks to Microsoft Teams

My problem has been solved by msjet40.dll Version 4.0.9801.27.

Thanks to Access Dev. Team