Problem with the MsJet40.dll released with the Windows 10 KB4566782 Update

Copper Contributor



We have a problem with the new MsJet40.dll version 4.0.9801.25 released with the Windows 10 KB4566782 Update


All "replicated' MDB database can't be open anymore with an error message :


" Impossible d'ouvrir la base de données 'MSysAccessObjects'. Ce n'est peut-être pas une base de données que votre application reconnaît, ou le fichier est peut être endommagé " (Sorry In french)


When I revert to msjet40.dll version 4.0.9801.20   the database can be openned again


I hope you can repair this problem. We are still using msaccess 2000, but I think this is a problem with all version using Jet engine





38 Replies

I have same problem. I hope Microsoft to fix it asap.

Could you be suffering from this will know bug caused by a faulty Windows 10 update?

@Daniel_Pineault No, this is a very new problem with the new August 2020 Windows 10 update. The database are not corrupted, but can't be openned with the new msjet40.dll. 

Reverting to the previous version of the dll, and the database can be openned

FYI, I've passed this thread along to the Access Dev Team.

@Daniel_Pineault Thank you ! let me know when you get an answer from the great Access Dev Team


For now, we need to replace the new msjet40.dll by the old one to 3000 users... As they all call us because our program does not work anymore

For this, we need to change the owner of the file from TrustedInstaller... and paste the old version of the file

Not very clean...


Danke für deinen Hinweis auf die MSJet40.dll, hat mich auf den richtigen Weg gebracht :)


Auch wir verschwenden nun unsere Zeit damit, an Hunderten Arbeitsplätzen unserer Anwender diese dll zurückzusetzen.
Hoffentlich wird hier bald eine Korrektur erfolgen oder ein eleganterer Lösungsweg aufgezeigt.


Since installing KB4566782 Win 10 2004 x-64 on 2 PC's I have the same problem and it is not only with replicated databases but also with non Microsoft programs that use my replicated Access 2003 .mdb databases like Fibotrader.
First, at 12/08/2020 I installed the KB4566782 at a laptop and next day my replicated Access 2003 databases since them is no longer accessible, further destroys themself when closing after opening creating a second RegSync database.
To find out for sure where the problem comes from, I used a second rarely used HP Desktop PC and installed first the Windows 10 2004 x-64Net-Framework KB4569745 Update, restarted new for installation and all worked as before without any error.
Then I installed the KB4566782 and after restart the MS Access 2003 database could not accessed with the 3049 Error message. 

Also it is not possible to restore from any previous restore points - I tried 4 different - because Windows 10 has problem to restore the file: C:\Windows\SysWOW64\DevDispItemprovider.dll


Repairing Access 2003 with the DVD helps nothing.

I had this error over a year before and Microsoft fix it after some days. I hope they do this again.

thx for help

Hi @Dan2000 


I have the same problem, but for me it came in the KB4565351 cumulative update.


Replacing the dll is easier and less dangerous than uninstalling the update (and pausing updates, so that Windows doesn't immediately reinstall it), which is what I did.


Keep well,


I exactly same problem with you after udpated KB4565351.

I got many complaints from my users due to MSjet40.dll issue.

Error Message:
Unable to open database 'MSysAccessObjects'. It may not be a database that your application recognizes, or the file may be damaged "

I restored manually from the MSjet40.dll 4.0.9801.25 to MSjet40.dll 4.0.9801.24 then my MS Access 2003 program resumed normal.

@PatrickLee2195 Maybe you can post here the latest working version here of the dll?



MSjet40.dll 4.0.9801.25 did not work after udpated KB4565351


Latest working dll is MSjet40.dll 4.0.9801.24.



heute hab ich - nachdem Microsoft seit 12.08.2020 bis 20.08.2020 (7 Tage) kein Update für den BUG aus KB4566782 bereitstellen konnte - auf einem wenig genutzten HP Desktop-PC die "fehlerbehaftete" Datei msjet40.dll Version 4.0.9801.25 durch die funktionsfähige Version 4.0.9801.24 ausgetauscht, die ich durch SUCHE in Windows gefunden habe.

In C:\Windows\sysWOW64 den Besitzer von msjet40.dll von TrustedInstaller auf Administratoren mit Vollzugriff geändert und 4.0.9801.24 reinkopiert. Die Datei wird vom System automatische im Ordner z.B. "C:\Windows\WinSxS\x86_microsoft-windows-m..-components-jetcore_31bf3856ad364e35_10.0.19041.450_none_8658938a4e325c3b" aktualisiert und hat dann auch statt 4.0.9801.25 die Versionsnummer 4.0.9801.24 - eine Art Sicherungscache, vermute ich mal mit Vorbehalt.
Die ersetzte Version und die drüberkopierte habe ich mal zur Sicherheit gesichert und bewahre alles samt Info in einem Ordner auf Festplatte und USB-Stick auf, wenn das Problem "wiedermal" auftaucht.

Vorher habe ich zur Sicherheit einen Wiederherstellungspunkt erstellt und nachdem es funktioniert hat, nochmals einen.
ich werde noch ein Sicherungsimage von C: erstellen, man weiß ja nie, was noch passiert.

Nachdem auch nach einem Neustart noch alles wieder gut funktioniert hat, hab ich den selben Vorgang auf dem wichtigerem Laptop durchgeführt und da werde ich auch das Sicherungsimage von C: erstellen.


Danke für die Unterstützung bei der Eingrenzung des Problems.


@PatrickLee2195 Yes can you post it here? as I don't have found it 



Here you go. See the attachment.


I found in my "C:\Windows\SysWOW64" directory.


Sorry for reply you late. please follow @viadyello to get ownership of msjet40.dll and below @GuWag's helpful information.

For how to get ownership of msjet40.dll, you may refer below video:

The video is showing not exactly case but similar for that.


Any response from the Access dev team?


The silence is deafening.



The issue must be fixed asap by Access Team. I am afraid my Access Program getting same problem again later, because Microsoft will be automatic updated suddenly, thus, I need to repeat the MSjet40.dll restoration.


Please Access Team!

@PatrickLee2195 @OChristiaanse @Dan2000 and all other affected people:


For the discussions with Microsoft it would be helpful to know to what extent you are talking about real Access applications. Therefore a few questions:


1) Is it that you or your users open Access to manage replicated data in an Access frontend with forms, queries etc. and it is there where they experience the replication related problem, i.e. they cant't open their Access application with Access any more?




2) Is it that you just use MDB files to hold data and pilote the MDB files and replication (i.e. msjt40.dll and msjro.dll) from outside of Access like with a VB or .NET etc. application? So there is no real Access application involved, just MDB files.


3) If Access is really involved, which version(s) of Access do you use?



I'd urge you to use the Feedback command from within Access itself with all the details: Access version, bitness, build, is Access both front-end and back-end (if not front-end then what is, similarly for backend), exact steps to reproduce the issue, what changed (if you know) - when did it previously work, and be sure to include your email address so they can follow-up if need be.

Good luck.