Problem with combobox form controls

Brass Contributor

I'm using exactly the same accdb in two computers. One is Win10 the other has been updated (fresh install) to Win11.

In the win10 computer, form's Combobox controls are working as they should, narrowing and presenting possible values as you type in it.

But in Win11 most of the times that doesn't work and I type without getting any hint from the list.


If I expand down the Combobox, the list is filled, so it is not a problem with the control source, and results matching what is already write are there.


This is a really big problem and make very, very difficult to work, so I ask you please to check the problem as soon as possible.

44 Replies

@José Francisco Ruiz 

While this is, indeed, a frustrating situation, I'm sure, you're probably not reaching the right audience with your request to "check the problem". That's because forums like this are NOT staffed by Microsoft support people. Rather, almost all of the participants are Access developers who share their experience and knowledge as peers. We have no control over what Microsoft does, or does not do. We can recommend and request, of course. 

That said, it sounds like there might be some problem with Windows 11 on your computer. Replicating that problem is the first step to getting help. Can you upload a copy of an accdb exhibiting this problem? I don't have Windows 11 installed, but perhaps someone else who does have it already could examine it for you and eventually offer ideas about dealing with the problem.

I contacted the support chat included with my Microsoft 365 subscription and was told that they didn't know about Access, except for installation and activation issues, and that I had to request assistance by accessing a link that brought me here, so despite knowing the nature of this invaluable forum, I posted thinking that official Access technicians were also here. I am sorry for the misunderstanding.

That said, I greatly appreciate your interest and would be happy to upload my acddb, but at the moment it is unfeasible, as it is a complex and very bulky development that requires going through an online installation and activation process without which it is impossible to start it, so it would be useless.

I would like to point out, in any case, that if the forms works perfectly in Windows 10 and the problem occurs only in windows 11 (I have already tested in two different machines) being something apparently as basic as the population of the text of a combobox while writing in it, it must be because something has changed in the operating system, without Access has adapted to it (I know it sounds strange, but I really can't find another explanation) and that's why I tried to request support, because I am developing with access and VBA for nearly 30 years and normally able to find what is my fault.

In the next days I will continue trying to isolate the problem to prepare and upload a trimmed version that allows to check what I say.

Thanks again.

@José Francisco Ruiz 


Window 11 has been a problem with Access, the best you can do is to have both machines use window 10. I had a similar issue as wello



I do not control all users of my app, so that is not an option. If there is a bug it should be fixed
As I noted, I don't have Windows 11 yet. I'm waiting for a "green light" in the form of seeing experiences of others, like this one, resolved....

That said, I'll try to bring the problem to the attention of someone who might be able to help.
That will be great. I appreciate your help!!!

Meanwhile, I continue debugging myself and find that problematic comboboxes may be only the ones in unbounded forms, with a query as control source. In some other comboxes with form recordset fields behind, all seem to be working as usual. I need to do more checking anyway...
I created a blank new form with a combobox. It has a RowSource (that's probably what you meant when you said ControlSource) that is a query. Is running just fine on Win11 and is doing its normal progressive search.
Neither do I see this issue.
Access Version 2209 (Build 15629.20208 Click to Run) Current channel.
Windows 11 Enterprise 21H2 Build 22000.1098
Thanks @Tom_van_Stiphout & Gustav Brock.

I will try in an empty new form a little later, but really don't understand what can be interfering here. As I say it work in a win10 but don't works in win11 install....
Is there any chance the Access version is also different on the two OSes?

I'm back from a trip and checking...


Both computers have the same Access Version: 2009 Build 15629.20208 CTR Current Chanel.


Now, I will try to reproduce problem in a newly created db

In a clean database, with a new form and not so complex control row source it works as usual.

The question now is why in my original db it works only in W10 but not on W11?
But I understand that is mainly my problem...

I'm sorry to have take your time.
Thanks again.

Things happen. You could recreate the form, and it will probably work as intended.

May someone please have a look into this db? I'm really out of clues...

It is a newly created one, like the two tables, the stored query, and the only form.


In the form I have inserted two Comboboxes. The first works as it should and gets target value as you type, the second doesn't do that in Windows 11 system (where I design the db) but it works perfectly in a Windows 10 system.


I have try in another computer with windows 11 / Microsoft 365 installed, and problem is there too 

Is there any explanation for that?

@Gustav Brock @George Hepworth @Tom_van_Stiphout  


Wondering why I didn't get any comment about the database I thought I had included with my last message, as it is clear to me that it at least confirms an Access / Windows 11 interaction error, I entered the thread of my question and saw that in fact the accdb was not uploaded because of a file compatibility problem*.

So I'm re-uploading it in a zip file in the hope that someone can give me a clue.

*the attachment's database1.accdb content type (application/octet-stream) does not match its file extension and has been removed

They work as intended here.
Access Version 2209 (Build 15629.20208 Click to run) Current channel.
Windows 11 Enterprise 21H2 Build 22000.1098

@Gustav Brock 

I have tried in two different windows 11 / Ms 365 installs, both fully updated, and the 2nd combobox does not work in none of them, while it does in Windows 10.


Data is in the list, but doesn't get to the field while I type in it...


Now I'm completely out of my depth...


Thanks for your interest and collaboration.

Can't tell. AutoComplete is set to Yes for both and both work very well here.

Hi @Gustav Brock ,

I have experienced a similar problem with the MS Access combobox on Win 11, however, my problem is that the auto-expand feature stops working beyond the 100th row. So if the initial text that I type is the start of any one of the first 100 values of the bound column, then auto-expand works fine, however, when typing the initial text of the values for rows 101 and beyond, I get no auto-expand result.

Our respective experiences seem to indicate a possible difference between Win 10 & Win 11 for the MS Access combobox. I have been putting up with this problem for about a year and a half, after I changed from Win 10 to Win 11. I had tried searching the web for a solution a few times since encountering the issue, however, it never occurred to me that the underlying issue could be the difference between Win 11 & Win 10.  I'm sorry that I do not have any solution to offer for this apparent issue with the MS Access combobox on Win 11, however, I thought it was worth posting a reply in support of your issue because this is a very a similar issue for me too.

FYI, the row sources of my bound columns are queries of tables, and the columns being bound to are of type text. I have 3 combo boxes that are affected: two with 261 rows in the rowsource, and one other with around 10,400 rows for the row source; and hence I hit my problem of this apparent "100 row" limit on auto-expand.



1 best response

Accepted Solutions
best response confirmed by José Francisco Ruiz (Brass Contributor)

A fix for this problem is in the works. See this AccessForever article. 

View solution in original post