Copilot for Microsoft 365 Tech Accelerator
Feb 28 2024 07:00 AM - Feb 29 2024 10:30 AM (PST)
Microsoft Tech Community

Office pro 2021 version 2205 build 15225.20204 Bug access sql linked table #delete

Copper Contributor

I have bug  with this new version , some off my linked table  (slq native client 10) diplay #delete in all colums.

I have other computers with an old version they work perfectly.

What can i do to solve this bug ?

Gil

15 Replies
It works also with : ODBC Driver 11 for SQL Server
thanks

@gil_gentien 

 

access 365, I try to make with odbc driver 17 but when link table again  I not saw system DSN .

and then I saw odbc driver 17 only not saw another version 

I use MySQL from Access via MySQL ODBC Driver,
after 2205 update, some of tables also display #delete.
first aid
Restore from 2205----> to 2204
open command prompt (admin mode)
(paste)
cd %ProgramFiles%\Common Files\Microsoft Shared\ClickToRun
(next line paste)
officec2rclient.exe /update user updatetoversion=16.0.15128.20248
then automatically rollback
after this
Access account info panel
office365 autoupdate----> off
until this problem is solved

@KenzoSoZy 

Hi

We have the same problem with postgresql tables linked via ODBC driver 

For the moment we have two solutions :

The first is to change all the tables having a non numeric primary key by adding a new numeric key (sequence) and keeping a unique constraint for the former one . It seems to work but it represents some work ..

The second solution is to use the Postgresl ODBC ANSI driver instead of the UNICODE driver. It makes the job for us

 

The best would be to solve the bug inside Microsoft Access but for the moment i have seen no news about it.

regards

 

this is from another thread I'm on, I can't validate as the move to ODBC 17 work as a fix for me yesterday...
""
George Hepworth replied to George Hepworth
‎Jun 01 2022 04:11 PM

The MS Access team is reporting that this is now fixed.

"This should be fixed now in Current Channel (Preview) channel now, and the fix should be in Current Channel tomorrow."

""
Hi
I have updated Access today and it works fine again. The problem seems to be solved
Thanks

@JoneSh77 

 

Hi - thanks for the update.  Could you (or anyone else who has received the fix) post your current Office version and channel?  It still hasn't shown up for me.

 

Thanks.

For info, MS have just announced that the #Deleted bug fix is now available to all in the Current Channel, Current Channel (Preview), Beta, and Semi-Annual Channel (Preview).
It does not require a new build but will require closing and restarting Access to see the change. In other words, the fix was done by rolling back the change that caused the problem

Just tested & now working for me
where is bug fix. I need this very very badly for my self and others on my team. thx
Hi
at Jun 07 2022. It's OK. I can to open table link from ms SQL. don't show #Delete and My office version is 2205( Build 15225.20204)
Thanks

Hi,
Sorry for the delay
I have Microsoft Access Version 2205 Build 16.0.15225.20172 64bits version
Since friday it works again for me with sql server and with postgresql
Best regards

Thanks, I can confirm this also - 32-bit version 2205 build 15225.20204 no longer causes tables with an nvarchar in the Primary Key display as #Deleted