Missing functions in Encrypted Access Application

%3CLINGO-SUB%20id%3D%22lingo-sub-1426561%22%20slang%3D%22en-US%22%3EMissing%20functions%20in%20Encrypted%20Access%20Application%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1426561%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20an%20Access%202000%20.adp%20application%20that%20uses%20VBA%20functions%20like%20Trim%2C%20DateDiff%20etc.%20Using%20Access%202010%20with%20the%20unencrypted%20application%20all%20the%20functions%20work%20properly%20(All%20the%20References%20are%20present).%26nbsp%3B%20However%2C%20when%20I%20encrypt%20the%20application%20and%20use%20the%20encrypted%20version%20the%20functions%20are%20not%20found.%20This%20problem%20only%20appears%20on%202%20of%2030%20machines.%20Any%20ideas%20what%20I%20need%20to%20do%20to%20these%202%20computers%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1426561%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAccess%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1426651%22%20slang%3D%22en-US%22%3ERe%3A%20Missing%20functions%20in%20Encrypted%20Access%20Application%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1426651%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F683457%22%20target%3D%22_blank%22%3E%40dpindy%3C%2FA%3E%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EFor%20starters%2C%20ADPs%20have%20been%20deprecated%20for%20quite%20a%20while%20so%20continuing%20to%20use%20them%20poses%20some%20risk%20in%20any%20case.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20most%20likely%20problem%20is%20that%20the%202%20problem%20computers%20have%20different%20versions%20of%20Access.%20Have%20you%20confirmed%20that%20all%20of%20your%20computers%2C%20including%20the%20one%20on%20which%20you%20perform%20the%20encryption%2C%20have%20the%20same%20version%20of%20Access%20with%20all%20updates%20applied%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAnd%20by%20%22encryption%22%20could%20you%20clarify%20how%20that%20is%20done%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1440119%22%20slang%3D%22en-US%22%3ERe%3A%20Missing%20functions%20in%20Encrypted%20Access%20Application%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1440119%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F46682%22%20target%3D%22_blank%22%3E%40George%20Hepworth%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%202%20problem%20computers%20(as%20well%20as%20most%20of%20the%20other%2028)%20use%20Access%202010%20Runtime.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAs%20I%20mentioned%2C%20the%20application%20was%20originally%20written%20using%20Access%202000.%26nbsp%3B%20It%20is%20encrypted%20by%20opening%20the%20application%20in%20Access%202000%2C%20compiling%20it%20then%20going%20to%20Tools%3B%20Database%20Utilities%3B%20Make%20an%20.ade%20file.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1440545%22%20slang%3D%22en-US%22%3ERe%3A%20Missing%20functions%20in%20Encrypted%20Access%20Application%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1440545%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F683457%22%20target%3D%22_blank%22%3E%40dpindy%3C%2FA%3E%26nbsp%3BThanks%20for%20the%20clarification.%20You%20are%20creating%20an%20.ade%26nbsp%3B%20from%20an.adp%20then.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20problem%20may%20be%20that%20the%202%20computers%20in%20question%20have%20been%20updated%20with%20newer%20versions%20of%20Office.%20I%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

I have an Access 2000 .adp application that uses VBA functions like Trim, DateDiff etc. Using Access 2010 with the unencrypted application all the functions work properly (All the References are present).  However, when I encrypt the application and use the encrypted version the functions are not found. This problem only appears on 2 of 30 machines. Any ideas what I need to do to these 2 computers?

3 Replies
Highlighted

@dpindy  

 

For starters, ADPs have been deprecated for quite a while so continuing to use them poses some risk in any case.

 

The most likely problem is that the 2 problem computers have different versions of Access. Have you confirmed that all of your computers, including the one on which you perform the encryption, have the same version of Access with all updates applied?

 

And by "encryption" could you clarify how that is done?

Highlighted

@George Hepworth 

 

The 2 problem computers (as well as most of the other 28) use Access 2010 Runtime.  

 

As I mentioned, the application was originally written using Access 2000.  It is encrypted by opening the application in Access 2000, compiling it then going to Tools; Database Utilities; Make an .ade file.

 

Highlighted

@dpindy Thanks for the clarification. You are creating an .ade  from an.adp then.

 

The problem may be that the 2 computers in question have been updated with newer versions of Office. I