Microsoft Access Reusing Record ID's

%3CLINGO-SUB%20id%3D%22lingo-sub-797205%22%20slang%3D%22en-US%22%3EMicrosoft%20Access%20Reusing%20Record%20ID's%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-797205%22%20slang%3D%22en-US%22%3EI%20have%20a%20(Microsoft%20access%20office%20365%20database).%20I%20have%20a%20number%20of%20records%20in%20a%20table%20in%20the%20database.%20Lets%20say%20I%20have%205%20records%20numbered%201%20to%205%20respectfully.%20now%20when%20I%20delete%20record%20number%203.%20Record%20number%203%20is%20now%20gone.%20The%20problem%20I%20am%20having%20is%20when%20I%20create%20a%20new%20record%20I%20see%20that%20record%20number%203%20is%20being%20used%20again%20as%20a%20record%20number%20despite%20the%20fact%20that%20record%20number%203%20has%20been%20deleted.%20This%20to%20me%20should%20not%20be%20happening.%20I%20recently%20upgraded%20the%20Microsoft%20Access%20Database%20Engine%20redistributable%202016%20on%20our%20server%20from%202010.%20Thinking%20this%20might%20resolve%20the%20problem.%20The%20data%20type%20and%20primary%20key%20for%20the%20archiveID%20field%20is%20AutoNumber.%20Please%20advise.%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-797205%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAccess%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-798950%22%20slang%3D%22en-US%22%3ERe%3A%20Microsoft%20Access%20Reusing%20Record%20ID's%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-798950%22%20slang%3D%22en-US%22%3E%3CDIV%20class%3D%22lia-spoiler-container%22%3E%3CA%20class%3D%22lia-spoiler-link%22%20href%3D%22%23%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%20target%3D%22_blank%22%3ESpoiler%3C%2FA%3E%3CNOSCRIPT%3E(Highlight%20to%20read)%3C%2FNOSCRIPT%3E%3CDIV%20class%3D%22lia-spoiler-border%22%3E%3CDIV%20class%3D%22lia-spoiler-content%22%3EUse%20your%20own%20record%20number%20field%20don't%20use%20the%20automatically%20generated%20id%20field.%3C%2FDIV%3E%3CNOSCRIPT%3E%3CDIV%20class%3D%22lia-spoiler-noscript-container%22%3E%3CDIV%20class%3D%22lia-spoiler-noscript-content%22%3EUse%20your%20own%20record%20number%20field%20don't%20use%20the%20automatically%20generated%20id%20field.%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FNOSCRIPT%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-799164%22%20slang%3D%22en-US%22%3ERe%3A%20Microsoft%20Access%20Reusing%20Record%20ID's%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-799164%22%20slang%3D%22en-US%22%3EUnfortunately%20I%20use%20the%20autonumber%20as%20a%20record%20ID%20data%20type%20field%20in%20the%20table.%20I%20have%20about%20five%20hundred%20entries%20in%20the%20table.%20Even%20at%20this%20stage%20can%20I%20use%20my%20own%20record%20numbering%20system%3F%20I%20am%20not%20sure%20how%20to%20implement%20my%20own%20record%20numbering%20system.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-799661%22%20slang%3D%22en-US%22%3ERe%3A%20Microsoft%20Access%20Reusing%20Record%20ID's%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-799661%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F338982%22%20target%3D%22_blank%22%3E%40DEGAN1000%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20autonumber%20field%20is%20not%20re-using%20numbers.%20You%20must%20have%20a%20other%20problem.%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20number%20in%20the%20forms%20what%20is%20showing%20recordnumbers%20(on%20the%20bottom)%20is%20a%20count%20of%20records%20and%20not%20the%20autonumber%20as%20you%20mentioned.%20Maybe%26nbsp%3B%20your%20confusing%20those%20two.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EGreetings%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMarcel%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor
I have a (Microsoft access office 365 database). I have a number of records in a table in the database. Lets say I have 5 records numbered 1 to 5 respectfully. now when I delete record number 3. Record number 3 is now gone. The problem I am having is when I create a new record I see that record number 3 is being used again as a record number despite the fact that record number 3 has been deleted. This to me should not be happening. I recently upgraded the Microsoft Access Database Engine redistributable 2016 on our server from 2010. Thinking this might resolve the problem. The data type and primary key for the archiveID field is AutoNumber. Please advise.
3 Replies
Highlighted
Spoiler
Use your own record number field don't use the automatically generated id field.
Highlighted
Unfortunately I use the autonumber as a record ID data type field in the table. I have about five hundred entries in the table. Even at this stage can I use my own record numbering system? I am not sure how to implement my own record numbering system.
Highlighted

@DEGAN1000 

 

The autonumber field is not re-using numbers. You must have a other problem. 

The number in the forms what is showing recordnumbers (on the bottom) is a count of records and not the autonumber as you mentioned. Maybe  your confusing those two. 

 

Greetings,

 

Marcel