Microsoft Access 2021 keeps on crashing (Mac M1 Pro, Parallels Desktop v17, Windows 11 ARM)

Copper Contributor

I had purchased Microsoft Office 2019, but MS Access database (Windows 11 ARM with Parallels Desktop V17 on Mac M1 Pro) crashes as soon as I open/create mdb file. So, I just purchased Microsoft Office 2021 Product Activation Key, but crashes as well.

It does not give any error message. It opens up Access normally. When I create a new database or try to open up existing mdb file, it crashes with no errors; just turns off.


I have tried everything on my end. Completely uninstalling Office 2019 and 2021 many times. Rebuilding Parallels Desktop with the latest Windows 11 ARMs version. Microsoft Access is the only application that is having problems. All other applications are working fine including Word, Excel, PowerPoint, Publisher, OneNotes, Quicken, QuickBooks, Adobe PDF, etc.

Even Mac support and Parallels Desktop support even several Microsoft Tier1 support, and they have no idea why this is happening.


Please help. 


Thank you

22 Replies
None of the workarounds stated in the link below works.

Please provide actual workaround or a fix that works for MS Access 2021 on Windows 11 ARMS-M1 with Parallels Desktop v17.

Thank you
This issue is still not resolved.

Nobody seems to have an answer for this. Parallels Desktop support did diagnostics and found no issue with their product. Apple Mac support verified all the other apps are working fine. The only issue is Microsoft Access Database, which Microsoft will have to provide a fix for M1 Pro Mac with Parallels Desktop w/ Windows 11 ARM install base.

Thank you,

I am having the same issue.  Have tried reinstalling Windows.  Access will open, but the minute it tries loading a file it says "the last time you opened <filename> it cause a series error.  Do you want to open it?" And when you say "Yes", Access just completely quits.    @mbatpatel 

@dumland @mbatpatel 


Have you reported this to Microsoft directly? This forum is for peer-to-peer support. It is frequented mostly by other Access developers who volunteer their time to help other developers. For that reason, we're not in a position to address what sounds like a possible bug in the way Windows 11 runs under Parallels.
As an aside, it seems to me that one of the things involved here is the problem is on Windows 11 ARM, which is relatively new. One thing neither of you has included in your posts here is whether you are using 32 bit or 64 bit Office. I don't know if that is a factor in this particular problem, but it's worth considering. It's also important to note what drivers might be available in your environments.


In short, none of the references I can find in a quick internet search offer a definitive answer, but it does look like this just might be a case where Microsoft has yet to address all of the issues for this particular environment. After all, it's been a few months since Windows 11 was actually released, and we all know that the early adopters of new software tend to be the "early testers" for that software.

You might also consult this page for the latest on where Windows 11 stands.


After updating Access to Microsoft Access 2021 MSO Version 2112 (Build 14827.20158 Klick-und-Los) 64 Bit it now is working.

(+ also installing the latest windows 11 built (22543.1000 rs_prerelease).

New Database is opening and an existing database is starting.

See also the threads:



I've just tried modifying some App setup for Windows 11 and installed some components as you can see in the attached photos. after installation, MC Access works find on Parallel Desktop V17 on MacOs M1



Thank you. The situation, then, is resolved by properly installing Windows 11 under Parallels? And by properly, I mean that you have to know which features to include? Is there documentation available for this process? Thanks.
Thanks, I hope it resolves problems to as many people as possible, today i remembered some old reports while releasing Windows 11, that Microsoft changed the .Net structure/privileges, so one of the components I added is .Net old version and "Legacy Components" and "Virtual Machine Platform", which i believe helped to solve my problem.


Creating New files now working well, same applies to opening existing database files



After updating Microsoft Access 2021 MSO Version 2112 (Build 14827.20158 Klick-und-Los) 64 Bit it now is working (without changing the above mentioned App Setup for Windows 11).
The MS Office Update seems to fix the problem.
(I also installed the latest windows 11 built (22543.1000 rs_prerelease).

-> New Database is opening and
-> existing database is starting

See also the threads:
I am having the exact same problem with the same hardware/software configuration. I have tried everything but nothing works so far.
Read the previous replies. There have been reported successes with configuring this environment to work properly.
Thank you @EyadLearner, that screenshot was enough to solve my problem. Much appreciated!



I would just like to add a hint on a Microsoft Feedback suggestion for a long term solution:


Bring Access to Apple Macintosh platform


Maybe one or the other from this thread wants to vote for it.


Access News
Access DevCon



Hi, I'm having trouble with the previous step. How did you manage to load office 2021 onto parallels in the first place?


I have tried to download various image files and all of them have the same error "Sorry, there was a problem mounting the file"


Any idea/help would be greatly appreciated

This issue is resolved for me with the latest Windows patch!
Thank you!
I had purchased Microsoft Office 2021 (Windows 11 ARM with Parallels Desktop V17 on Mac M1 Pro). Everything works well, except I am not able to migrate my MS OneNote files.

Anyone knows fix for this?

Thank you