Error message - could not open table 'msysaccounts' in the workgroup information file. (error 3173)

Occasional Contributor

Dear Sir/Mdm,

I have this error message while trying to create a new database in Microsoft Access - could not open table 'msysaccounts' in the workgroup information file. (error 3173).


I have the Home Office 2019 before i install the Microsoft Access 2021.


The problem arises after i install the Microsoft 365 personal.


I have un-install and re-install the software but to no avail.

19 Replies
there is a downloadable "scrubber" (now named Microsoft Support and Recovery Assistant) for All windows installation, meaning totally uninstall and "clean" any trace of Office installation whether Click-To-run, etc.
Run this program, before installing another version of ms office.
MSysAccounts is only used if you are still using the old user level security which isn't applicable with ACCDB files
I do not have any knowledge about user security level. Can you elaborate more?


AS already mentioned, user level security was an optional feature in old MDB files but it was deprecated with the ACCDB file format introduced in Access 2007. I haven't used it in almost 15 years so I suggest you do a Bing/Google search to find out more


Try this link as a starting point:

How to Set, Manage or Remove User-Level Security from MDB File in Access 2010 (

Noted on the information.

The Access i am using is the latest so i can't understand why this legacy thing appears. Further, i am just trying to use Access 2021 to create a new database. These are the steps leading to the error message:
1. Click on Access icon to open the program.
2. Click on the icon "Blank database".
3. Click on the icon "Create".
4. The error message appears!
That seems very odd. Are you trying to create an ACCDB file or an MDB?

Check for the existence of a workgroup information file - normally called system.mdw.
If it exists - make a backup (just in case) then delete it ...if you can
It's accdb. I tried to delete the system.mdw file but it does not work.
Its probably still in use with one of your files so can't be deleted.
1. Make a backup in case you need it later
2. Try rebooting your computer then see if you can delete the MDW file immediately after restarting Windows. Do NOT open any Access app before you do so.
I have deleted the system.mdw file but I still can't create a new database after that.
What happens now? Same error or something else?
Can you show screenshots of anything relevant to this issue
I have tried the deleting the system.mdw method but it does not work.
what does "did not work" means.
it does not Totally remove all traces of your previous Office installation?
try to run the "scrubber" again and use a Registry cleaner to extra clean your registry.
After running the scrubber and reinstalling the program, I still can't create a new database.
best response confirmed by mokhc (Occasional Contributor)

I found some information from other resources and have solved the problem by using these steps:
1. First, you need to locate the file system.mdw
2. Open the visual basic editor by using Ctrl plus G keys
3. Type DoCmd.RunCommand acCmdWorkgroupAdministrator at the immediate window
4. Browse for the file system.mdw at its location after selecting Join…
Thanks for trying to help.

I believe that all you've done is made the problem 'go away' for this database.
My belief is that hasn't solved the problem for future databases.
I have created three new databases and they are working fine.