Access

Copper Contributor

Instalei o Access 2023 mas as Bases de Dados que funcionam normalmente no Access 2007 aqui não funcionam correctamente...Preciso de Ajuda

5 Replies
I installed Access 2023 but the Databases that work normally in Access 2007 here do not work correctly...as soon as I open a code page...the program is destabilized... I need help to be able to work correctly...will it be does anyone have solutions to the problem?
I installed Access 2021 but the Databases that work normally in Access 2007 here do not work correctly...as soon as I open a code page...the program is destabilized... I need help to be able to work correctly...will it be does anyone have solutions to the problem?

Your description is very vague. What exactly does 'destabilised' mean? 

Do you get any error messages? If so what?

 

I'm going to make a guess and suggest that one or both of the following apply:

1. You have installed 64-bit Access 2021 whereas A2007 is 32-bit only. If so, some conversion may be necessary

2. Some of your references don't work in A2021 & need updating.

hello, thanks for your answer...I installed the Office 2021 Pro version on a computer with Windows 10 Pro 64 bits. I went to check and found that the version of Office 2007 Enterprise is 32-bit... Can you explain to me what I should do?

I'm answering on a different workstation and have to use a different account

However, I'm also Mendip Data Systems!

 

You didn't explain what destabilized means!
What error messages do you get?
Have you checked whether there are any references marked MISSING?

The Windows bitness is irrelevant

1. Check whether the Office version is 64-bit. If that is the case, consider removing it and installing 32-bit Office 2021. Both versions are supported on your license.
2. If you want to keep 64-bit Office, you will need to convert all API declarations to the 64-bit equivalent. That isn't a simple topic that can be explained in a couple of sentences. You will need to research how that is done
3. Are you using any old ActiveX components? If so either remove them or replace with a 64-bit version if it exists