SOLVED

Access freezes when I copy a record

Occasional Contributor

Windows 11 Office 365 Access

 

Suddenly, when I copied a record in the database Access froze as if it didn't have enough memory. I tried compact and repair, repairing Office, uninstalling and reinstalling Office 365, exporting the database into CSV and importing back as text into a new table in a clean database, after that didn't work, I reduced the number of entries by 80% and imported as text into a fresh table. It still froze as soon as I control-C for 45 to 50 seconds each time.

 

A completely different Access database is experiencing a shorter delay after each control-C

 

Has anyone encountered this error or know a reputable contractor who specializes in such file specific issues?

39 Replies

@Art_Menius Yes I've had exactly the same problem over the past several weeks. I copy a row, then when I try to paste it, it freezes. When I copy from an Access query and paste it into Excel, the copy-paste is very very slow, much slower than it used to be.

Thanks. Have you been able to resolve. I have spent 3 hours with MS Business support with no progress

@Art_Menius Nope, but if I get a chance I'll try to figure it out. I think it might be happened after a recent Windows 11 update.

You know, this started for me after downloading the latest Win 11 update Monday or Tuesday
Can you be a bit more specific?
Is the data in an ACE table, or a linked SQL Server or other database table?
When you attempt to do this, are you using a form in datasheet view, in single form view, or in continuous view?
Does it also occur if you try to copy a record from the table in datasheet view?
It is in an Access table. I am in datasheet view
Yes, it occurs in any Access table or query with more than 1000 records
It started after the most recent update to Win 11
And only if the table contains more than 1,000 records?
How is the table sorted? What Indexes are on it? I am assuming that it would have a Primary Key, but please confirm that, as well.?

Also, please confirm whether this is a local table in the same accdb, a linked table in a second accdb, or a linked table in a different database, such as SQL Server.

Okay, then. I can confirm that this occurs as described in a local Access table with 300,000 records at any rate. Given that I'm going to assume there is a new problem that needs to be investigated with Microsoft. I'll see if anyone has reported this yet.

Can you also please provide answers to the questions I asked?
Yes. I just tested a table with 920 records. Cut and paste worked normally. 1100 record table experiences a freeze not as long as 4900. 31000 record table freezes completely.
Primary key is ID and the only permanent index. Sorted on whatever column needs for the immediate function. Fails have happened on several different sorts.
These are all local tables in their own Access accdb's
just did

thanks for your help
It may be a a couple of days, but I sent an alert to MS Access team.

Also, thanks for the details.

I too have this same problem of copying a record row from table and it freezes for long time.

My database is an Access .accdb, with 14,940 records and it doesn't completely freeze, but it freezes for a few minutes.  During the freeze, I've noticed that the open Access process grows in memory from around 40,000KB to around 400,000 KB before it stops growing and returns to operability.

I also have some workstations that access this same database and they are using Access 2016 without this problem.  So, it seems as though Access 2019 has a specific problem that recently occurred, probably around October 15+.

I will be watching this if any further info is needed.

Thanks
Paul

Spoiler
 

@George Hepworth Hi sorry, I didn't see these posts until now. I'm using a local Access database, Office 365, default database format, local tables in the database, nothing SQL linked. I'm copying and pasting in a query that is simply a listing of the table with sort on a date field. The table has one auto-number field (not the Access default index field). The table has approx 30,000 records, *but* in my attempts to narrow down the issue, I had created a fresh database and created a table, and had the same issue with much smaller fresh tables, e.g. 10 to 20 rows. For some new tables I didn't have the problem, others I did, and I thought that it might be because of a certain field type, e.g. date, but I haven't narrowed it down from there. The issue seems to have started after I had a Windows 11 update, but I can't be sure that it wasn't just coincidence. (However my inclination is that the Windows update started it.) The primary symptom is that if I pick a row and copy it Ctrl-C, then go to the new row line and selected it and paste, Ctrl-V, it freezes hard. Same with multiple rows. Another symptom is that there are queries I can copy and then paste into Access (I know about links from Excel to Access but that technique isn't effective with ever-growing queries), but the paste operation is extremely slow, e.g. 5 to 10 seconds to paste 1000 rows from an Access query to Excel. 

I've asked the Access team at Microsoft to investigate this and provided them with links to this and other threads reporting the same problem. It certainly looks to me like a bug as you describe it.
Thanks, much appreciated. I could always produce a screen video showing precise steps, if that would be helpful, but I'll await word from the MSC Access team.
Thanks to you both. Jon and I seem to be experiencing the same issues. Also the largest database of mine 31,000 records asked to be backed up to a new BAK file every time I open it. The MS Access team was supposed to contact me yesterday afternoon but did not which suggests they had no figured it out yet.

I have Experienced the same issue. and I immediately Uninstalled the Recent Windows Update: Cumulative Update for Windows 11 Version 22H2 for x64-based Systems (KB5019980). which Resolved the Issue. Reproduced the Issues several times by Installing and Uninstalling the very Update.@Art_Menius 

Exactly and the Update is KB5019980. Un-installing resolves the issue immediately.
Hello, that sounds exactly right because the problems occurred after I installed this update, but unfortunately Windows isn't allowing me to uninstall that update. Hopefully a Microsoft team can fix whatever bug is in that update.