Access doesn't close properly. A remaining background process can only be terminated in task manager

Copper Contributor

Since yesterday I noticed that in all my Access databases there is a problem when I close them.

When I close a database, it leaves a background process that can only be terminated in Task Manager. Without this, it is not possible to (re)open databases!

I have already checked some possible causes. It also concerns databases that I have not changed at all in recent months and that worked fine until this week. Therefore, I have to assume that it is a bug in an automatic update!

It seems that it has to do with a malfunction in the deallocation of allocated memory in VBA source code.

Did anyone experience the same problem? Are there already fixes or solutions available?

178 Replies


You are not alone. There are reports about it in all Access forums of the world. I answered it like this several times:


According to many posts in the last days M365 Current Channel version 2201 build 16.0.14827.20158 of Jan 26 causes
- a persistent .laccdb, an Access ghost process
- error 3048
cant open any more databases

- other errors like "already in use by Admin"

The only remedy so far is to revert back to an older build of M365. See also the M365 version history.


I've reported it to Microsoft, too.


Access News
Access DevCon

What about downgrading runtime versions?


Ciao Davide,


I've never done it myself. So, if somebody has been successful with the Runtime, please report/confirm it here for others.


Personally I would assume the same procedure as desribed in the linked articles also for the Runtime, i.e. with


I would expect to revert the installation back to the previous build of the Current Channel.


Access News
Access DevCon


I tried the procedure with the target version "16.0.14729.20194".
It worked fine on every full version, but nothing changed on runtime versions, they still remain 16.0.14827.20158...

I'm searching for any solution


Downgrading Office 365 to previous version solved
- error 3048 cant open any more databases
for me!
I didn't try for Run-time version

Thanks a lot

@Gommacri  How do I downgrade my version in more simple terms?  It's killing my productivity.  I presume Microsoft will deploy a fix fairly swiftly.  

I find that closing it and then rebooting the machine helps until the next time the DB is closed.

BTW I'm in England, and have been suffering this since about 1pm our time (7 hours ago) - having changed nothing, installed nothing, and have been blamed for corrupting the database ever since.

@StuBux Make the location of the database a 'Trusted Location' in the trust center. Microsoft just released a patch that caused this issue.

You can also somewhat automate it by creating a .reg script or using group policy. The settings you need are:
[HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Access\Security\Trusted Locations\DBLocation]
"Description"="Local DB Folder"
"Date"="2/2/2022 7:44 PM"

Prior to this patch, files in the Users\username\AppData folder were allowed but now they are being treated differently. It may be true for other locations as well.
Well, it worked.
The procedure is the same, just you cannot force the update after setting the version.
at the last step you have to wait that the runtime update by itself.


@NiteOwl adding the trusted location worked, amazing thank you so much.  Will MS subsequently do another patch to undo their damage?



Meanwhile, I've seen more reports that putting the database in a Trusted Folder would help. So, anyone who has problems with build 16.0.14827.20158 could try this and please report if it helped for you too. That way we can determine how generally applicable this workaround is, as various errors/problems caused by this build have been reported.


BTW If you only have the Runtime and/or don't want to write reg scripts etc. you can also use the small tool AddPath2016.exe from Gunter Avenius to define a Trusted Folder.


Access News
Access DevCon

@Karl Donaubauer Same here. Adding the database folder to trusted locations seems to work. In my case it is a UNC path.

Same issue. QuitAccess macro close the access file, but the access program with blank screen still is open, and the linked text file is still shown as open and another job that is supposed to delete the linked text file cannot delete the file. When I rename the file with suffix, the access program is closed by the QuitAccess macro. And there are other files that I have QuitAccess macro because I run all my access files by schedule, and they all seem working. Only one file is having this issue. I am going to try trusted folder option I read earlier on this thread.
I see a better solution than downgrade has been provided, good to know
Somehow I was not able to add a network folder as trusted location. I moved the file to C drive, and the file was closed properly. For now, this is the answer.

@eatmanna There is a checkbox in the Trusted Locations area for 'Allow Trusted Locations on my Network (not recommended)'. Did you make sure that was checked?

This fixed the issue for me.
Thank you so much!!

Hi all,

the trusted folder entry works perfectly with my databases, too. It is necessary to add the folder of the front end, though! (By the way: The tool of Gunter Avenius - cf. above - makes it very easy! Thanks)
THANKS VERY MUCH, FOLKS !!! I appreciate this active community very much!

What worked for me, after much flailing between 2201 and 2112 - "Online Repair" of Microsoft 365 via appwiz.cpl. This left me with 2201, which still did not work correctly (MS Access zombie process after quit). I then checked for updates - again, this was after repairing - and I was then updated from 2201 to 2108 (?!) which actually works without a problem.

I did try making Trust Center changes detailed here, which did not help in my case. Possible I wasn't adding the correct locations. Bottom line, not using version 2201 and back to normal behavior here. Hoping next official update goes better.
1 best response

Accepted Solutions
best response confirmed by Florian1290 (Copper Contributor)
Yes, here also the update available (Europe). Tested en fix the problem. Trusted Location not necessary any more. But I highly recommend it. Otherwise you will have problem starting from April. MS is blocking marcos. Check

View solution in original post