Access 2016 Compact and Repair

New Contributor

I have Access 2016 and a file I've used for many years.  I sometimes will do a compact and repair on the file and it's always worked before.  Yesterday when I tried, I got a message saying I couldn't compact and repair because the file was already is use.  I'm the only user on my home computer.  I worked with Microsoft tech support but they couldn't fix it.  The file seems to work OK except for the compact issue.  Also if I try to save a backup copy.  Thanks for any help.

2 Replies

@GaryC1971 This recent bug might be the problem.

However, you should have received the fix for it in a more recent update.


Step one is to make sure your MS Office is up-to-date.

 

Another issue that has been reported is that some Anti-Virus programs, especially McAfee, is the cause. Perhaps set an exception for Access would be appropriate in your AV if that is the problem.

Thank you for the reply. I don't have the 365 version of Access which I assume provides updates. I purchased the Office Professional package as a one time purchase. I'll try the McAfee suggestion.