Home

Hyphenating at hyphens

%3CLINGO-SUB%20id%3D%22lingo-sub-549327%22%20slang%3D%22en-US%22%3EHyphenating%20at%20hyphens%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-549327%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%20%26nbsp%3B%20It%20appears%20that%20Word%202010%20will%20not%20take%20the%20opportunity%20to%20hyphenate%20a%20word%20following%20a%20typed%20hyphen.%20For%20example%2C%20I%20would%20like%20the%20word%20%22post-processor%22%20to%20be%20split%20to%20a%20new%20line%20following%20%22post-%22%20if%20there%20is%20insufficient%20space%20on%20the%20line.%20If%20I%20use%20an%20optional%20hyphen%20then%20the%20word%20splits%20as%20expected%2C%20but%20then%20I%20don't%20get%20the%20hyphen%20when%20the%20word%20fits%20on%20a%20line.%3C%2FP%3E%3CP%3E%26nbsp%3B%20%26nbsp%3B%20Interestingly%20(well%20at%20least%20for%20me)%2C%20the%20word%20%22processor-post%22%20does%20get%20hyphenated%20following%20%22pro%22%20and%20%22proces%22%2C%20but%20not%20unfortunately%20at%20the%20hyphen.%3C%2FP%3E%3CP%3E%26nbsp%3B%20%26nbsp%3B%20Hopefully%20there%20is%20a%20setting%20or%20version%20that%20will%20solve%20this%20problem.%3C%2FP%3E%3CP%3EThanks%2C%3C%2FP%3E%3CP%3EBrian.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-549327%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EWord%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-567312%22%20slang%3D%22en-US%22%3ERe%3A%20Hyphenating%20at%20hyphens%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-567312%22%20slang%3D%22en-US%22%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20813px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F113305i6C37CFD4316999EB%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Optional%20Hyphens.PNG%22%20title%3D%22Optional%20Hyphens.PNG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F338357%22%20target%3D%22_blank%22%3E%40BrianRFrancis%3C%2FA%3E%26nbsp%3Bdoes%20your%20display%20settings%20for%20'Always%20show%20these%20formatting%20marks%20on%20the%20screen'%20have%20'Optional%20Hyphens'%20ticked%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
BrianRFrancis
Occasional Visitor

Hi,

    It appears that Word 2010 will not take the opportunity to hyphenate a word following a typed hyphen. For example, I would like the word "post-processor" to be split to a new line following "post-" if there is insufficient space on the line. If I use an optional hyphen then the word splits as expected, but then I don't get the hyphen when the word fits on a line.

    Interestingly (well at least for me), the word "processor-post" does get hyphenated following "pro" and "proces", but not unfortunately at the hyphen.

    Hopefully there is a setting or version that will solve this problem.

Thanks,

Brian.

2 Replies

Optional Hyphens.PNG

 

@BrianRFrancis does your display settings for 'Always show these formatting marks on the screen' have 'Optional Hyphens' ticked?

 

 

My Word 2010 does work "correctly", as you expect, without any additional intervention. Just type the normal hyphen between the 2 words, they wrap at the hyphen when the words approach the margin of the page. I have to be in "print layout" view. Actually I can't defeat it. Even in Web view it works correctly. The only thing I can think of is that you are not using a hyphen character, but some other character that looks like one.
Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
35 Replies
Extentions Synchronization
ChirmyRam in Discussions on
3 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies