Home

Windows Virtual Desktop - deployment problem

%3CLINGO-SUB%20id%3D%22lingo-sub-750170%22%20slang%3D%22en-US%22%3EWindows%20Virtual%20Desktop%20-%20deployment%20problem%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-750170%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3EIn%20my%20comprehension%20%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20first%20part%20is%20deploying%20infrasctructure%20in%20Azure%20(that%20make%20availability%20set%20with%20networks%2C%20machines%2C%20disks%20....)%2C%20this%20step%20is%20good.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20second%20part%20is%20deploying%20Managament%20Tool%20(to%20have%20a%20SAAS%20to%20control%20infrastructure)%2C%20in%20my%20case%20i%20get%20an%20error%20in%20this%20part.%20Through%20GitHub%20i%20deploy%20in%20Azure%20the%20template%20and%20i%20get%20a%20conflit%20error%20(see%20picture)%2C%20but%20a%20web%20page%20%22Your%20app%20service%20is%20up%20and%20runing%22)%20but%20i%20don't%20have%20managment%20tool%20web%20service.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'am%20very%20disapointed%2C%26nbsp%3BSomebody%20can%20help%20me.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-752345%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%20Virtual%20Desktop%20-%20deployment%20problem%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-752345%22%20slang%3D%22en-US%22%3EHi%2C%20tried%20to%20setup%20management%20Tool%20today%20and%20I've%20received%20the%20same%20error.%3CBR%20%2F%3EMy%20bet%20is%20that%20there%20is%20an%20error%20in%20a%20JSON%20template%20and%20Automation%20jobs%20were%20not%20running%20well..%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-754631%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%20Virtual%20Desktop%20-%20deployment%20problem%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-754631%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F141315%22%20target%3D%22_blank%22%3E%40Radek%20V%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThank%20you%2C%20i%20posted%20an%20issue%20on%20GitHub%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-764837%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%20Virtual%20Desktop%20-%20deployment%20problem%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-764837%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F374735%22%20target%3D%22_blank%22%3E%40AurelienB%3C%2FA%3E%26nbsp%3B%3CBR%20%2F%3EI%20have%20opened%20a%20ticket%20in%20Azure%20portal%20and%20received%20a%20hint%20from%20Azure%20Support%3A%3C%2FP%3E%3CDIV%3E%3CDIV%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CEM%3EWhen%20you%20use%20an%20ARM%20as%20in%20your%20case%2C%20you%20have%20to%20give%20the%20name%20of%20the%20Job%26nbsp%3Bwhich%20should%20be%20a%20unique%20ID%20if%20you%20follow%20the%20documentation%3A%3C%2FEM%3E%3C%2FP%3E%3CP%3E%3CEM%3E%3CA%20title%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Ftemplates%2Fmicrosoft.automation%2F2015-10-31%2Fautomationaccounts%2Fjobschedules%22%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Ftemplates%2FMicrosoft.Automation%2F2015-10-31%2FautomationAccounts%2FjobSchedules%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Ftemplates%2FMicrosoft.Automation%2F2015-10-31%2FautomationAccounts%2FjobSchedules%3C%2FA%3E%3C%2FEM%3E%3C%2FP%3E%3CP%3E%3CEM%3E%26nbsp%3B%3C%2FEM%3E%3C%2FP%3E%3CP%3E%3CEM%3EFor%20each%20job%20schedule%2C%20the%20'name'%20property%20is%20a%20GUID%20(Global%20Unique%20ID)%2C%20and%20this%20needs%20to%20be%20unique.%3C%2FEM%3E%3C%2FP%3E%3CP%3E%3CEM%3E%26nbsp%3B%3C%2FEM%3E%3C%2FP%3E%3CP%3E%3CEM%3EIn%20your%20case%2C%20you%20probably%20ran%20it%20once%20so%20it%20no%20longer%20got%20unique%20as%20it%20got%20hardcoded.%3C%2FEM%3E%3C%2FP%3E%3CP%3E%3CEM%3E%26nbsp%3B%3C%2FEM%3E%3C%2FP%3E%3CDIV%3E%3CEM%3EUsing%20the%20function%20guid(baseString)%26nbsp%3Bfrom%3A%26nbsp%3B%3CA%20title%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fazure-resource-manager%2Fresource-group-template-functions-string%23guid%22%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fazure-resource-manager%2Fresource-group-template-functions-string%23guid%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fazure-resource-manager%2Fresource-group-template-functions-string%23guid%3C%2FA%3E%26nbsp%3B%3C%2FEM%3E%3C%2FDIV%3E%3CDIV%3E%3CEM%3EThis%20would%20generate%20a%20unique%20ID%20on%20resource%20group%20ID%20and%20deployment%20name%3A%3C%2FEM%3E%3C%2FDIV%3E%3CP%3E%3CEM%3E%26nbsp%3B%3C%2FEM%3E%3C%2FP%3E%3CP%3E%3CEM%3E%22%5Bguid(resourceGroup().id%2C%20deployment().name)%5D%22%3C%2FEM%3E%3C%2FP%3E%3CP%3E%3CEM%3E%26nbsp%3B%3C%2FEM%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E%3CSTRONG%3ESo%20if%20the%20deployment%20is%20pushed%20twice%2C%20the%20job%20ID%20might%20not%20be%20unique%20because%20the%20template%20is%20used%20on%20the%20same%20resource%20group%2C%20hence%20generating%20the%20same%20GUID.%3C%2FSTRONG%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E%26nbsp%3B%3CBR%20%2F%3E%3C%2FSPAN%3E%3CSTRONG%3E%3CU%3EAction%20Plan%3A%3C%2FU%3E%3C%2FSTRONG%3E%3C%2FP%3E%3C%2FDIV%3E%3C%2FDIV%3E%3CDIV%3E%3CDIV%3E%3CSPAN%3EPass%20the%20current%20time%20as%20the%20parameter%20and%20use%20it%20as%20a%20base.string.%20this%20would%20generate%20a%20completely%20unique%20string.%20Then%20you%20use%20this%20to%20generate%20the%20NewGuid%3A%26nbsp%3B%3CA%20title%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fazure-resource-manager%2Fresource-group-template-functions-string%23newguid%22%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fazure-resource-manager%2Fresource-group-template-functions-string%23newguid%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fazure-resource-manager%2Fresource-group-template-functions-string%23newguid%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3EI%20have%20modified%20a%20JSON%20template%20with%20a%20code%3A%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%3CEM%3E%22utcValue%22%3A%20%7B%3CBR%20%2F%3E%22type%22%3A%20%22string%22%2C%3CBR%20%2F%3E%22defaultValue%22%3A%20%22%5ButcNow()%5D%22%3CBR%20%2F%3E%7D%2C%3C%2FEM%3E%3C%2FDIV%3E%3CDIV%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%3Ebefore%20the%20line%20starting%20with%20%22%3CSPAN%3ERDBrokerURL%22.%3CBR%20%2F%3EI%20had%20chose%20a%20different%20name%20of%20App%20Service%20as%20before%20and%20after%20this%20modification%20the%20deployment%20was%20successful.%3C%2FSPAN%3E%3CBR%20%2F%3E%3C%2FDIV%3E%3CDIV%3E%26nbsp%3B%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-769435%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%20Virtual%20Desktop%20-%20deployment%20problem%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-769435%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F141315%22%20target%3D%22_blank%22%3E%40Radek%20V%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CDIV%3E%3CDIV%3E%3CDIV%20class%3D%22gt-is%22%3E%3CDIV%20class%3D%22gt-is-ctr%22%3E%3CDIV%20class%3D%22gt-is-itm%22%3E%3CDIV%20class%3D%22gt-is-lb%22%3E%3CSPAN%3EThank%20for%20you%20reply%2C%20i%20got%20another%20way%2C%20this%20is%20the%20reply%20from%20Rachel%20from%20GitHub%20%3A%3C%2FSPAN%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FDIV%3E%3CDIV%3E%3CEM%3E%3CBR%20%2F%3EI%20got%20this%20same%20error%2C%20and%20it%20was%20due%20to%20the%20credentials%20you%20enter%20when%20deploying%20the%20Web%20App.%20While%20my%20user%20was%20a%20Global%20Admin%20(and%20an%20RDS%20Tenant%20Owner)%2C%20they%20weren't%20a%20'Contributor'%20at%20the%20Subscription%20level.%20So%20went%20into%20that%20particular%20subscription%20and%20assigned%20the%20role%20of%20contributor%2C%20and%20then%20this%20deploy%20template%20started%20working.%3C%2FEM%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FDIV%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20try%20all%20this%20in%20the%20next%20days.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERegards%3C%2FP%3E%3C%2FLINGO-BODY%3E
AurelienB
New Contributor

Hi,

In my comprehension :

 

The first part is deploying infrasctructure in Azure (that make availability set with networks, machines, disks ....), this step is good.

 

The second part is deploying Managament Tool (to have a SAAS to control infrastructure), in my case i get an error in this part. Through GitHub i deploy in Azure the template and i get a conflit error (see picture), but a web page "Your app service is up and runing") but i don't have managment tool web service.

 

I'am very disapointed, Somebody can help me.

 

Thanks

4 Replies
Hi, tried to setup management Tool today and I've received the same error.
My bet is that there is an error in a JSON template and Automation jobs were not running well..

@Radek V 

Thank you, i posted an issue on GitHub

@AurelienB 
I have opened a ticket in Azure portal and received a hint from Azure Support:

 

When you use an ARM as in your case, you have to give the name of the Job which should be a unique ID if you follow the documentation:

https://docs.microsoft.com/en-us/azure/templates/Microsoft.Automation/2015-10-31/automationAccounts/...

 

For each job schedule, the 'name' property is a GUID (Global Unique ID), and this needs to be unique.

 

In your case, you probably ran it once so it no longer got unique as it got hardcoded.

 

This would generate a unique ID on resource group ID and deployment name:

 

"[guid(resourceGroup().id, deployment().name)]"

 

So if the deployment is pushed twice, the job ID might not be unique because the template is used on the same resource group, hence generating the same GUID.

 
Action Plan:

Pass the current time as the parameter and use it as a base.string. this would generate a completely unique string. Then you use this to generate the NewGuid: https://docs.microsoft.com/en-us/azure/azure-resource-manager/resource-group-template-functions-stri...

I have modified a JSON template with a code:
"utcValue": {
"type": "string",
"defaultValue": "[utcNow()]"
},
 
before the line starting with "RDBrokerURL".
I had chose a different name of App Service as before and after this modification the deployment was successful.
 

@Radek V 

 

Thank for you reply, i got another way, this is the reply from Rachel from GitHub :

I got this same error, and it was due to the credentials you enter when deploying the Web App. While my user was a Global Admin (and an RDS Tenant Owner), they weren't a 'Contributor' at the Subscription level. So went into that particular subscription and assigned the role of contributor, and then this deploy template started working.

 

I try all this in the next days.

 

Regards

Related Conversations
Extentions Synchronization
Deleted in Discussions on
3 Replies
Tabs and Dark Mode
cjc2112 in Discussions on
36 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
29 Replies