SOLVED
Home

We couldn't connect to the gateway because of an error

%3CLINGO-SUB%20id%3D%22lingo-sub-523130%22%20slang%3D%22en-US%22%3EWe%20couldn't%20connect%20to%20the%20gateway%20because%20of%20an%20error%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-523130%22%20slang%3D%22en-US%22%3E%3CP%3EMy%20test%20account%20can%20see%20the%20VD%20in%20the%20web%20browser%20but%20I%20get%20this%20error%20every%20time%20I%20try%20to%20connect%2C%20it%20says%20%22opening%20remote%20port%22%20and%20fails.%20If%20I%20try%20to%20connect%20through%20the%20app%20I%20get%20told%20I%20do%20not%20have%20permission.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20can%20remote%20into%20the%20VD%20while%20I%20am%20controlling%20the%20server%20but%20I%20cannot%20access%20the%20VD%20as%20my%20admin%20account%20that%20I%20used%20to%20join%20the%20VD.%26nbsp%3B%3C%2FP%3E%3CP%3EIdeas%3F%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-524906%22%20slang%3D%22en-US%22%3ERe%3A%20We%20couldn't%20connect%20to%20the%20gateway%20because%20of%20an%20error%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-524906%22%20slang%3D%22en-US%22%3E%3CP%3EHI%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F332652%22%20target%3D%22_blank%22%3E%40ian11230%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20had%20the%20same%20problem%2C%20and%20to%20solve%20it%20I%20raise%20the%20word%20complix%3CBR%20%2F%3EAs%20a%20%3A%3C%2FP%3E%3CP%3Eo%20minimum%20length%2012%20characters%3CBR%20%2F%3Eo%20Capital%20letters%20of%20European%20languages%20(A%20to%20Z%2C%20with%20diacritics%2C%20Greek%20and%20Cyrillic%20characters)%3CBR%20%2F%3Eo%20Tiny%20letters%20from%20European%20languages%20(a%20to%20z%2C%20sharp-s%2C%20with%20diacritics%2C%20Greek%20and%20Cyrillic%20characters)%3CBR%20%2F%3Eo%20Figures%20in%20base%2010%20(0%20to%209)%3CBR%20%2F%3Eo%20Non-alphanumeric%20characters%20(special%20characters)%3A%20(~!%20%40%20%23%20%24%25%20%5E%20%26amp%3B%20*%20_-%20%2B%20%3D%20'%7C%20%5C%20()%20%7B%7D%20%5C%20%5B%5D%20%3A%3B%20%C2%BB%C2%BB%20%26lt%3B%26gt%3B%2C.%3F%20%2F)%20currency%20symbols%20such%20as%20l%20Euro%20or%20a%20British%20pound%20are%20not%20considered%20special%20characters%20for%20this%20policy%20setting.%3CBR%20%2F%3Eo%20The%20password%20should%20not%20be%20in%20a%20dictionary%20(dictionary%20attack)%3CBR%20%2F%3Eo%20The%20password%20should%20not%20be%20a%20subject%20known%20as%20Christmas%2C%20Easter%2C%20Carnival%2C%20etc.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-531202%22%20slang%3D%22en-US%22%3ERe%3A%20We%20couldn't%20connect%20to%20the%20gateway%20because%20of%20an%20error%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-531202%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F326415%22%20target%3D%22_blank%22%3E%40Mcinf2000%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EYou%20mean%20raise%20the%20password%20complexity%20yeah%3F%20Cause%20both%20my%20test%20account%20and%20the%20account%20I%20used%20for%20the%20UPN%20have%20the%20same%20password%20and%20it%20is%20over%2012%20characters%20and%20does%20contain%20a%20%2B%20but%20azure%20never%20complained%20about%20it%20while%20making%20the%20WVD.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-559977%22%20slang%3D%22en-US%22%3ERe%3A%20We%20couldn't%20connect%20to%20the%20gateway%20because%20of%20an%20error%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-559977%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F332652%22%20target%3D%22_blank%22%3E%40ian11230%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHello%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIs%20there%20any%20new%20info%20regarding%20this%20issue%3F%20Or%20increasing%20password%20complexity%20is%20solution%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERegards%2C%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-559980%22%20slang%3D%22en-US%22%3ERe%3A%20We%20couldn't%20connect%20to%20the%20gateway%20because%20of%20an%20error%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-559980%22%20slang%3D%22en-US%22%3EChanging%20the%20password%20complexity%20did%20not%20help.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-562665%22%20slang%3D%22en-US%22%3ERe%3A%20We%20couldn't%20connect%20to%20the%20gateway%20because%20of%20an%20error%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-562665%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F332652%22%20target%3D%22_blank%22%3E%40ian11230%3C%2FA%3E%26nbsp%3B%3CBR%20%2F%3E%3CBR%20%2F%3EI'm%20having%20the%20same%20issue.%20Managed%20to%20create%20a%20tenant%20and%20deploy%2C%20but%20can't%20login.%20I've%20added%203%20users%20via%20Powershell%20to%20the%20user%20list%2C%20none%20of%20them%20are%20able%20to%20open%20a%20desktop%20session.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EUsing%20the%20client%20(not%20the%20web%20app)%20just%20keeps%20giving%20me%20credential%20prompts%20until%20it%20locks%20out%20the%20account.%20The%20web%20app%20just%20gives%20me%20an%20error%20for%20all%203%20users.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAlso%20keep%20having%20random%20issues%20with%20powershell%20giving%20me%20%22User%20is%20not%20authorized%20to%20query%20the%20management%20service%22%20when%20I'm%20signed%20in%20with%20the%20account%20I%20created%20everything%20in%2C%20which%20is%20also%20the%20subscription%20admin.%3CBR%20%2F%3E%3CBR%20%2F%3EHave%20you%20managed%20to%20get%20any%20further%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-562684%22%20slang%3D%22en-US%22%3ERe%3A%20We%20couldn't%20connect%20to%20the%20gateway%20because%20of%20an%20error%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-562684%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F332652%22%20target%3D%22_blank%22%3E%40ian11230%3C%2FA%3E%26nbsp%3BIf%20you're%20using%20Azure%20Active%20Directory%20Domain%20Services%2C%20you%20need%20to%20make%20sure%20the%20deployed%20servers%20are%20in%20the%20%22AADDC%20Computers%22%20OU%20and%20you%20log%20in%20using%20an%20admin%20account%20that%20is%20in%20the%20%22AADDC%20Users%22%20OU.%26nbsp%3B%20Make%20sure%20the%20admin%20user%20is%20a%20member%20of%20the%20%22AAD%20DC%20Administrators%22%20group%20in%20Azure%20Active%20Directory.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20I%20did%20this%2C%20I%20was%20finally%20able%20to%20Remote%20Desktop%20directly%20into%20the%20deployed%20VM's%20in%20the%20hostgroup.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-562700%22%20slang%3D%22en-US%22%3ERe%3A%20We%20couldn't%20connect%20to%20the%20gateway%20because%20of%20an%20error%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-562700%22%20slang%3D%22en-US%22%3E%3CP%3EWhat%20about%20if%20we%20have%20on-premise%20AD%20with%20AD%20Connect%20instead%20Azure%20ADDS%3F%3CBR%20%2F%3EAlso%2C%20one%20of%20DCs%20is%20in%20Azure%20as%20VM%2C%20and%20HostPool%20machines%20are%20joined%20to%20AD.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERegards%2C%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-563808%22%20slang%3D%22en-US%22%3ERe%3A%20We%20couldn't%20connect%20to%20the%20gateway%20because%20of%20an%20error%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-563808%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F21775%22%20target%3D%22_blank%22%3E%40Conrad%20Agramont%3C%2FA%3EI%20wouldn't%20want%20to%20make%20the%20users%20any%20sort%20of%20admin%26nbsp%3B%20-%20I%20don't%20think%20that%20there%20should%20be%20a%20need%20to.%20The%20service%20should%20be%20secure%20by%20design%2C%20so%20elevating%20a%20user%20must%20surely%20be%20working%20around%20a%20problem%2C%20rather%20than%20fixing%20it's%20cause%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-564284%22%20slang%3D%22en-US%22%3ERe%3A%20We%20couldn't%20connect%20to%20the%20gateway%20because%20of%20an%20error%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-564284%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F21775%22%20target%3D%22_blank%22%3E%40Conrad%20Agramont%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECan%20you%20help%20me%20check%2Fdo%20that%3F%20I%20am%20still%20getting%20used%20to%20Azure.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-871597%22%20slang%3D%22en-US%22%3ERe%3A%20We%20couldn't%20connect%20to%20the%20gateway%20because%20of%20an%20error%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-871597%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F52144%22%20target%3D%22_blank%22%3E%40Vladimir%20Stefanovic%3C%2FA%3E%26nbsp%3BYes%2C%20we%20are%20in%20the%20same%20scenario.%20The%20error%20message%20we%20get%20when%20using%20the%20desktop%20client%20or%20the%20web%20link%20is%3A%3C%2FP%3E%3CP%3E%22%3CSPAN%3EOops%2C%20we%20couldn%E2%80%99t%20connect%20to%20%E2%80%9CUSSPA-RDSH%E2%80%9D.%20We%20couldn%E2%80%99t%20connect%20to%20the%20gateway%20because%20of%20an%20error.%20If%20this%20keeps%20happening%2C%20ask%20your%20admin%20or%20tech%20support%20for%20help.%E2%80%9D%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EAny%20ideas%3F%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-871981%22%20slang%3D%22en-US%22%3ERe%3A%20We%20couldn't%20connect%20to%20the%20gateway%20because%20of%20an%20error%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-871981%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F332652%22%20target%3D%22_blank%22%3E%40ian11230%3C%2FA%3E%26nbsp%3BWe%20had%20the%20same%20error%20message%20as%20you.%20Our%20solution%20was%20to%20start%20an%20Azure%20P2%20trial%20for%20our%20tenant.%20So%20I'm%20guessing%20it%20was%20a%20licensing%20issue%2C%20but%20I%20can't%20find%20exactly%20what%20license%20is%20required%2C%20as%20maybe%20a%20cheaper%20license%20would%20have%20sufficed.%3C%2FP%3E%3C%2FLINGO-BODY%3E
ian11230
Occasional Contributor

My test account can see the VD in the web browser but I get this error every time I try to connect, it says "opening remote port" and fails. If I try to connect through the app I get told I do not have permission. 

 

I can remote into the VD while I am controlling the server but I cannot access the VD as my admin account that I used to join the VD. 

Ideas? 

11 Replies

HI@ian11230 

 

I had the same problem, and to solve it I raise the word complix
As a :

o minimum length 12 characters
o Capital letters of European languages (A to Z, with diacritics, Greek and Cyrillic characters)
o Tiny letters from European languages (a to z, sharp-s, with diacritics, Greek and Cyrillic characters)
o Figures in base 10 (0 to 9)
o Non-alphanumeric characters (special characters): (~! @ # $% ^ & * _- + = '| \ () {} \ [] :; »» <>,.? /) currency symbols such as l Euro or a British pound are not considered special characters for this policy setting.
o The password should not be in a dictionary (dictionary attack)
o The password should not be a subject known as Christmas, Easter, Carnival, etc.

@Mcinf2000 

You mean raise the password complexity yeah? Cause both my test account and the account I used for the UPN have the same password and it is over 12 characters and does contain a + but azure never complained about it while making the WVD.

@ian11230 

 

Hello,

 

Is there any new info regarding this issue? Or increasing password complexity is solution?

 

Regards,

Changing the password complexity did not help.

@ian11230 

I'm having the same issue. Managed to create a tenant and deploy, but can't login. I've added 3 users via Powershell to the user list, none of them are able to open a desktop session.

 

Using the client (not the web app) just keeps giving me credential prompts until it locks out the account. The web app just gives me an error for all 3 users.

 

Also keep having random issues with powershell giving me "User is not authorized to query the management service" when I'm signed in with the account I created everything in, which is also the subscription admin.

Have you managed to get any further?

Solution

@ian11230 If you're using Azure Active Directory Domain Services, you need to make sure the deployed servers are in the "AADDC Computers" OU and you log in using an admin account that is in the "AADDC Users" OU.  Make sure the admin user is a member of the "AAD DC Administrators" group in Azure Active Directory.

 

When I did this, I was finally able to Remote Desktop directly into the deployed VM's in the hostgroup.

What about if we have on-premise AD with AD Connect instead Azure ADDS?
Also, one of DCs is in Azure as VM, and HostPool machines are joined to AD.

 

Regards,

@Conrad AgramontI wouldn't want to make the users any sort of admin  - I don't think that there should be a need to. The service should be secure by design, so elevating a user must surely be working around a problem, rather than fixing it's cause?

@Conrad Agramont 

Can you help me check/do that? I am still getting used to Azure.

@Vladimir Stefanovic Yes, we are in the same scenario. The error message we get when using the desktop client or the web link is:

"Oops, we couldn’t connect to “USSPA-RDSH”. We couldn’t connect to the gateway because of an error. If this keeps happening, ask your admin or tech support for help.”

 

Any ideas?

@ian11230 We had the same error message as you. Our solution was to start an Azure P2 trial for our tenant. So I'm guessing it was a licensing issue, but I can't find exactly what license is required, as maybe a cheaper license would have sufficed.

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
38 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
29 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
13 Replies