Home

WVD Deployment Failed

%3CLINGO-SUB%20id%3D%22lingo-sub-466799%22%20slang%3D%22en-US%22%3EWVD%20Deployment%20Failed%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-466799%22%20slang%3D%22en-US%22%3E%3CP%3EHaving%20worked%20through%20the%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fvirtual-desktop%2Ftenant-setup-azure-active-directory%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fvirtual-desktop%2Ftenant-setup-azure-active-directory%3C%2FA%3E%26nbsp%3Btutorials%2C%20I%20got%20to%20the%20final%20stage%2C%20but%20the%20deployment%20failed.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20see%20the%20following%20in%20the%20Activity%20Log%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3D%3D%3D%3C%2FP%3E%3CP%3EOperation%20Name%3A%20Create%20or%20Update%20Virtual%20Machine%20Extension%3C%2FP%3E%3CP%3ETime%20Stamp%3A%20%3CTIME%3E%3C%2FTIME%3E%3C%2FP%3E%3CP%3EEvent%20initiated%20by%3A%20%3CME%3E%3C%2FME%3E%3C%2FP%3E%3CP%3EError%20code%3A%20ResourceOperationFailure%3C%2FP%3E%3CP%3EMessage%3A%20The%20resource%20operation%20completed%20with%20terminal%20provisioning%20state%20'Failed'.%3C%2FP%3E%3CP%3E%3D%3D%3D%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3D%3D%3D%3C%2FP%3E%3CP%3EOperation%20Name%3A%20Create%20Deployment%3C%2FP%3E%3CP%3ETime%20Stamp%3A%20%3CTIME%3E%3C%2FTIME%3E%3C%2FP%3E%3CP%3EEvent%20initiated%20by%3A%20%3CME%3E%3C%2FME%3E%3C%2FP%3E%3CP%3E%3D%3D%3D%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3D%3D%3D%3C%2FP%3E%3CP%3EOperation%20Name%3A%20Create%20or%20Update%20Virtual%20Machine%20Extension%3C%2FP%3E%3CP%3ETime%20Stamp%3A%20%3CTIME%3E%3C%2FTIME%3E%3C%2FP%3E%3CP%3EEvent%20initiated%20by%3A%20%3CME%3E%3C%2FME%3E%3C%2FP%3E%3CP%3EError%20code%3A%20ResourceDeploymentFailure%3C%2FP%3E%3CP%3EMessage%3A%20The%20resource%20operation%20completed%20with%20terminal%20provisioning%20state%20'Failed'.%3C%2FP%3E%3CP%3E%3D%3D%3D%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHow%20do%20I%20go%20about%20diagnosing%20what%20has%20failed%3F%20I%20can%20see%20the%20VM%20%2F%20Disk%20%2F%20NIC%20%2F%20Availability%20Set%20have%20been%20created%2C%20but%20I%20can't%20see%20anything%20when%20I%20try%20to%20connect%20to%20the%20remote%20desktop%2C%20either%20by%20client%20or%20web.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20help%20will%20be%20gratefully%20received!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ER%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-466799%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3Erichard.evans%40finsbury.com%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-471578%22%20slang%3D%22en-US%22%3ERe%3A%20WVD%20Deployment%20Failed%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-471578%22%20slang%3D%22en-US%22%3EIn%20case%20anyone%20gets%20something%20similar...%20Following%20fixed%20the%20issue...%3CBR%20%2F%3E%3CBR%20%2F%3EI%20deleted%20the%20entire%20resource%20group%20to%20start%20afresh%2C%20and%20used%20%3CA%20href%3D%22https%3A%2F%2Ferjenrijnders.nl%2F2019%2F04%2F04%2Fhow-to-deploy-windows-virtual-desktop-in-azure%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Ferjenrijnders.nl%2F2019%2F04%2F04%2Fhow-to-deploy-windows-virtual-desktop-in-azure%2F%3C%2FA%3E%20along%20with%20the%20MS%20documentation.%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-472217%22%20slang%3D%22en-US%22%3ERE%3A%20WVD%20Deployment%20Failed%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-472217%22%20slang%3D%22en-US%22%3EI%20think%20one%20of%20the%20issues%20I%20am%20having%20is%20the%20wvd%20is%20in%20my%20azure%20subscription%20that%20does%20not%20have%20ad%20syncing%20I%20have%20one%20that%20is%20but%20it%20is%20completely%20separate%20from%20the%20one%20I%20have%20azure%20setup%20in.%20I%20was%20thinking%20if%20this%20machine%20could%20see%20my%20azure%20domain%20I%20should%20be%20able%20to%20get%20this%20to%20join%20but%20it%20is%20not%20seeing%20the%20other%20domain%20could%20be%20a%20dns%20issue%20still%20trying%20to%20figure%20it%20out%3C%2FLINGO-BODY%3E
RichAtFins
New Contributor

Having worked through the https://docs.microsoft.com/en-us/azure/virtual-desktop/tenant-setup-azure-active-directory tutorials, I got to the final stage, but the deployment failed.

 

I see the following in the Activity Log;

 

===

Operation Name: Create or Update Virtual Machine Extension

Time Stamp: <time & date>

Event initiated by: <me>

Error code: ResourceOperationFailure

Message: The resource operation completed with terminal provisioning state 'Failed'.

===

 

===

Operation Name: Create Deployment

Time Stamp: <time & date>

Event initiated by: <me>

===

 

===

Operation Name: Create or Update Virtual Machine Extension

Time Stamp: <time & date>

Event initiated by: <me>

Error code: ResourceDeploymentFailure

Message: The resource operation completed with terminal provisioning state 'Failed'.

===

 

How do I go about diagnosing what has failed? I can see the VM / Disk / NIC / Availability Set have been created, but I can't see anything when I try to connect to the remote desktop, either by client or web.

 

Any help will be gratefully received!

 

R

 

2 Replies
In case anyone gets something similar... Following fixed the issue...

I deleted the entire resource group to start afresh, and used https://erjenrijnders.nl/2019/04/04/how-to-deploy-windows-virtual-desktop-in-azure/ along with the MS documentation.

I think one of the issues I am having is the wvd is in my azure subscription that does not have ad syncing I have one that is but it is completely separate from the one I have azure setup in. I was thinking if this machine could see my azure domain I should be able to get this to join but it is not seeing the other domain could be a dns issue still trying to figure it out
Related Conversations
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
Tabs and Dark Mode
cjc2112 in Discussions on
30 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
29 Replies