Home

Unable to Create New Host Pools

%3CLINGO-SUB%20id%3D%22lingo-sub-677951%22%20slang%3D%22en-US%22%3EUnable%20to%20Create%20New%20Host%20Pools%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-677951%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20are%20running%20into%20an%20issue%20when%20we%20are%20attempting%20to%20create%20new%20host%20pools%20in%20the%20preview%20environment.%26nbsp%3B%20here%20is%20the%20error%20we%20are%20getting.%20has%20anyone%20else%20run%20into%20this%20issue%20as%20well%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CPRE%3E%7B'code'%3A'DeploymentFailed'%2C'message'%3A'At%20least%20one%20resource%20deployment%20operation%20failed.%20Please%20list%20deployment%20operations%20for%20details.%20Please%20see%20https%3A%2F%2Faka.ms%2Farm-debug%20for%20usage%20details.'%2C'details'%3A%5B%7B'code'%3A'Conflict'%2C'message'%3A'%7B%5C%5Cr%5C%5Cn%20%5C%5C'status%5C%5C'%3A%20%5C%5C'Failed%5C%5C'%2C%5C%5Cr%5C%5Cn%20%5C%5C'error%5C%5C'%3A%20%7B%5C%5Cr%5C%5Cn%20%5C%5C'code%5C%5C'%3A%20%5C%5C'ResourceDeploymentFailure%5C%5C'%2C%5C%5Cr%5C%5Cn%20%5C%5C'message%5C%5C'%3A%20%5C%5C'The%20resource%20operation%20completed%20with%20terminal%20provisioning%20state%20'Failed'.%5C%5C'%2C%5C%5Cr%5C%5Cn%20%5C%5C'details%5C%5C'%3A%20%5B%5C%5Cr%5C%5Cn%20%7B%5C%5Cr%5C%5Cn%20%5C%5C'code%5C%5C'%3A%20%5C%5C'DeploymentFailed%5C%5C'%2C%5C%5Cr%5C%5Cn%20%5C%5C'message%5C%5C'%3A%20%5C%5C'At%20least%20one%20resource%20deployment%20operation%20failed.%20Please%20list%20deployment%20operations%20for%20details.%20Please%20see%20https%3A%2F%2Faka.ms%2Farm-debug%20for%20usage%20details.%5C%5C'%2C%5C%5Cr%5C%5Cn%20%5C%5C'details%5C%5C'%3A%20%5B%5C%5Cr%5C%5Cn%20%7B%5C%5Cr%5C%5Cn%20%5C%5C'code%5C%5C'%3A%20%5C%5C'Conflict%5C%5C'%2C%5C%5Cr%5C%5Cn%20%5C%5C'message%5C%5C'%3A%20%5C%5C'%7B%5C%5C%5C%5Cr%5C%5C%5C%5Cn%20%5C%5C%5C%5C%5C%5C'status%5C%5C%5C%5C%5C%5C'%3A%20%5C%5C%5C%5C%5C%5C'Failed%5C%5C%5C%5C%5C%5C'%2C%5C%5C%5C%5Cr%5C%5C%5C%5Cn%20%5C%5C%5C%5C%5C%5C'error%5C%5C%5C%5C%5C%5C'%3A%20%7B%5C%5C%5C%5Cr%5C%5C%5C%5Cn%20%5C%5C%5C%5C%5C%5C'code%5C%5C%5C%5C%5C%5C'%3A%20%5C%5C%5C%5C%5C%5C'ResourceDeploymentFailure%5C%5C%5C%5C%5C%5C'%2C%5C%5C%5C%5Cr%5C%5C%5C%5Cn%20%5C%5C%5C%5C%5C%5C'message%5C%5C%5C%5C%5C%5C'%3A%20%5C%5C%5C%5C%5C%5C'The%20resource%20operation%20completed%20with%20terminal%20provisioning%20state%20'Failed'.%5C%5C%5C%5C%5C%5C'%2C%5C%5C%5C%5Cr%5C%5C%5C%5Cn%20%5C%5C%5C%5C%5C%5C'details%5C%5C%5C%5C%5C%5C'%3A%20%5B%5C%5C%5C%5Cr%5C%5C%5C%5Cn%20%7B%5C%5C%5C%5Cr%5C%5C%5C%5Cn%20%5C%5C%5C%5C%5C%5C'code%5C%5C%5C%5C%5C%5C'%3A%20%5C%5C%5C%5C%5C%5C'AllocationFailed%5C%5C%5C%5C%5C%5C'%2C%5C%5C%5C%5Cr%5C%5C%5C%5Cn%20%5C%5C%5C%5C%5C%5C'message%5C%5C%5C%5C%5C%5C'%3A%20%5C%5C%5C%5C%5C%5C'The%20VM%20allocation%20failed%20due%20to%20an%20internal%20error.%20Please%20retry%20later%20or%20try%20deploying%20to%20a%20different%20location.%5C%5C%5C%5C%5C%5C'%5C%5C%5C%5Cr%5C%5C%5C%5Cn%20%7D%5C%5C%5C%5Cr%5C%5C%5C%5Cn%20%5D%5C%5C%5C%5Cr%5C%5C%5C%5Cn%20%7D%5C%5C%5C%5Cr%5C%5C%5C%5Cn%7D%5C%5C'%5C%5Cr%5C%5Cn%20%7D%5C%5Cr%5C%5Cn%20%5D%5C%5Cr%5C%5Cn%20%7D%5C%5Cr%5C%5Cn%20%5D%5C%5Cr%5C%5Cn%20%7D%5C%5Cr%5C%5Cn%7D'%7D%5D%7D%3C%2FPRE%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-681355%22%20slang%3D%22en-US%22%3ERe%3A%20Unable%20to%20Create%20New%20Host%20Pools%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-681355%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F356630%22%20target%3D%22_blank%22%3E%40OMG-ItsKipp%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-689281%22%20slang%3D%22en-US%22%3ERe%3A%20Unable%20to%20Create%20New%20Host%20Pools%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-689281%22%20slang%3D%22en-US%22%3E%3CP%3EHi%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F356630%22%20target%3D%22_blank%22%3E%40OMG-ItsKipp%3C%2FA%3E%26nbsp%3B%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECould%20you%20retry%20to%20deploy%20the%20VMs%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20does%20not%20seem%20to%20be%20an%20WVD%20issue%2C%20more%20an%20Azure%20issue%2C%20as%20the%20error%20says%3A%26nbsp%3B%3C%2FP%3E%3CPRE%3E'The%20VM%20allocation%20failed%20due%20to%20an%20internal%20error.%26nbsp%3B%3C%2FPRE%3E%3CP%3E%26nbsp%3BSo%20my%20suggestion%20would%20be%20to%20retry%20the%20deployment%3C%2FP%3E%3C%2FLINGO-BODY%3E
OMG-ItsKipp
Occasional Visitor

We are running into an issue when we are attempting to create new host pools in the preview environment.  here is the error we are getting. has anyone else run into this issue as well?

 

{'code':'DeploymentFailed','message':'At least one resource deployment operation failed. Please list deployment operations for details. Please see https://aka.ms/arm-debug for usage details.','details':[{'code':'Conflict','message':'{\\r\\n \\'status\\': \\'Failed\\',\\r\\n \\'error\\': {\\r\\n \\'code\\': \\'ResourceDeploymentFailure\\',\\r\\n \\'message\\': \\'The resource operation completed with terminal provisioning state 'Failed'.\\',\\r\\n \\'details\\': [\\r\\n {\\r\\n \\'code\\': \\'DeploymentFailed\\',\\r\\n \\'message\\': \\'At least one resource deployment operation failed. Please list deployment operations for details. Please see https://aka.ms/arm-debug for usage details.\\',\\r\\n \\'details\\': [\\r\\n {\\r\\n \\'code\\': \\'Conflict\\',\\r\\n \\'message\\': \\'{\\\\r\\\\n \\\\\\'status\\\\\\': \\\\\\'Failed\\\\\\',\\\\r\\\\n \\\\\\'error\\\\\\': {\\\\r\\\\n \\\\\\'code\\\\\\': \\\\\\'ResourceDeploymentFailure\\\\\\',\\\\r\\\\n \\\\\\'message\\\\\\': \\\\\\'The resource operation completed with terminal provisioning state 'Failed'.\\\\\\',\\\\r\\\\n \\\\\\'details\\\\\\': [\\\\r\\\\n {\\\\r\\\\n \\\\\\'code\\\\\\': \\\\\\'AllocationFailed\\\\\\',\\\\r\\\\n \\\\\\'message\\\\\\': \\\\\\'The VM allocation failed due to an internal error. Please retry later or try deploying to a different location.\\\\\\'\\\\r\\\\n }\\\\r\\\\n ]\\\\r\\\\n }\\\\r\\\\n}\\'\\r\\n }\\r\\n ]\\r\\n }\\r\\n ]\\r\\n }\\r\\n}'}]}
2 Replies

Hi @OMG-ItsKipp ,

 

Could you retry to deploy the VMs?

 

This does not seem to be an WVD issue, more an Azure issue, as the error says: 

'The VM allocation failed due to an internal error. 

 So my suggestion would be to retry the deployment

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
35 Replies
Extentions Synchronization
ChirmyRam in Discussions on
3 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies