Setup Error

%3CLINGO-SUB%20id%3D%22lingo-sub-382686%22%20slang%3D%22en-US%22%3ESetup%20Error%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-382686%22%20slang%3D%22en-US%22%3E%3CP%3EI%20get%20the%20message%20below%20when%20running%26nbsp%3B%3C%2FP%3E%3CP%3EAdd-RdsAccount%20-DeploymentUrl%20%E2%80%9C%3CA%20href%3D%22https%3A%2F%2Frdbroker.wvd.microsoft.com%E2%80%9D%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Frdbroker.wvd.microsoft.com%E2%80%9D%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMessage%3A%26nbsp%3B%20AADSTS50020%3A%20User%20account%20xxx%20from%20identity%20provider%20'live.com'%20does%20not%20exist%20in%20tenant%20'MS%20Azure%20Cloud'%20and%20cannot%20access%20the%20application%3CBR%20%2F%3E(Windows%20Virtual%20Desktop%20Client)%20in%20that%20tenant.%20The%20account%20needs%20to%20be%20added%20as%20an%20external%20user%20in%20the%20tenant%20first.%3CBR%20%2F%3ESign%20out%20and%20sign%20in%20again%20with%20a%20different%20Azure%20Active%20Directory%20user%20account.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20I%20go%20to%20AD%20the%20account%20has%20TenantCreator%20and%20Default%20Access.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-391071%22%20slang%3D%22en-US%22%3ERe%3A%20Setup%20Error%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-391071%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F306217%22%20target%3D%22_blank%22%3E%40ak4work%3C%2FA%3E%26nbsp%3B%20%3A%20Thanks%20for%20testing%20this%20out!%20We%20may%20have%20missed%20some%20guidance%20here%2C%20but%20live%20accounts%20will%20not%20work.%20The%20user%20needs%20to%20be%20a%20%22work%20or%20school%20account%22%20sourced%20from%20that%20Azure%20AD%20tenant.%3C%2FP%3E%3C%2FLINGO-BODY%3E
ak4work
Occasional Visitor

I get the message below when running 

Add-RdsAccount -DeploymentUrl “https://rdbroker.wvd.microsoft.com”

 

Message:  AADSTS50020: User account xxx from identity provider 'live.com' does not exist in tenant 'MS Azure Cloud' and cannot access the application
(Windows Virtual Desktop Client) in that tenant. The account needs to be added as an external user in the tenant first.
Sign out and sign in again with a different Azure Active Directory user account.

 

When I go to AD the account has TenantCreator and Default Access.

1 Reply
Highlighted

@ak4work  : Thanks for testing this out! We may have missed some guidance here, but live accounts will not work. The user needs to be a "work or school account" sourced from that Azure AD tenant.

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
46 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
30 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
13 Replies