Home

Setting up Personal Host Pools does not work - the Persistent Flag is not set to True

%3CLINGO-SUB%20id%3D%22lingo-sub-465909%22%20slang%3D%22en-US%22%3ESetting%20up%20Personal%20Host%20Pools%20does%20not%20work%20-%20the%20Persistent%20Flag%20is%20not%20set%20to%20True%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-465909%22%20slang%3D%22en-US%22%3E%3CDIV%3EI%20created%20a%20%22PERSONAL%22%20pool%20with%201%20Desktop.%26nbsp%3B%20I%20set%20the%20enablepersistentdesktop%20to%20%24true%20at%20time%20of%20deployment.%26nbsp%3B%20After%20Deployment%20doing%20a%20get-rdshostpool%20for%20that%20host%20pool%20the%20'persistent'%20flag%20is%20false%20-%20AND%20-%20it%20cannot%20be%20changed.%26nbsp%3B%20That%20flag%20isnt'%20even%20listed%20in%20the%20documentation%20for%20the%20set-rdshostpool%20command.%26nbsp%3B%26nbsp%3B%3C%2FDIV%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-505416%22%20slang%3D%22en-US%22%3ERe%3A%20Setting%20up%20Personal%20Host%20Pools%20does%20not%20work%20-%20the%20Persistent%20Flag%20is%20not%20set%20to%20True%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-505416%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F322670%22%20target%3D%22_blank%22%3E%40ClayOstlund%3C%2FA%3E%26nbsp%3B%20I%20am%20experiencing%20the%20same%20issue.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-505454%22%20slang%3D%22en-US%22%3ERE%3A%20Setting%20up%20Personal%20Host%20Pools%20does%20not%20work%20-%20the%20Persistent%20Flag%20is%20not%20set%20to%20True%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-505454%22%20slang%3D%22en-US%22%3EPool%20configuration%20looks%20like%20the%20following%20and%20I%20confirmed%20my%20user%20jumps%20around%20between%20VM's.%20I%20am%20not%20pinned%20to%20a%20single%20virtual%20desktop.%20I%20selected%20%22Personal%22%20and%20I%20believed%20that%20would%20assign%20setup%20the%20pool%20with%201%3A1%20mapping%20between%20a%20desktop%20and%20the%20user.%20TenantName%20%3A%20XXX%20TenantGroupName%20%3A%20Default%20Tenant%20Group%20HostPoolName%20%3A%20pool2%20FriendlyName%20%3A%20pool2%20Description%20%3A%20Created%20through%20ARM%20template%20Persistent%20%3A%20False%20CustomRdpProperty%20%3A%20MaxSessionLimit%20%3A%20999999%20LoadBalancerType%20%3A%20BreadthFirst%20ValidationEnv%20%3A%20False%20Ring%20%3A%3C%2FLINGO-BODY%3E
ClayOstlund
Occasional Visitor
I created a "PERSONAL" pool with 1 Desktop.  I set the enablepersistentdesktop to $true at time of deployment.  After Deployment doing a get-rdshostpool for that host pool the 'persistent' flag is false - AND - it cannot be changed.  That flag isnt' even listed in the documentation for the set-rdshostpool command.  
2 Replies
Highlighted
Pool configuration looks like the following and I confirmed my user jumps around between VM's. I am not pinned to a single virtual desktop. I selected "Personal" and I believed that would assign setup the pool with 1:1 mapping between a desktop and the user. TenantName : XXX TenantGroupName : Default Tenant Group HostPoolName : pool2 FriendlyName : pool2 Description : Created through ARM template Persistent : False CustomRdpProperty : MaxSessionLimit : 999999 LoadBalancerType : BreadthFirst ValidationEnv : False Ring :
Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
46 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
13 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
29 Replies