Home

Oops, we couldn't connect to "Session Desktop"

%3CLINGO-SUB%20id%3D%22lingo-sub-390777%22%20slang%3D%22en-US%22%3EOops%2C%20we%20couldn't%20connect%20to%20%22Session%20Desktop%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-390777%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20have%20a%20host%20pool%20stood%20up%20using%20the%20market%20place%20provisioning%2C%20and%20when%20it%20completes%20and%20we%20attempt%20to%20connect%2C%20we're%20not%20having%20success.%26nbsp%3B%20The%20network%20team%20was%20wondering%20if%20we%20need%20to%20create%20a%20static%20route%20on%20our%20side%20because%20we%20can%20ping%20the%20vm%20while%20on%20prem%20and%20can%20rdp%20into%20it%2C%20but%20cannot%20get%20to%20them%20from%20the%20web%20or%20desktop%20clients.%26nbsp%3B%20We%20use%20zscaler%2C%20so%20that%20is%20possibly%20another%20roadblock%2C%20but%20only%20for%20ssl%20scanning.%26nbsp%3B%20Anyone%20have%20any%20thoughts%20on%20next%20steps%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-391035%22%20slang%3D%22en-US%22%3ERe%3A%20Oops%2C%20we%20couldn't%20connect%20to%20%22Session%20Desktop%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-391035%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310494%22%20target%3D%22_blank%22%3E%40GeoffreyKOBrien%3C%2FA%3E%26nbsp%3B%3A%20Thanks%20for%20the%20update.%20The%20initial%20stalling%2Ffailure%20may%20have%20been%20for%20one%20of%20two%20reasons%3A%3C%2FP%3E%0A%3COL%3E%0A%3CLI%3E(Temporary)%20If%20you%20tried%20connecting%20right%20away%2C%20the%20virtual%20machines%20were%20most%20likely%20self-updating%20our%20Windows%20Virtual%20Desktop%20agent%20to%20be%20on%20the%20latest.%3C%2FLI%3E%0A%3CLI%3E(Permanent)%20There%20are%20some%20cases%20where%20the%20virtual%20machine%20is%20unable%20to%20complete%20the%20update%20(not%20enough%20storage%2C%20or%20bugs).%3C%2FLI%3E%0A%3C%2FOL%3E%0A%3CP%3EWe're%20consistently%20trying%20to%20avoid%20those%20permanent%20failures%2C%20so%20we%20appreciate%20all%20of%20the%20testing%20and%20feedback!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-390989%22%20slang%3D%22en-US%22%3ERe%3A%20Oops%2C%20we%20couldn't%20connect%20to%20%22Session%20Desktop%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-390989%22%20slang%3D%22en-US%22%3E%3CP%3EI%20built%20a%20second%20hostpool%20and%20now%20it's%20working.%26nbsp%3B%20Ive%20since%20deleted%20the%20first%20one%20and%20im%20good%20to%20go%2C%20odd.%3C%2FP%3E%3C%2FLINGO-BODY%3E
GeoffreyKOBrien
New Contributor

We have a host pool stood up using the market place provisioning, and when it completes and we attempt to connect, we're not having success.  The network team was wondering if we need to create a static route on our side because we can ping the vm while on prem and can rdp into it, but cannot get to them from the web or desktop clients.  We use zscaler, so that is possibly another roadblock, but only for ssl scanning.  Anyone have any thoughts on next steps?

2 Replies

I built a second hostpool and now it's working.  Ive since deleted the first one and im good to go, odd.

@GeoffreyKOBrien : Thanks for the update. The initial stalling/failure may have been for one of two reasons:

  1. (Temporary) If you tried connecting right away, the virtual machines were most likely self-updating our Windows Virtual Desktop agent to be on the latest.
  2. (Permanent) There are some cases where the virtual machine is unable to complete the update (not enough storage, or bugs).

We're consistently trying to avoid those permanent failures, so we appreciate all of the testing and feedback!

Related Conversations
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
Tabs and Dark Mode
cjc2112 in Discussions on
30 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
7 Replies