Home

No Heartbeat on Session Host after shutdown

%3CLINGO-SUB%20id%3D%22lingo-sub-987520%22%20slang%3D%22en-US%22%3ENo%20Heartbeat%20on%20Session%20Host%20after%20shutdown%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-987520%22%20slang%3D%22en-US%22%3E%3CP%3EI've%20been%20trialing%20WVD%20and%20followed%20the%20Microsoft%20guides%20to%20setup.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20then%20expanded%20the%20trial%20to%20include%20a%20custom%20image%20using%20the%20guide%20here%3A%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fwww.robinhobo.com%2Fhow-to-create-a-custom-windows-10-multi-user-image-with-lob-applications-for-windows-virtual-desktop-preview-wvd-hostpool-deployments%2F%22%20target%3D%22_blank%22%20rel%3D%22noopener%20nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fwww.robinhobo.com%2Fhow-to-create-a-custom-windows-10-multi-user-image-with-lob-applications-for-windows-virtual-desktop-preview-wvd-hostpool-deployments%2F%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ELast%20night%20I%20shutdown%20the%20session%20host%2C%20powered%20up%20this%20morning%20and%20attempted%20to%20run%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EGet-RdsStartMenuApp%20%3CTENANTNAME%3E%20%3CHOSTPOOLNAME%3E%20%22RemoteApp%20Application%20Group%22%3C%2FHOSTPOOLNAME%3E%3C%2FTENANTNAME%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhich%20gave%20the%20error%20%22Get-RdsStartMenuApp%20%3A%20There%20are%20no%20Session%20Hosts%20available%20in%20the%20HostPool%20to%20service%20the%20Start%20Menu%20request%22%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThen%20ran%3A%26nbsp%3BGet-RdsSessionHost%20%3CTENANTNAME%3E%20%3CHOSTPOOLNAME%3E%3C%2FHOSTPOOLNAME%3E%3C%2FTENANTNAME%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhich%20showed%3A%3C%2FP%3E%3CP%3E%26nbsp%3BLastHeartBeat%20%3A%2005%2F11%2F2019%2020%3A40%3A59%3CBR%20%2F%3EAgentVersion%20%3A%201.0.1486.900%3CBR%20%2F%3EAssignedUser%20%3A%3CBR%20%2F%3EOsVersion%20%3A%2010.0.18362%3CBR%20%2F%3ESxSStackVersion%20%3A%20rdp-sxs190905003%3CBR%20%2F%3EStatus%20%3A%20NoHeartbeat%3CBR%20%2F%3EUpdateState%20%3A%20Succeeded%3CBR%20%2F%3ELastUpdateTime%20%3A%2005%2F11%2F2019%2020%3A37%3A26%3CBR%20%2F%3EUpdateErrorMessage%20%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHave%20checked%20the%20vm%20and%20confirmed%20that%20the%26nbsp%3B%3CEM%3ERDAgentBootLoader%26nbsp%3B%3C%2FEM%3Eservice%20is%20started%20as%20suggested%20on%20other%20threads.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhat%20should%20be%20the%20next%20steps%20I%20need%20to%20be%20taking%20to%20troubleshoot%20this%3F%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EFor%20now%2C%20as%20it's%20a%20test%20environment%20redeploying%20the%20host%20pool%20seems%20to%20resolve%20but%20if%20I%20were%20to%20use%20this%20in%20production%20I%20would%20expect%20to%20use%20azure%20automation%20to%20power%20down%20unused%20VM's%20outside%20of%20business%20hours%20to%20reduce%20compute%20costs.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-987520%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EWVD%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
cwljack
Regular Visitor

I've been trialing WVD and followed the Microsoft guides to setup.

 

I've then expanded the trial to include a custom image using the guide here:

https://www.robinhobo.com/how-to-create-a-custom-windows-10-multi-user-image-with-lob-applications-f...

 

Last night I shutdown the session host, powered up this morning and attempted to run:

 

Get-RdsStartMenuApp <tenantname> <hostpoolname> "RemoteApp Application Group"

 

Which gave the error "Get-RdsStartMenuApp : There are no Session Hosts available in the HostPool to service the Start Menu request"

 

Then ran: Get-RdsSessionHost <tenantname> <hostpoolname>

 

Which showed:

 LastHeartBeat : 05/11/2019 20:40:59
AgentVersion : 1.0.1486.900
AssignedUser :
OsVersion : 10.0.18362
SxSStackVersion : rdp-sxs190905003
Status : NoHeartbeat
UpdateState : Succeeded
LastUpdateTime : 05/11/2019 20:37:26
UpdateErrorMessage :

 

Have checked the vm and confirmed that the RDAgentBootLoader service is started as suggested on other threads.

 

What should be the next steps I need to be taking to troubleshoot this? 

 

For now, as it's a test environment redeploying the host pool seems to resolve but if I were to use this in production I would expect to use azure automation to power down unused VM's outside of business hours to reduce compute costs.

 

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
46 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
29 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
13 Replies