Home

Need help with Virtual Host deployment

%3CLINGO-SUB%20id%3D%22lingo-sub-453480%22%20slang%3D%22en-US%22%3ENeed%20help%20with%20Virtual%20Host%20deployment%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-453480%22%20slang%3D%22en-US%22%3E%3CP%3E%7B%22code%22%3A%22DeploymentFailed%22%2C%22message%22%3A%22At%20least%20one%20resource%20deployment%20operation%20failed.%20Please%20list%20deployment%20operations%20for%20details.%20Please%20see%20%3CA%20href%3D%22https%3A%2F%2Faka.ms%2Farm-debug%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Faka.ms%2Farm-debug%3C%2FA%3E%20for%20usage%20details.%22%2C%22details%22%3A%5B%7B%22code%22%3A%22Conflict%22%2C%22message%22%3A%22%7B%5Cr%5Cn%20%5C%22status%5C%22%3A%20%5C%22Failed%5C%22%2C%5Cr%5Cn%20%5C%22error%5C%22%3A%20%7B%5Cr%5Cn%20%5C%22code%5C%22%3A%20%5C%22ResourceDeploymentFailure%5C%22%2C%5Cr%5Cn%20%5C%22message%5C%22%3A%20%5C%22The%20resource%20operation%20completed%20with%20terminal%20provisioning%20state%20'Failed'.%5C%22%2C%5Cr%5Cn%20%5C%22details%5C%22%3A%20%5B%5Cr%5Cn%20%7B%5Cr%5Cn%20%5C%22code%5C%22%3A%20%5C%22VMExtensionProvisioningError%5C%22%2C%5Cr%5Cn%20%5C%22message%5C%22%3A%20%5C%22VM%20has%20reported%20a%20failure%20when%20processing%20extension%20'joindomain'.%20Error%20message%3A%20%5C%5C%5C%22Exception(s)%20occured%20while%20joining%20Domain%20'********'%5C%5C%5C%22.%5C%22%5Cr%5Cn%20%7D%5Cr%5Cn%20%5D%5Cr%5Cn%20%7D%5Cr%5Cn%7D%22%7D%5D%7D%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-454847%22%20slang%3D%22en-US%22%3ERe%3A%20Need%20help%20with%20Virtual%20Host%20deployment%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-454847%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%20looks%20like%20we're%20missing%20a%20bit%20of%20the%20error%20there%20but%20we%20know%20it%20is%20breaking%20at%20the%20%22joindomain%22%20stage.%20Do%20you%20have%20an%20on-prem%20AD%3F%20The%20gotcha%20I%20had%20on%20here%20was%20that%20the%20admin%20account%20I%20was%20using%20didn't%20comply%20with%20Azure%20complexity%20requirements%20and%20therefore%20wouldn't%20allow%20the%20system%20to%20connect%20to%20the%20AD....%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-458884%22%20slang%3D%22en-US%22%3ERe%3A%20Need%20help%20with%20Virtual%20Host%20deployment%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-458884%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F321218%22%20target%3D%22_blank%22%3E%40Graeme1165%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20for%20the%20answer%3C%2FP%3E%3CP%3EI%20am%20trying%20to%20create%20a%20Host%20Pool%20for%20the%20Windows%20Virtual%20Desktop%3C%2FP%3E%3CP%3Ewhen%20he%20gets%20to%20the%20stage%20of%20adding%20the%20machine%20to%20the%20domain%20he%20stuck%20at%20that%20error%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20a%20DC%20in%20the%20Azure%20and%20not%20on-prem%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-459261%22%20slang%3D%22en-US%22%3ERe%3A%20Need%20help%20with%20Virtual%20Host%20deployment%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-459261%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F106042%22%20target%3D%22_blank%22%3E%40Yossi%20Vizel%3C%2FA%3E%26nbsp%3Bthat%20may%20well%20be%20the%20problem%20then!%20I%20am%20seeing%20a%20lot%20of%20comments%20saying%20that%20you%20need%20on-premise%20AD%20for%20this%20preview%20-%20I%20don't%20know%20if%20that%20is%20true%20or%20not%20as%20I%20have%20an%20on-prem%20so%20hopefully%20someone%20else%20can%20help%20you....%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-459587%22%20slang%3D%22en-US%22%3ERe%3A%20Need%20help%20with%20Virtual%20Host%20deployment%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-459587%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F106042%22%20target%3D%22_blank%22%3E%40Yossi%20Vizel%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMay%20be%20the%20issue%2C%20if%20you've%20not%20done%20it.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20you%20are%20using%20Azure%20ADDS%20for%20the%20domain%20join%20of%20your%20VM%2C%20you%20need%20to%20make%20sure%20that%20you%20change%20the%20password%20of%20the%20account%20that%20is%20being%20used%20for%20the%20domain%20join%20(and%20it%20also%20needs%20to%20be%20in%20the%20correct%20group).%20That%20password%20change%20will%20then%20sync%20from%20Azure%20AD%20to%20AADDS.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSTRONG%3EIf%20your%20organization%20has%20cloud-only%20user%20accounts%2C%20all%20users%20who%20need%20to%20use%20Azure%20Active%20Directory%20Domain%20Services%20must%20change%20their%20passwords.%3C%2FSTRONG%3E%3CSPAN%3E%20A%20cloud-only%20user%20account%20is%20an%20account%20that%20was%20created%20in%20your%20Azure%20AD%20directory%20using%20either%20the%20Azure%20portal%20or%20Azure%20AD%20PowerShell%20cmdlets.%20Such%20user%20accounts%20aren't%20synchronized%20from%20an%20on-premises%20directory.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CFONT%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Factive-directory-domain-services%2Factive-directory-ds-getting-started-password-sync%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Factive-directory-domain-services%2Factive-directory-ds-getting-started-password-sync%3C%2FA%3E%3C%2FFONT%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Yossi Vizel
New Contributor

{"code":"DeploymentFailed","message":"At least one resource deployment operation failed. Please list deployment operations for details. Please see https://aka.ms/arm-debug for usage details.","details":[{"code":"Conflict","message":"{\r\n \"status\": \"Failed\",\r\n \"error\": {\r\n \"code\": \"ResourceDeploymentFailure\",\r\n \"message\": \"The resource operation completed with terminal provisioning state 'Failed'.\",\r\n \"details\": [\r\n {\r\n \"code\": \"VMExtensionProvisioningError\",\r\n \"message\": \"VM has reported a failure when processing extension 'joindomain'. Error message: \\\"Exception(s) occured while joining Domain '********'\\\".\"\r\n }\r\n ]\r\n }\r\n}"}]}

4 Replies

Hi, looks like we're missing a bit of the error there but we know it is breaking at the "joindomain" stage. Do you have an on-prem AD? The gotcha I had on here was that the admin account I was using didn't comply with Azure complexity requirements and therefore wouldn't allow the system to connect to the AD....

@Graeme1165 

Thanks for the answer

I am trying to create a Host Pool for the Windows Virtual Desktop

when he gets to the stage of adding the machine to the domain he stuck at that error 

I have a DC in the Azure and not on-prem 

 

@Yossi Vizel that may well be the problem then! I am seeing a lot of comments saying that you need on-premise AD for this preview - I don't know if that is true or not as I have an on-prem so hopefully someone else can help you....

@Yossi Vizel 

 

May be the issue, if you've not done it.

 

If you are using Azure ADDS for the domain join of your VM, you need to make sure that you change the password of the account that is being used for the domain join (and it also needs to be in the correct group). That password change will then sync from Azure AD to AADDS.

 

If your organization has cloud-only user accounts, all users who need to use Azure Active Directory Domain Services must change their passwords. A cloud-only user account is an account that was created in your Azure AD directory using either the Azure portal or Azure AD PowerShell cmdlets. Such user accounts aren't synchronized from an on-premises directory.

 

 

https://docs.microsoft.com/en-us/azure/active-directory-domain-services/active-directory-ds-getting-...

 

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
46 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
30 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
13 Replies