Home

Issues with Side by Side Stack

%3CLINGO-SUB%20id%3D%22lingo-sub-792896%22%20slang%3D%22en-US%22%3EIssues%20with%20Side%20by%20Side%20Stack%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-792896%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20been%20trying%20to%20deploy%20WVD%20host%20pool%20with%20a%20custom%20image%2C%20and%20having%20trouble%20with%20SxS%20stack.%20As%20a%20result%20(I%20believe)%20although%20I%20can%20see%20the%20VM%2Fdesktop%2Fpool%20available%20in%20the%20WVD%20portal%2C%20connection%20to%20it%20fails.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENow%20the%20run%20down%20of%20what%20I've%20done%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECustom%20image%20creation%3A%3CBR%20%2F%3EAn%20Azure%20Windows%2010%201803%20Pro%20VM%20is%20created.%3C%2FP%3E%3CP%3EVarious%20programs%20and%20configuration%20installed.%3C%2FP%3E%3CP%3ESysprep%20and%20shutdown%2C%20then%20capture%20into%20an%20image.%3C%2FP%3E%3CP%3EI%20even%20ran%20through%20the%20steps%20here%20second%20time%20around%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fvirtual-machines%2Fwindows%2Fprepare-for-upload-vhd-image%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fvirtual-machines%2Fwindows%2Fprepare-for-upload-vhd-image%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EOnce%20image%20is%20created%2C%20a%20new%20Windows%20Virtual%20Desktop%20host%20pool%20is%20deployed%20using%20that%20and%20as%20far%20as%20host%20pool%20deployment%2C%20everything%20is%20fine.%20No%20errors%2C%20domain%20join%20is%20good%2C%20Windows%20Virtual%20Desktop%20Agent%20and%20Bootloader%20are%20installed%20and%20reg%20keys%20are%20present%2C%20however%20running%20Get-RdsSessionHost%20shows%20SxSStackListenerNotReady%20for%20SxSStackStatus.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20even%20followed%20these%20instructions%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fvirtual-desktop%2Fcreate-host-pools-powershell%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fvirtual-desktop%2Fcreate-host-pools-powershell%3C%2FA%3Eand%20manually%20joined%20to%20domain%20and%20installed%20agent%20and%20bootloader%20and%20Get-RdsSessionHost%20does%20not%20even%20show%20the%20new%20VM!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERunning%20qwinsta%20does%20NOT%20show%20rdp-sxs%20process.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20also%20run%20through%20this%20troubleshooting%20page%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fvirtual-desktop%2Ftroubleshoot-vm-configuration%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fvirtual-desktop%2Ftroubleshoot-vm-configuration%3C%2FA%3Eand%20the%20only%20section%20that%20applies%20to%20my%20situation%20is%20SxS%20not%20installed%20or%20enabled%2C%20and%20it%20talks%20about%20a%20%3CSTRONG%3Eenablesxstackrs.ps1%3C%2FSTRONG%3Escript%2C%20however%20that's%20no%20where%20to%20be%20found%20on%20the%20page!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20I%20deploy%20a%20host%20pool%20with%20MS%20gallery%20images(%20i.e.%20Win%2010%20Ent%20Multisession%20and%20O365)%2C%20I%20can%20connect%20to%20the%20VM%2Fdesktop%20from%20%3CA%20href%3D%22https%3A%2F%2Frdweb.wvd.microsoft.com%2Fwebclient%2Findex.html%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Frdweb.wvd.microsoft.com%2Fwebclient%2Findex.html%3C%2FA%3Eand%20obviously%20rdp-sxs%20shows%20when%20you%20run%20qwinsta%20and%20Get-RdsSessionHost%20returns%20the%20heartbeat%20data%20for%20SxSStackStatus.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESo%20I%20am%20pretty%20sure%20either%20I%20am%20missing%20a%20step%2C%20or%20something%20does%20not%20get%20enabled%20when%20installing%20agent%20and%20bootloader.%20Otherwise%20maybe%20no%20other%20version%20of%20Win%2010%20is%20supported%20for%20this%2C%20hence%20the%20issues%20with%20SxS%20stack.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWould%20really%20appreciate%20some%20help.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%2C%3C%2FP%3E%3CP%3EFaranoosh%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-798672%22%20slang%3D%22en-US%22%3ERe%3A%20Issues%20with%20Side%20by%20Side%20Stack%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-798672%22%20slang%3D%22en-US%22%3ECan%20you%20post%20the%20output%20of%20Get-RDSSessionHost%20for%20us%20here%20from%20the%20machine%20where%20you%20have%20manually%20installed%20the%20bootloader%20and%20agent%20%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-798715%22%20slang%3D%22en-US%22%3ERe%3A%20Issues%20with%20Side%20by%20Side%20Stack%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-798715%22%20slang%3D%22en-US%22%3EThanks%20for%20the%20reply.%3CBR%20%2F%3E%3CBR%20%2F%3EUnfortunately%20since%20we%20needed%20a%20solution%20ASAP%2C%20I%20removed%20the%20original%20pools%20and%20VMs%20and%20created%20my%20image%20from%20Win%2010%201809%20for%20WVD%20(from%20Azure%20Gallery)%20and%20that%20seems%20to%20work%20fine.%20Agent%20and%20bootloader%20were%20installed%20during%20host%20pool%20creation%20and%20I%20didn't%20have%20to%20do%20any%20other%20customization%20on%20the%20image%20itself.%3CBR%20%2F%3E%3CBR%20%2F%3EI%20may%20revisit%201803%20image%20again%20and%20will%20post%20the%20output%2C%20but%20I%20have%20a%20feeling%20running%20those%20non-multisession%20versions%20is%20probably%20not%20supported.%20Even%20though%20hearing%20otherwise%20from%20couple%20of%20Azure%20Solutions%20Architects.%3CBR%20%2F%3E%3CBR%20%2F%3ECheers%3CBR%20%2F%3E%3CBR%20%2F%3E%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-804264%22%20slang%3D%22en-US%22%3ERe%3A%20Issues%20with%20Side%20by%20Side%20Stack%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-804264%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F388508%22%20target%3D%22_blank%22%3E%40fara1%3C%2FA%3EI've%20had%20the%20same%20issue%20with%20no%20reply%20so%20far.%20Thing%20is%2C%20it%20was%20working%20before%20with%20older%20builds.%3CBR%20%2F%3EMS%20removed%20the%20SxS%20script%20and%20setup%20from%20the%20technet%20articles%2C%20according%20to%20the%20comment%20on%20github%20becasue%20SxS%20is%20not%20needed%20anymore...%20well%20I'd%20say%20that's%20not%20entirely%20true.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-805579%22%20slang%3D%22en-US%22%3ERe%3A%20Issues%20with%20Side%20by%20Side%20Stack%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-805579%22%20slang%3D%22en-US%22%3EThanks%20for%20the%20reply.%20Yeah%2C%20not%20sure%20why%20they%20removed%20the%20script%20but%20are%20referencing%20it%20in%20the%20guide%20still!%20Also%20would%20have%20been%20nice%20to%20have%20some%20direct%20support%20as%20first%20impression%2C%20technical%20and%20end%20user%2C%20is%20everything%20with%20a%20new%20tech.%3CBR%20%2F%3E%3CBR%20%2F%3EWe%20have%20not%20been%20happy%20with%20the%20(laggy)%20user%20experience%20either%20so%20will%20probably%20move%20away%20and%20look%20for%20a%20different%20solution.%20I%20am%20assuming%20the%20lag%20is%20because%20of%20the%20management%20plane%20being%20in%20US%20only!%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-806084%22%20slang%3D%22en-US%22%3ERe%3A%20Issues%20with%20Side%20by%20Side%20Stack%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-806084%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F388508%22%20target%3D%22_blank%22%3E%40fara1%3C%2FA%3EIn%20the%20end%20I've%20just%20deployed%20a%20VM%20with%20the%20image%20from%20the%20marketplace%20and%20on%20top%20of%20that%20installed%20and%20configured%20everything%20we%20need%2C%20then%20created%20a%20managed%20Image%20and%20deployed%20this%20one%2C%20works%20like%20a%20charm%20but%20for%20another%20issue%20that%20the%20RD%20agent%20Updater%20doesn't%20work%20anymore.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EYes%20the%20preformance%20is%20related%20to%20the%20management%20plane%20in%20the%20US.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-806114%22%20slang%3D%22en-US%22%3ERe%3A%20Issues%20with%20Side%20by%20Side%20Stack%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-806114%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F380065%22%20target%3D%22_blank%22%3E%40A_priori_superior%3C%2FA%3EYeah%20I%20basically%20did%20the%20same%20thing%20to%20capture%20from%20a%20VM%20and%20use%20for%20hostpool.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAlso%20Today%20I%20asked%20our%20developers%20to%20use%20the%20standard%20RDP%20into%20those%20VMs%20and%20obviously%20massive%20improvements%20in%20user%20experience.%20They%20can%20actually%20do%20their%20work.%20I%20was%20really%20excited%20about%20WVD%20and%20it%20was%20my%20suggestion%20to%20implement%20and%20use%20it%20but%20unfortunately%20it%20is%20not%20enterprise%20yet%20or%20at%20least%20for%20outside%20US.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EBack%20to%20the%20whole%20SXS%20issue%2C%20I%20created%20another%20VM%20from%20Win%2010%201809%20for%20WVD%20(from%20Azure%20Gallery)%20today%20and%20followed%20this%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-au%2Fazure%2Fvirtual-desktop%2Fcreate-host-pools-powershell%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-au%2Fazure%2Fvirtual-desktop%2Fcreate-host-pools-powershell%3C%2FA%3Eto%20domain%20join%20and%20install%20RD%20agent%20and%20bootloader.%20It%20still%20did%20not%20register%20with%20the%20hostpool%20and%20rdp-sxs%20does%20not%20appear!%20So%20whatever%20they%20have%20removed%20from%20the%20guides%2C%20whether%20it's%20the%20PoSH%20script%20or%20something%20else%2C%20has%20definitely%20broken%20this%20process.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
fara1
New Contributor

I have been trying to deploy WVD host pool with a custom image, and having trouble with SxS stack. As a result (I believe) although I can see the VM/desktop/pool available in the WVD portal, connection to it fails.

 

Now the run down of what I've done:

 

Custom image creation:
An Azure Windows 10 1803 Pro VM is created.

Various programs and configuration installed.

Sysprep and shutdown, then capture into an image.

I even ran through the steps here second time around https://docs.microsoft.com/en-us/azure/virtual-machines/windows/prepare-for-upload-vhd-image

 

Once image is created, a new Windows Virtual Desktop host pool is deployed using that and as far as host pool deployment, everything is fine. No errors, domain join is good, Windows Virtual Desktop Agent and Bootloader are installed and reg keys are present, however running Get-RdsSessionHost shows SxSStackListenerNotReady for SxSStackStatus.

 

I have even followed these instructions https://docs.microsoft.com/en-us/azure/virtual-desktop/create-host-pools-powershell and manually joined to domain and installed agent and bootloader and Get-RdsSessionHost does not even show the new VM!

 

Running qwinsta does NOT show rdp-sxs process.

 

I've also run through this troubleshooting page https://docs.microsoft.com/en-us/azure/virtual-desktop/troubleshoot-vm-configuration and the only section that applies to my situation is SxS not installed or enabled, and it talks about a enablesxstackrs.ps1 script, however that's no where to be found on the page!

 

If I deploy a host pool with MS gallery images( i.e. Win 10 Ent Multisession and O365), I can connect to the VM/desktop from https://rdweb.wvd.microsoft.com/webclient/index.html and obviously rdp-sxs shows when you run qwinsta and Get-RdsSessionHost returns the heartbeat data for SxSStackStatus.

 

So I am pretty sure either I am missing a step, or something does not get enabled when installing agent and bootloader. Otherwise maybe no other version of Win 10 is supported for this, hence the issues with SxS stack.

 

Would really appreciate some help.

 

Thanks,

Faranoosh

6 Replies
Can you post the output of Get-RDSSessionHost for us here from the machine where you have manually installed the bootloader and agent ?
Thanks for the reply.

Unfortunately since we needed a solution ASAP, I removed the original pools and VMs and created my image from Win 10 1809 for WVD (from Azure Gallery) and that seems to work fine. Agent and bootloader were installed during host pool creation and I didn't have to do any other customization on the image itself.

I may revisit 1803 image again and will post the output, but I have a feeling running those non-multisession versions is probably not supported. Even though hearing otherwise from couple of Azure Solutions Architects.

Cheers



@fara1I've had the same issue with no reply so far. Thing is, it was working before with older builds.
MS removed the SxS script and setup from the technet articles, according to the comment on github becasue SxS is not needed anymore... well I'd say that's not entirely true.

Thanks for the reply. Yeah, not sure why they removed the script but are referencing it in the guide still! Also would have been nice to have some direct support as first impression, technical and end user, is everything with a new tech.

We have not been happy with the (laggy) user experience either so will probably move away and look for a different solution. I am assuming the lag is because of the management plane being in US only!

@fara1In the end I've just deployed a VM with the image from the marketplace and on top of that installed and configured everything we need, then created a managed Image and deployed this one, works like a charm but for another issue that the RD agent Updater doesn't work anymore.

 

Yes the preformance is related to the management plane in the US.

@A_priori_superiorYeah I basically did the same thing to capture from a VM and use for hostpool.

 

Also Today I asked our developers to use the standard RDP into those VMs and obviously massive improvements in user experience. They can actually do their work. I was really excited about WVD and it was my suggestion to implement and use it but unfortunately it is not enterprise yet or at least for outside US.

 

Back to the whole SXS issue, I created another VM from Win 10 1809 for WVD (from Azure Gallery) today and followed this https://docs.microsoft.com/en-au/azure/virtual-desktop/create-host-pools-powershell to domain join and install RD agent and bootloader. It still did not register with the hostpool and rdp-sxs does not appear! So whatever they have removed from the guides, whether it's the PoSH script or something else, has definitely broken this process.

 

 

Related Conversations
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
Tabs and Dark Mode
cjc2112 in Discussions on
30 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
29 Replies