Home

How do I configure WVD to only use one monitor/screen - It always spans all my monitors

%3CLINGO-SUB%20id%3D%22lingo-sub-400528%22%20slang%3D%22en-US%22%3EHow%20do%20I%20configure%20WVD%20to%20only%20use%20one%20monitor%2Fscreen%20-%20It%20always%20spans%20all%20my%20monitors%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-400528%22%20slang%3D%22en-US%22%3E%3CP%3EUsing%20Server%202016%20for%20the%20session%20hosts%20and%20Windows%2010%20to%20connect.%3C%2FP%3E%3CP%3EBTW%3A%20Is%20there%20an%20up-to-date%20list%20of%20supported%20settings%20that%20I%20can%20refer%20to%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20tried%20to%20use%20the%20setting%20%22use%20multimon%22%20on%20the%20host%20pool%20with%20the%20below%20command%20and%20waited%20over%20night%20to%20ensure%20any%20delayed%20publishing%20propagation%20would%20have%20occurred.%20I%20then%20connected%20again%20with%20remote%20desktop%20but%20no%20change.%20Command%20I%20tried%20is%20copied%20below%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EPS%20C%3A%5CUsers%5Cjohan%26gt%3B%20set-rdshostpool%20-TenantName%20%22munobia%22%20-Name%20%22pool%22%20-ValidationEnv%20%24true%20-CustomRdpProperty%20%22use%20multimon%3Ai%3A0%22%3C%2FP%3E%3CP%3E%3CBR%20%2F%3ETenantName%20%3A%20munobia%3CBR%20%2F%3ETenantGroupName%20%3A%20Default%20Tenant%20Group%3CBR%20%2F%3EHostPoolName%20%3A%20pool%3CBR%20%2F%3EFriendlyName%20%3A%20pool%3CBR%20%2F%3EDescription%20%3A%20Created%20through%20ARM%20template%3CBR%20%2F%3EPersistent%20%3A%20False%3CBR%20%2F%3EDiskPath%20%3A%3CBR%20%2F%3EEnableUserProfileDisk%20%3A%20False%3CBR%20%2F%3EExcludeFolderPath%20%3A%3CBR%20%2F%3EExcludeFilePath%20%3A%3CBR%20%2F%3EIncludeFilePath%20%3A%3CBR%20%2F%3EIncludeFolderPath%20%3A%3CBR%20%2F%3ECustomRdpProperty%20%3A%20use%20multimon%3Ai%3A0%3B%3CBR%20%2F%3EMaxSessionLimit%20%3A%20999999%3CBR%20%2F%3ELoadBalancerType%20%3A%20BreadthFirst%3CBR%20%2F%3EValidationEnv%20%3A%20True%3CBR%20%2F%3ERing%20%3A%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-572322%22%20slang%3D%22en-US%22%3ERe%3A%20How%20do%20I%20configure%20WVD%20to%20only%20use%20one%20monitor%2Fscreen%20-%20It%20always%20spans%20all%20my%20monitors%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-572322%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F309051%22%20target%3D%22_blank%22%3E%40Johan_Eriksson%3C%2FA%3E%26nbsp%3B%3A%20We%20are%20continuously%20improving%20our%20documentation%2C%20and%20we%20have%20the%20latest%2C%20most%20up-do-date%20set%20here%3A%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fwindows-server%2Fremote%2Fremote-desktop-services%2Fclients%2Fremote-desktop-app-compare%23supported-rdp-settings%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fwindows-server%2Fremote%2Fremote-desktop-services%2Fclients%2Fremote-desktop-app-compare%23supported-rdp-settings%3C%2FA%3E%20.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EDid%20the%20multi-mon%20property%20end%20up%20working%3F%20From%20what%20you've%20entered%2C%20it%20looks%20correct.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-574820%22%20slang%3D%22en-US%22%3ERe%3A%20How%20do%20I%20configure%20WVD%20to%20only%20use%20one%20monitor%2Fscreen%20-%20It%20always%20spans%20all%20my%20monitors%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-574820%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F305776%22%20target%3D%22_blank%22%3E%40christianmontoya%3C%2FA%3E%26nbsp%3BThanks%20for%20the%20reply%20and%20the%20link.%20Yes%2C%20I%20got%20it%20to%20work%20with%20that%20setting%20in%20the%20end.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Johan_Eriksson
Contributor

Using Server 2016 for the session hosts and Windows 10 to connect.

BTW: Is there an up-to-date list of supported settings that I can refer to?

 

I tried to use the setting "use multimon" on the host pool with the below command and waited over night to ensure any delayed publishing propagation would have occurred. I then connected again with remote desktop but no change. Command I tried is copied below:

 

PS C:\Users\johan> set-rdshostpool -TenantName "munobia" -Name "pool" -ValidationEnv $true -CustomRdpProperty "use multimon:i:0"


TenantName : munobia
TenantGroupName : Default Tenant Group
HostPoolName : pool
FriendlyName : pool
Description : Created through ARM template
Persistent : False
DiskPath :
EnableUserProfileDisk : False
ExcludeFolderPath :
ExcludeFilePath :
IncludeFilePath :
IncludeFolderPath :
CustomRdpProperty : use multimon:i:0;
MaxSessionLimit : 999999
LoadBalancerType : BreadthFirst
ValidationEnv : True
Ring :

2 Replies

@Johan_Eriksson : We are continuously improving our documentation, and we have the latest, most up-do-date set here: https://docs.microsoft.com/windows-server/remote/remote-desktop-services/clients/remote-desktop-app-... .

 

Did the multi-mon property end up working? From what you've entered, it looks correct.

@christianmontoya Thanks for the reply and the link. Yes, I got it to work with that setting in the end.

Related Conversations
Extentions Synchronization
Deleted in Discussions on
3 Replies
Tabs and Dark Mode
cjc2112 in Discussions on
36 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
29 Replies