Home

Erreur Add-RdsAccount

%3CLINGO-SUB%20id%3D%22lingo-sub-429071%22%20slang%3D%22fr-FR%22%3EAdd-RdsAccount%20error%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-429071%22%20slang%3D%22fr-FR%22%3E%3CP%3EHello%26nbsp%3B%3C%2FP%3E%3CP%3EI%20want%20to%20set%20up%20WVD%20for%20a%20client%20as%20soon%20as%20it%20comes%20out%20of%20the%20preview%2C%20but%20I%20can't%20get%20it%20already%20set%20up%20on%20one%20of%20my%20holding%20for%20a%20problem%20that%20I%20imagine%20is%20simple.%20I%20have%20read%20the%20errors%20encountered%20that%20are%20all%20after%20the%20step%20or%20I%20block.%3C%2FP%3E%3CP%3EI%20rely%20on%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fvirtual-desktop%2Ftenant-setup-azure-active-directory%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.Microsoft.com%2Fen-us%2Fazure%2Fvirtual-desktop%2Ftenant-Setup-azure-Active-Directory%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20block%20on%20add-RdsAccount-DeploymentUrl%20%22%3CA%20href%3D%22https%3A%2F%2Frdbroker.wvd.microsoft.com%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Frdbroker.WVD.Microsoft.com%3C%2FA%3E%22%20which%20returns%20me%20an%20error%20(module%20installed%20version%201.0.1.11)%3C%2FP%3E%3CPRE%3EPS%20C%3A%5CWINDOWS%5Csystem32%26gt%3B%20Install-Module%20-Name%20Microsoft.RDInfra.RDPowerShell%3CBR%20%2F%3EPS%20C%3A%5CWINDOWS%5Csystem32%26gt%3B%20Import-Module%20-Name%20Microsoft.RDInfra.RDPowerShell%3CBR%20%2F%3EPS%20C%3A%5CWINDOWS%5Csystem32%26gt%3B%20Add-RdsAccount%20-DeploymentUrl%20%22https%3A%2F%2Frdbroker.wvd.microsoft.com%22%3CBR%20%2F%3EAdd-RdsAccount%20%3A%20Une%20ou%20plusieurs%20erreurs%20se%20sont%20produites.%3CBR%20%2F%3EAu%20caract%C3%A8re%20Ligne%3A1%20%3A%201%3CBR%20%2F%3E%2B%20Add-RdsAccount%20-DeploymentUrl%20%22https%3A%2F%2Frdbroker.wvd.microsoft.com%22%3CBR%20%2F%3E%2B%20~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~%3CBR%20%2F%3E%2B%20CategoryInfo%20%3A%20NotSpecified%3A%20(%3A)%20%5BAdd-RdsAccount%5D%2C%20AggregateException%3CBR%20%2F%3E%2B%20FullyQualifiedErrorId%20%3A%20System.AggregateException%2CMicrosoft.RDInfra.RDPowershell.Context.AddRdsAccount%3C%2FPRE%3E%3CP%3EI%20solved%20the%20name%20of%20the%20site%20well%2C%20the%20%22consents%22%20did%20not%20bother%20me%20on%20the%20holding%20or%20I%20wish%20to%20deploy%20the%20WVD%2C%20and%20I%20am%20well%20%22TenantCreator%22.%3C%2FP%3E%3CP%3EThe%20first%20azure%20support%20told%20me%20that%20it%20did%20not%20support%20the%20preview%20and%20sent%20me%20here.%3C%2FP%3E%3CP%3ETenant%20ID%2025f527cb-a837-40a2-b467-7bd2ab69f27c%20application%20ID%20%3CSPAN%3E5a0aa725-4958-4b0c-80a9-34562e23f3b7%3C%2FSPAN%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EThank%20you%20for%20coming%20back%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-432744%22%20slang%3D%22en-US%22%3ERe%3A%20Erreur%20Add-RdsAccount%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-432744%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F316607%22%20target%3D%22_blank%22%3E%40Voxan%3C%2FA%3E%26nbsp%3B%3A%20When%20going%20through%20the%20consent%20flow%20it%20takes%20some%20time%20to%20register.%20Please%20try%20to%20follow%20this%20steps%20again%20and%20you%20should%20be%20successfull.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-437949%22%20slang%3D%22fr-FR%22%3ERe%3A%20error%20add-RdsAccount%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-437949%22%20slang%3D%22fr-FR%22%3E%3CP%3EHi%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F139744%22%20target%3D%22_blank%22%3E%40Eva%20Seydl%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20for%20your%20answer.%26nbsp%3B%3C%2FP%3E%3CP%3EI%20made%20again%20consent%20page%20for%20server%20app%20(thank%20you!%20A%3CSPAN%3Ead%20application%20has%20been%20successfully%20registered)%20and%20I'm%20still%20getting%20the%20error%20message%20in%20PS%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EI%20made%20another%20more%20consent%20this%20time%20for%20both%20Server%20%26amp%3B%20client%20app%2C%20and%20I'm%20still%20getting%20the%20error%20message%20in%20PS%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EI%20then%20checked%20if%20I%20was%20always%20a%20Tenantcreator.%20My%20account%20appeared%202%20times%2C%20one%20default%2C%20and%20one%20Tenantcreator.%20I%20tried%20to%20update%20default%20to%20Tenantcreator%20and%20it%20failed%20wich%20was%20expected.%20I%20deleted%20the%20Tenantcreator%20account%20and%20then%20updated%20the%20default%20account%20to%20Tenantcreator%20with%20success.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EBut%20I'm%20still%20getting%20the%20same%20error%20message%20in%20PS....%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EThanks%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-468759%22%20slang%3D%22en-US%22%3ERe%3A%20Erreur%20Add-RdsAccount%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-468759%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F316607%22%20target%3D%22_blank%22%3E%40Voxan%3C%2FA%3E%26nbsp%3B%3A%20Two%20questions%3A%3C%2FP%3E%0A%3CP%3E-%20Are%20you%20logging%20in%20with%20a%20user%20or%20service%20principal%3F%3C%2FP%3E%0A%3CP%3E-%20Is%20it%20sourced%20from%20that%20Azure%20AD%20tenant%3F%20Or%20is%20it%20a%20guest%20(B2B%20user)%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-468859%22%20slang%3D%22en-US%22%3ERe%3A%20Erreur%20Add-RdsAccount%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-468859%22%20slang%3D%22en-US%22%3E%3CP%3EHi%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F305776%22%20target%3D%22_blank%22%3E%40christianmontoya%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20logging%20with%20a%20user%20interactively%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20user%20is%20not%20sourced%20from%20the%20tenant%20i'm%20trying%20to%20configure%20WVD.%3C%2FP%3E%3CP%3EThe%20user%20is%20at%20first%20attached%20to%20my%20local%20company%20AD%20and%20the%20AAD%20tenant%20linked%20is%20not%20used.%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20are%20using%20a%20development%20tenant%20for%20our%20NAV%2FBC%20developers%2C%20wich%20is%20the%20one%20where%20i'm%20trying%20to%20configure%20WVD.%26nbsp%3B%3C%2FP%3E%3CP%3ESince%20the%20last%20answer%20i%20made%20i%20also%20tried%20this%20%3A%20create%20a%20new%20tenant%2C%20consent%20apps%2C%20tenantowner%20role%2C%20and%20ran%20the%20commands%20from%20a%20new%20win2k19%20azure%20VM.%20Still%20without%20success%20and%20same%20error%20message.%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-482954%22%20slang%3D%22en-US%22%3ERe%3A%20Erreur%20Add-RdsAccount%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-482954%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F316607%22%20target%3D%22_blank%22%3E%40Voxan%3C%2FA%3E%20%3A%20Thanks%20for%20your%20patience.%20Can%20you%20try%20performing%20the%20same%20operations%20but%20with%20a%20user%20who%26nbsp%3B%3CSTRONG%3Eis%26nbsp%3B%3C%2FSTRONG%3Esourced%20from%20the%20Azured%20AD%20that%20you're%20trying%20to%20create%20a%20Windows%20Virtual%20Desktop%20tenant%20for%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E
Voxan
New Contributor

Bonjour, 

Je souhaite mettre en place WVD pour un client dès qu'il sort de la preview, mais je n'arrive pas à déjà le mettre en place sur un de mes tenant pour un problème qui j'imagine est simple. J'ai lu les erreurs rencontrées qui sont toutes après l'étape ou je bloque.

Je m'appuie sur https://docs.microsoft.com/en-us/azure/virtual-desktop/tenant-setup-azure-active-directory 

 

Je bloque sur Add-RdsAccount -DeploymentUrl "https://rdbroker.wvd.microsoft.com" qui me renvoie une erreur (module installé version 1.0.1.11)

PS C:\WINDOWS\system32> Install-Module -Name Microsoft.RDInfra.RDPowerShell
PS C:\WINDOWS\system32> Import-Module -Name Microsoft.RDInfra.RDPowerShell
PS C:\WINDOWS\system32> Add-RdsAccount -DeploymentUrl "https://rdbroker.wvd.microsoft.com"
Add-RdsAccount : Une ou plusieurs erreurs se sont produites.
Au caractère Ligne:1 : 1
+ Add-RdsAccount -DeploymentUrl "https://rdbroker.wvd.microsoft.com"
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (:) [Add-RdsAccount], AggregateException
+ FullyQualifiedErrorId : System.AggregateException,Microsoft.RDInfra.RDPowershell.Context.AddRdsAccount

Je résouds bien le nom du site, les "consent" ne m'ont pas posé soucis sur le tenant ou je souhaite déployer le WVD, et je suis bien "TenantCreator".

Le support premier Azure m'a répondu qu'il ne faisaient pas de support sur les preview et m'ont envoyé ici.

Tenant ID 25f527cb-a837-40a2-b467-7bd2ab69f27c Application ID 5a0aa725-4958-4b0c-80a9-34562e23f3b7 

Merci de votre retour

 

5 Replies

@Voxan : When going through the consent flow it takes some time to register. Please try to follow this steps again and you should be successfull.

Hi @Eva Seydl 

Thanks for your answer. 

I made again consent page for server app ( Thank You! AAD Application has been successfully registered) and i'm still getting the error message in PS

I made another more consent this time for both server & client app, and i'm still getting the error message in PS

I then checked if i was always a Tenantcreator. My account appeared 2 times, one default, and one Tenantcreator. I tried to update default to Tenantcreator and it failed wich was expected. I deleted the Tenantcreator account and then updated the default account to Tenantcreator with success.

But i'm still getting the same error message in PS....

Thanks

@Voxan : Two questions:

- Are you logging in with a user or service principal?

- Is it sourced from that Azure AD tenant? Or is it a guest (B2B user)?

Hi @christianmontoya 

I'm logging with a user interactively 

The user is not sourced from the tenant i'm trying to configure WVD.

The user is at first attached to my local company AD and the AAD tenant linked is not used. 

We are using a development tenant for our NAV/BC developers, wich is the one where i'm trying to configure WVD. 

Since the last answer i made i also tried this : create a new tenant, consent apps, tenantowner role, and ran the commands from a new win2k19 azure VM. Still without success and same error message. 

Thanks

@Voxan : Thanks for your patience. Can you try performing the same operations but with a user who is sourced from the Azured AD that you're trying to create a Windows Virtual Desktop tenant for?

Related Conversations
Extentions Synchronization
Deleted in Discussions on
3 Replies
Tabs and Dark Mode
cjc2112 in Discussions on
36 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies