Home

Deployment Windows Virtual Desktop

%3CLINGO-SUB%20id%3D%22lingo-sub-838434%22%20slang%3D%22en-US%22%3EDeployment%20Windows%20Virtual%20Desktop%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-838434%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20deploy%20in%20an%20existing%20environment%20where%20all%20outgoing%20traffic%20is%20over%20a%20proxy.%3CBR%20%2F%3Ewe%20use%20a%20custom%20image%20which%20has%20the%20proxy%20settings%20in%20it.%20However%20(if%20I'm%20correct)%3CBR%20%2F%3EI%20think%20WVD%20tries%20to%20download%20the%20configuration.zip%20with%20the%20local%20system%20account%20so%3CBR%20%2F%3EI%20made%20sure%20that%20that%20account%20can%20access%20and%20download%20the%20configuration.zip.%3CBR%20%2F%3EI%20tested%20that%20by%20logging%20in%20to%20the%20RDS%20session%20host%2C%20ran%20IE%20as%20local%20system%20and%20then%20access%20the%20url.%20that%20worked.%3CBR%20%2F%3EHowever%20when%20WVD%20'does'%20the%20deployment%20then%20it%20still%20fails.%3CBR%20%2F%3EIs%20there%20a%20way%20to%20work%20around%20this%20issue%20or%20a%20way%20to%20make%20sure%20the%20download%20is%20started%20with%20the%20correct%20proxy%20settings%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-840552%22%20slang%3D%22en-US%22%3ERe%3A%20Deployment%20Windows%20Virtual%20Desktop%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-840552%22%20slang%3D%22en-US%22%3E%3CP%3ECan%20anyone%20from%20Microsoft%20reply%20to%20this%20please%3F%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F403858%22%20target%3D%22_blank%22%3E%40Ramon1986%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-848447%22%20slang%3D%22en-US%22%3ERe%3A%20Deployment%20Windows%20Virtual%20Desktop%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-848447%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20eventually%20got%20it%20fixed.%20The%20process%20responsible%20for%20downloading%20the%20configuration.zip%20is%20the%20Azure%20VM%20Agent%20which%20runs%20under%20local%20system.%20We%20made%20the%20local%20system%20aware%20of%20our%20proxy%20config%20by%20changing%20the%20DeFaultConnectionSettings%20key%20in%26nbsp%3BSOFTWARE%5CMicrosoft%5CWindows%5CCurrentVersion%5CInternet%20Settings%5CConnections.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F193408%22%20target%3D%22_blank%22%3E%40Marcel%20A'%20Campo%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Ramon1986
Occasional Visitor

We deploy in an existing environment where all outgoing traffic is over a proxy.
we use a custom image which has the proxy settings in it. However (if I'm correct)
I think WVD tries to download the configuration.zip with the local system account so
I made sure that that account can access and download the configuration.zip.
I tested that by logging in to the RDS session host, ran IE as local system and then access the url. that worked.
However when WVD 'does' the deployment then it still fails.
Is there a way to work around this issue or a way to make sure the download is started with the correct proxy settings?

2 Replies

Can anyone from Microsoft reply to this please? 

 

@Ramon1986 

We eventually got it fixed. The process responsible for downloading the configuration.zip is the Azure VM Agent which runs under local system. We made the local system aware of our proxy config by changing the DeFaultConnectionSettings key in SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\Connections.

 

@Marcel A' Campo 

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
35 Replies
Extentions Synchronization
ChirmyRam in Discussions on
3 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
29 Replies