SOLVED
Home

Constant delay that makes WVD unusable

%3CLINGO-SUB%20id%3D%22lingo-sub-853595%22%20slang%3D%22en-US%22%3EConstant%20delay%20that%20makes%20WVD%20unusable%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-853595%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20gone%20through%20all%20the%20steps%20to%20provision%20a%20host%20pool%20called%20Desktop.%20My%20tenant%20is%20Virtual%20Desktop%20and%20I%20have%20one%20session%20host%20called%20WVD-VM-0%20which%20is%20a%20D4s_v3%20instance.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20I%20RDP%20directly%20into%20WVD-VM-0%20the%20performance%20is%20perfect%20and%20normal.%20However%20when%20using%20the%20Remote%20Desktop%20app%20or%20the%20web%20client%20I%20experience%20a%20constant%20delay%20of%20perhaps%20up%20to%20500ms.%20Typing%2C%20moving%20windows%2C%20drawing%20in%20paint%20etc.%20is%20all%20significantly%20delayed.%20Either%20the%20encoding%20or%20there%20is%20input%20lag%20or%20constant%20networking%20lag.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20problem%20is%20not%20our%20network%2C%20we%20have%20a%20gigabit%20fiber%20link%20and%20I%20have%20tried%20from%20multiple%20other%20locations%20and%20this%20delay%20always%20occurs.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20connection%20quality%20always%20says%20'Poor'%20in%20the%20Remote%20Desktop%20application%2C%20again%20it%20doesn't%20matter%20where%20I%20run%20it%20or%20on%20what%20type%20of%20internet%20connection.%3CBR%20%2F%3E%3CBR%20%2F%3EThis%20has%20been%20provisioned%20in%20the%20Australia%20East%20region.%20I%20have%20read%20that%20the%20control%20plane%20is%20currently%20in%20the%20US%20East%202%20region.%20Does%20this%20mean%20the%20session%20is%20routed%20to%20that%20region%20and%20then%20back%20again%3F%20This%20would%20explain%20a%20500ms%20delay%20in%20Australia.%20Any%20help%20would%20be%20gratefully%20appreciated.%20I%20want%20to%20use%20WVD%20for%20our%20small%20non-profit%20of%2027%20employees%20(even%20though%20it%20is%20still%20in%20preview)%20but%20the%20latency%20is%20too%20high%20to%20be%20usable.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-854907%22%20slang%3D%22en-US%22%3ERe%3A%20Constant%20delay%20that%20makes%20WVD%20unusable%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-854907%22%20slang%3D%22en-US%22%3E%3CP%3E%26nbsp%3BYou%20are%20right.%20The%20WVD%20control%20plane%20is%20located%20in%20east%20us%20including%20the%20the%20rd%20gateways.%20All%20session%20traffic%20is%20routed%20through%20the%20rd%20gateways.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAfter%20GA%20of%20the%20WVD%20service%20rd%20gateways%20will%20be%20deployed%20in%20all%20azure%20locations%20and%20the%20session%20traffic%20is%20routed%20through%20this%20gateways.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EYou%20can%20try%20to%20mark%20your%20host%20pool%20as%20validation%20pool%20to%20get%20the%20most%20recent%20service%20updates%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fvirtual-desktop%2Fcreate-validation-host-pool%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fvirtual-desktop%2Fcreate-validation-host-pool%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EClaus%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-856414%22%20slang%3D%22en-US%22%3ERe%3A%20Constant%20delay%20that%20makes%20WVD%20unusable%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-856414%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F192194%22%20target%3D%22_blank%22%3E%40Claus%20Schwemmlein%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20for%20the%20confirmation%20much%20appreciated.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Deleted
Not applicable

I have gone through all the steps to provision a host pool called Desktop. My tenant is Virtual Desktop and I have one session host called WVD-VM-0 which is a D4s_v3 instance.

 

If I RDP directly into WVD-VM-0 the performance is perfect and normal. However when using the Remote Desktop app or the web client I experience a constant delay of perhaps up to 500ms. Typing, moving windows, drawing in paint etc. is all significantly delayed. Either the encoding or there is input lag or constant networking lag.

 

The problem is not our network, we have a gigabit fiber link and I have tried from multiple other locations and this delay always occurs.

 

The connection quality always says 'Poor' in the Remote Desktop application, again it doesn't matter where I run it or on what type of internet connection.

This has been provisioned in the Australia East region. I have read that the control plane is currently in the US East 2 region. Does this mean the session is routed to that region and then back again? This would explain a 500ms delay in Australia. Any help would be gratefully appreciated. I want to use WVD for our small non-profit of 27 employees (even though it is still in preview) but the latency is too high to be usable.

2 Replies
Highlighted
Solution

 You are right. The WVD control plane is located in east us including the the rd gateways. All session traffic is routed through the rd gateways.

 

After GA of the WVD service rd gateways will be deployed in all azure locations and the session traffic is routed through this gateways.

 

You can try to mark your host pool as validation pool to get the most recent service updates:

 

https://docs.microsoft.com/en-us/azure/virtual-desktop/create-validation-host-pool

 

Claus

 

 

@Claus Schwemmlein 

 

Thanks for the confirmation much appreciated.

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
46 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
29 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
13 Replies